This Software and Documentation are provided “as is” and without express or limited warranty of any kind by either MicroStrategy, Inc. or anyone who has been involved in the creation, production, or distribution of the Software or Documentation, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The entire risk as to the quality and performance of the Software and Documentation is with you. Should the Software or Documentation prove defective, you (and not MicroStrategy, Inc. or anyone else who has been involved with the creation, production, or distribution of the Software or Documentation) assume the entire cost of all necessary servicing, repair, or correction. Some states do not allow the exclusion of implied warranties, so the above exclusion may not apply to you.

In no event will MicroStrategy, Inc. or any other person involved with the creation, production, or distribution of the Software be liable to you on account of any claim for damage, including any lost profits, lost savings, or other special, incidental, consequential, or exemplary damages, including but not limited to any damages assessed against or paid by you to any third party, arising from the use, inability to use, quality, or performance of such Software and Documentation, even if MicroStrategy, Inc. or any such other person or entity has been advised of the possibility of such damages, or for the claim by any other party. In addition, MicroStrategy, Inc. or any other person involved in the creation, production, or distribution of the Software shall not be liable for any claim by you or any other party for damages arising from the use, inability to use, quality, or performance of such Software and Documentation, based upon principles of contract warranty, negligence, strict liability for the negligence of indemnity or contribution, the failure of any remedy to achieve its essential purpose, or otherwise. The entire liability of MicroStrategy, Inc. and your exclusive remedy shall not exceed, at the option of MicroStrategy, Inc., either a full refund of the price paid, or replacement of the Software. No oral or written information given out expands the liability of MicroStrategy, Inc. beyond that specified in the above limitation of liability. Some states do not allow the limitation or exclusion of liability for incidental or consequential damages, so the above limitation may not apply to you.

Copyright © 2000, MicroStrategy Incorporated. All rights reserved.

The information contained in this manual (the Documentation) and the Software are copyrighted and all rights are reserved by MicroStrategy, Inc. MicroStrategy, Inc. reserves the right to make periodic modifications to the Software or the Documentation without obligation to notify any person or entity of such revision. Copying, duplicating, selling, or otherwise distributing any part of the Software or Documentation without prior written consent of an authorized representative of MicroStrategy, Inc. are prohibited. U.S. Government Restricted Rights. It is acknowledged that the Software and Documentation were developed at private expense, that no part is public domain, and that the Software and Documentation are Commercial Computer Software provided with RESTRICTED RIGHTS under Federal Acquisition Regulations and agency supplements to them. Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(1)(iii) of the Rights in Technical Data and Computer Software clause at DFAR 252.227-7013 et. seq. or subparagraphs (c)(1) and (2) of the Commercial Computer Software—Restricted Rights at FAR 52.227-19, as applicable. Contractor is MicroStrategy, Inc., 8000 Towers Crescent Drive, Vienna, Virginia 22182. Rights are reserved under copyright laws of the United States with respect to unpublished portions of the Software.

Contents

Report Designer Overview 11

Section I  Concepts 1

Chapter 1  Templates 3
Template layouts 3
Template object placement 4
To learn about... 5

Chapter 2  Filters 7
Filter operators 8
  What is an operator? 8
  Logical operators 8
  Comparison operators 11
  Rank and percent operators 12
  Pattern operators 13
Qualification types 13
  Attribute qualification 13
  Metric qualification 16
  Filter qualification 19
  Advanced qualification 20
Relationship filtering 21
  Relationship filtering syntax 21
To learn about... 23

Chapter 3  Metrics 25
Metric types 25
  Simple aggregation metrics 25
  Nested aggregation metrics 26
  Compound metrics 27
Metric composition 28
Metric operators and delimiters 29
Metric aggregation 30
  Subtotals 30
    Applying subtotals to a metric 31
Metric Editor: general capabilities 32
Metric Editor: menu capabilities 32
To learn about... 32

Chapter 4  Reports 35
Designing reports 35
Filters 36
Template 36
Customizing reports 37
  Sorting 37
  Wordwrap 37
  Autofit 37
  Banding formatting options 38
  Metric properties formatting options 38
  Autostyles 38
  Page-by 38
  View long name 39
  Lock row headers 39
  Lock column headers 39
Report limits 40
To learn about... 40

Chapter 5  Prompts 41
Properties 41
Options 42
  Filter definition prompts 42
  Object prompts 44
  Value prompts 44
  Level prompts 45
To learn about... 45

Chapter 6  Custom Groups 47
Custom group elements 48
  Custom group element headers 49
  Qualification types 49
To learn about... 51

Chapter 7  Consolidations 53
Consolidation elements 54
  Elements of the same attribute 54
  Expressions of consolidation elements 55
  Elements from unrelated attributes 55
  Import elements 55
Evaluation order 56
To learn about... 56

Chapter 8  Documents 57
Document layout 57
Advanced concepts: XML and XSL 58
  XML 58
  XSL 59
Section II   Interface 61

Chapter 9   Template Editor 63
Template Editor layout 64
Template Editor toolbar and menu options 65

Chapter 10   Filter Editor 69
Filter Editor layout 70
   Filter definition 70
Filter Editor toolbar and menu options 72

Chapter 11   Metric Editor 73
Metric Editor layout 74
The Formula tab 74
   General 75
   Tab components 77
   Tab usage 77
The Subtotals tab 80
   General 80
   Tab components 81
   Tab usage 81
   Subtotals at runtime 82
Unique menu options 83
   View menu: Show Dimensionality Properties 84
   View menu: Show/Hide Function Parameters 84
   View menu: Object Browser 84
   View menu: Refresh 84
   Tools menu: Formatting 84
   Tools menu: Metric Join Type 86
   Tools menu: Advanced Settings/VLDB Properties 86
   Tools menu: Advanced Settings/Metric Join Type 87

Chapter 12   Report Editor 89
Report Editor layout 90
   Filter 90
   Template 90
Report Editor toolbar and menu options 91

Chapter 13   The Prompt Generation Wizard 97
Prompt Generation Wizard layout 98
   The primary page 98
   Prompt definition pages 99
Defining prompts 99
  Filter definition prompts: Choose from all attributes in a hierarchy 99
  Filter definition prompts: Qualify on an attribute 100
  Filter definition prompts: Choose from an attribute element list 100
  Filter definition prompts: Qualify on a metric 101
Object prompts 102
Value prompts 102
Level (dimensionality) prompts 103

Chapter 14 Custom Group Editor 105
Custom Group Editor layout 106
  Custom Group Definition 106
  Custom Group Options 107
  Attribute Qualification 107
  Metric Qualification 107
  Filter Qualification 108
  Advanced Qualification 108
  Custom Group Banding Qualification 108

Chapter 15 Consolidation Editor 109
Consolidation Editor layout 110
  Elements for this consolidation 110
  Selected element 110
Consolidation Editor toolbar and menu options 111

Chapter 16 Document Editor 113
Document Editor layout 114
  Document Content 114
  Layout 115
Document Editor toolbar and menu options 117

Section III How do I...? 119

Chapter 17 Templates 121
Add pages to the template 121
Change the evaluation order from the Template Editor 122
Clear report limits from the Template Editor 122
Create a report limit from the Template Editor 123
Create a template using the Template Editor 124
Hide pages 124
Lock column headers 125
Lock row headers 125
Merge header cells on a template 126
Modify a template 126
Modify report limits from the Template Editor 127
Open the Report Limit Editor 128
Restore metric defaults from the Template Editor 128
Select autostyles 129
Set banding options 129
Set metric formatting options 130
Set the join type from the Template Editor 131
Sort the data from the Template Editor 131
View the attribute forms in the template 132
View VLDB properties 132
View or modify attribute options 133

Chapter 18 Filters 135
Access the Level Editor 135
Activate advanced qualification options 136
Allow view of buttons for simple prompts 136
Change the logical operator for a filter with multiple qualifications 137
Create a filter 137
Create a metric prompt qualification 138
Create a metric qualification 138
Create a simple prompt metric qualification 139
Create an advanced qualification using the Filter Editor 140
Create an attribute qualification 142
Create an attribute-to-attribute qualification 143
Create an attribute qualification prompt 144
Create a filter qualification 145
Create a filter qualification prompt 146
Create an operator prompt 147
Set the break by for a metric’s rank operator 149
Set default filter options 150
Trim leading spaces of a value 151
Use the Level Editor to calculate output levels 151

Chapter 19 Metrics 153
Create a metric 153
Display or hide the (metric) Object Browser 155
Enable subtotals using the Metric Editor 156
Modify an existing metric 156
Select a join type for a metric 157
Select an advanced function for a metric 158
Update a metric’s displayed values 158
Use metric formatting functions: fonts 159
Use metric formatting functions: numbers 160
Use metric formatting functions: patterns 161
View a metric’s VLDB settings 162
Chapter 20  Reports 165

Add a filter to a report 165
Add a page to a report 166
Add a template to a report 167
Apply banding to a report 167
Apply metric formatting options to a report 169
Change the evaluation order from the Report Editor 169
Clear report limits 169
Clear the sorts for a report 170
Create a report 170
Create a report limit 170
Create a template using the Report Editor 171
Embed a template in a report 173
Link a template to a report 174
Merge header cells on a report 174
Modify the attribute display 174
Modify the Page Setup options 175
Modify the report limits 180
Open the Report Limit Editor 180
Preview a report before printing 181
Remove a page field from a report 181
Restore metric defaults from the Report Editor 182
Run a report 182
Set the default presentation of graph report results 183
Select an autostyle for the report format 183
Set the default presentation of grid report results 183
Set the join type using the Report Editor 184
Sort the data in a report using the Report Editor 185
View long names in the Report Editor 185
View a report as a graph 186
View a report as a grid 186
View the report limit settings from the Report Editor 186

Chapter 21  Prompts 189

Create a “Choose from all attributes in a hierarchy” prompt 189
Create a “Choose from an attribute element list” prompt 191
Create a Level prompt 192
Create a “Qualify on a metric” prompt 194
Create a “Qualify on an attribute” prompt 195
Create a Value prompt 197
Create an Object prompt 199
Select a prompt type 200
Chapter 22  Custom Groups  203
Add a custom group to a report  203
Create a custom group  204
Create a custom group banding qualification using the Custom Group Editor  205
Create a metric qualification using the Custom Group Editor  206
Create a shortcut to a filter using the Custom Group Editor  207
Create an advanced qualification using the Custom Group Editor  208
Create an attribute qualification using the Custom Group Editor  210
Name custom group element bands  211
Rename a custom group element  212
Set the default custom group options  213
Show display options for a custom group element header  213

Chapter 23  Consolidations  215
Create a consolidation  215
Create a new consolidation element  216
Create an element expression  216
Import a consolidation element  217
Validate a consolidation expression  217

Chapter 24  Documents  219
Add a report to a document  219
Add or remove a bulleted list in a document  220
Add or remove a numbered list in a document  220
Change the font color in a document  221
Change the highlight color in a document  221
Choose a different XSL  221
Create a hyperlink in a document  222
Create a table in a document  222
Decrease the indent in a document  223
Edit the HTML in a document  223
Format the font in a document  224
Indent text or images in a document  224
Insert an image in a document  224
Insert or delete table cells in a document  225
Insert or delete table columns in a document  225
Insert or delete table rows in a document  226
Merge table cells in a document  226
Modify the report object to grid or graph  227
Preview a document  227
Set default document options  227
Split table cells in a document  228
View hidden elements  228
View hidden table borders  228
View the HTML source code for a document  228
Section IV  Appendixes 231

Appendix A  Project Preferences 233

Project Preferences layout 233
  Home Page tab 233
  Reports tab 234
  Editors tab 235
  Advanced tab 236

Appendix B  XSL Stylesheets 237

Appendix C  Analytical Functions in MicroStrategy 7 247

Basic Functions 247
OLAP Functions 247
Statistic Aggregate Functions 248
Rank Functions 248
Advanced Statistic Functions 248
Mathematical Functions 250
Financial Functions 251

Index 255
INTRODUCTION

Report Designer
Overview

As the report designer of a decision support tool, you are responsible for the design, implementation, or distribution of your company’s business reports or reporting environment.

You work closely with analysts and other end users to gather reporting requirements. These requirements help you work backwards to determine which reports need to be published to your user community.

Before you can design reports, you must design and create the building blocks that comprise reports. There are three objects that fall into this category:

• templates
• filters
• metrics

Some of these objects generics, used in a number of different reports; others are created specifically for one or two reports.

Once you have analyzed requirements and set objectives, you create and publish reports. These reports are viewed by the analyst, and based on that individual’s needs, you may have to modify or create additional reports.

Organization

The information in this guide is divided into three main sections:

• Concepts
  This section provides you with the key concepts about the objects you are working with.

• Interface
  Refer to this section for interface-specific information. This section explains the interfaces you use to create such objects as reports, metrics, templates and filters.
• How do I
  This is where the procedural information is found. This section provides the answers to the how do I questions you will encounter while using MicroStrategy 7.
Topics for this section include:

- Templates
- Filters
- Metrics
- Reports
- Prompts
- Custom Groups
- Consolidations
- Documents
A template defines the layout of general categories of information in a report. In a template, you specify the information you want to retrieve from the data warehouse and the way you want it to be displayed in each of the modes of reporting.

This section provides conceptual information on templates. For steps, such as instructions on how to create a template, refer to the following How do I...? section:

Templates

Template layouts

A template specifies which information is retrieved and how the results are displayed. The layout of a template can be crosstab or tabular:

- A crosstab layout is useful for multidimensional analysis (for example, a report with day and location information in the rows, and products and corresponding sales information in the columns).

<table>
<thead>
<tr>
<th></th>
<th>South</th>
<th>North</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Atlanta</td>
<td>Miami</td>
</tr>
<tr>
<td>Sales ($)</td>
<td>100</td>
<td>200</td>
</tr>
</tbody>
</table>

- A tabular layout is useful for simple lists of information (for example, a column of days, a column of products, and a column of locations, followed by corresponding columns of sales figures).

<table>
<thead>
<tr>
<th>Region</th>
<th>Store</th>
<th>Sales ($)</th>
</tr>
</thead>
<tbody>
<tr>
<td>South</td>
<td>Atlanta</td>
<td>100</td>
</tr>
<tr>
<td>South</td>
<td>Miami</td>
<td>200</td>
</tr>
<tr>
<td>North</td>
<td>Boston</td>
<td>300</td>
</tr>
<tr>
<td>North</td>
<td>New York</td>
<td>400</td>
</tr>
</tbody>
</table>
Each object placed on a template becomes a row or column header that organizes the data when the report results are displayed. The empty cells below the headers in the template are placeholders for the actual data. During the report execution process, filtered data is placed into the appropriate template location, based on the position of these headers.

**Template object placement**

Templates may contain any of the following objects, in any unique combination:

<table>
<thead>
<tr>
<th>Object</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attribute</strong>:</td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td>Represents a specific level of data calculation or aggregation.</td>
<td></td>
</tr>
<tr>
<td>Examples:</td>
<td></td>
</tr>
<tr>
<td>• Region</td>
<td></td>
</tr>
<tr>
<td>• Week</td>
<td></td>
</tr>
<tr>
<td>• Department</td>
<td></td>
</tr>
<tr>
<td><strong>Consolidation</strong>: Custom grouping of attributes. Allows for “row math” between attributes.</td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td>Examples:</td>
<td></td>
</tr>
<tr>
<td>• Holiday colors</td>
<td></td>
</tr>
<tr>
<td>• Actual vs. Planned Sales</td>
<td></td>
</tr>
<tr>
<td><strong>Hierarchy</strong>:</td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td>Enables dynamic substitution of attributes in a report.</td>
<td></td>
</tr>
<tr>
<td>Examples:</td>
<td></td>
</tr>
<tr>
<td>• Geography</td>
<td></td>
</tr>
<tr>
<td>• Product</td>
<td></td>
</tr>
<tr>
<td>• Time</td>
<td></td>
</tr>
</tbody>
</table>
To learn about...

...template-related tasks you can perform using MicroStrategy Desktop, please see the Templates chapter of the How do I section in this guide.

...the Template Editor, please see the Template Editor chapter of the Interfaces section in this guide.

<table>
<thead>
<tr>
<th>Object</th>
<th>Rules</th>
</tr>
</thead>
</table>
| **Metric**: A calculation built from facts in the data warehouse. Examples:  
  • Total Sales ($)  
  • Profit ($)  
  • Inventory (units) | Can be placed in a row, column or as a page.  
  All the metrics are grouped together and bound to one axis. You cannot have a metric as both a row and a column. |
| **Custom Group**: Groupings of elements that allow for inter-row mathematical operations. Examples:  
  • Northeast Athletics  
  • South Casual Clothing  
  • Top Selling Stores  
  • Best Selling Clothes | Can be placed in a row, column or as a page. |
| **Object Prompt**: Allows you to select, at report run-time, specific objects. Examples:  
  • Attribute prompt  
  • Metric prompt  
  • Consolidation  
  • Custom Group | Can be placed in a row, column or as a page.  
  You cannot drop an object prompt that returns metrics on the pages axis if the column already contains metrics. |
A filter specifies the conditions that the data must meet in order to be included in the report results. For example, consider the following diagram which shows a list of last names filtered with three different filtering conditions:

Each filter definition above returns a different result set. Depending upon what information your users need in a report, you need to know how to design the correct filter accordingly.

This section provides conceptual information on filters. For instructions on how to create a filter, refer to the following How do I section:

Filters
Filter operators

The following types of operators are used when specifying filtering conditions:

- logical
- comparison
- rank and percent
- pattern

What is an operator?

Operators are used to manipulate individual data items and data sets. These data items are called operands or arguments. Operators are represented by special characters or by keywords. For example, multiplication is represented by an asterisk (*) and division is represented by a slash (/). Filtering conditions are expressions built from column names, constants, subexpressions, and operators. For example, consider the following filtering definition:

Store_ID = 1

The definition above contains an attribute form (Store_ID), a comparison operator (=), and a numeric constant (1).

Logical operators

Logical operators allow the application of certain conditions to two sets of items simultaneously. There are three basic logical operators:

- **union**: behaves as the inclusive term OR does in grammar. The union of two sets yields a TRUE value any time that either or both of the sets are represented by a true statement.
- **intersection**: behaves as the term AND does in grammar. The intersection of two sets yields a TRUE value only when both sets are represented by a true statement.
- **exclusion**: behaves as the term AND NOT does in grammar. When two sets are linked in this manner, their combination yields a TRUE value only when one set is represented by a true statement, the other set by a false statement.

The following tables show the combinations possible with each logical operator, and the value that each combination yields, using as an example the following attributes

\[A = \text{(customers located in the) Northeast region}\]
Logical union filter: A + B

Possible filter combinations resulting from the **union** of attributes A and B (customers that either are located in the Northeast region **OR** have purchased blankets) are as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Result Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TRUE</td>
<td>customers located in the Northeast region OR customers that purchased blankets</td>
</tr>
<tr>
<td>2</td>
<td>FALSE</td>
<td>customers that purchased blankets (but are not located in the Northeast region)</td>
</tr>
<tr>
<td>3</td>
<td>TRUE</td>
<td>customers located in the Northeast region (but have not purchased blankets)</td>
</tr>
<tr>
<td>4</td>
<td>FALSE</td>
<td>no display (customers that are neither located in the Northeast region nor purchased blankets)</td>
</tr>
</tbody>
</table>

Because a union of two sets yields a valid result if data corresponding to either of set is found, this filter causes display as shown in statements 1, 2, and 3.

Logical intersection filter: A * B

Possible filter combinations resulting from the **intersection** of attributes A and B (customers that are located in the Northeast region **AND** have purchased blankets) are as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Result Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TRUE</td>
<td>customers that are located in the Northeast region AND have purchased blankets</td>
</tr>
<tr>
<td>2</td>
<td>FALSE</td>
<td>no display (customers that purchased blankets but are not located in the Northeast region)</td>
</tr>
<tr>
<td>3</td>
<td>TRUE</td>
<td>no display (customers that are located in the Northeast region but have not purchased blankets)</td>
</tr>
<tr>
<td>4</td>
<td>FALSE</td>
<td>no display (customers that are neither located in the Northeast region nor purchased blankets)</td>
</tr>
</tbody>
</table>

**Filter operators**
Because an intersection of two sets yields a valid result only if data corresponding to both sets is found, this filter causes display as shown in statement 1, and in no other combination.

**Logical exclusion filter: A * NOT B**

Possible filter combinations resulting from the *not (and not) exclusion of an attribute (for example, B) (customers that are located in the Northeast region AND have not purchased blankets) are as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>NOT B</th>
<th>Result Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TRUE</td>
<td>customers who are located in the Northeast region AND have not purchased blankets</td>
</tr>
<tr>
<td>2</td>
<td>FALSE</td>
<td>no display (customers who have not purchased blankets AND are not located in the Northeast region)</td>
</tr>
<tr>
<td>3</td>
<td>TRUE</td>
<td>no display (customers that are located in the Northeast region AND have purchased blankets)</td>
</tr>
<tr>
<td>4</td>
<td>FALSE</td>
<td>no display (customers not located in the Northeast region who have purchased blankets)</td>
</tr>
</tbody>
</table>

The behavior of exclusive *not (and not) statements is the same as that of intersections—the combination yields a valid result only when data corresponding to the “included” set is found and data corresponding to the “excluded” set is not. This filter would cause display as shown in statement 1 and in no other combination.

**Logical exclusion filter: A + NOT B**

Possible filter combinations resulting from the + not (or not) exclusion of an attribute (for example, B) (customers that are located in the Northeast region OR have not purchased blankets) are as follows:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>Result Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TRUE</td>
<td>customers who are located in the Northeast region OR have not purchased blankets</td>
</tr>
</tbody>
</table>
The behavior of exclusive + not (or not) statements is the same as that of unions—the combination yields a valid result when either data corresponding to the “included” set is found or data corresponding to the “excluded” set is not. This filter would cause display as shown in statements 1, 2, and 3.

### Comparison operators

Comparison operators compare values. The values can be numbers, text strings, or expressions. The comparison operators are

- **Between**: Used to indicate corresponding lower and upper values. For example, Between 10 And 20 returns all values within the specified range for the selected metric or attribute form value.
- **Not between**: Used to indicate values that are not between a lower and upper value. For example, Not between 10 and 20 returns all values not between 10 and 20, such as 2 and 21.
- **Exactly**: Used to indicate a corresponding value. For example, Exactly 1 returns all values with a value of 1 for the selected metric.
- **Greater than**: Used to indicate corresponding values that are greater than the value indicated. For example, Greater than 10 returns values 11 or greater.
- **Greater than or equal to**: Used to indicate corresponding values that are greater than or equal to the value indicated. For example, Greater than or equal to 10 returns values 10 or higher.
- **Less than**: Used to indicate corresponding values that are less than the value indicated. For example, Less than 10 returns values 9 or less.
- **Less than or equal to**: Used to indicate corresponding values that are less than or equal to the value indicated. For example, Less than or equal to 10 returns values 10 or lower.
- **Different from**: Used to indicate values that are other than the value indicated. For example, Different from 10 returns all values that are not 10.
Rank and percent operators

The following operators are used to define metric qualifications. These operators are visible when you qualify on the Rank or Percent function.

- **Bottom**: Indicates a corresponding value. For example, Bottom 40 returns the 40 lowest values for the selected metric.

- **Closest to**: Indicates a corresponding value. For example, if you have a set of six unique values, Closest to 50% Top returns row three as a median. For non-unique values, the median location is determined in the same way, then all report rows that have the same value as the one at the median location are returned (not available for Rank).

- **Exclude top**: Used to indicate corresponding top values for rank and percent that will not be included in the result set. For example, Exclude top 10 returns all but the top 10 percent.

- **Exclude bottom**: Used to indicate corresponding bottom values for rank and percent that will not be included in the result set. For example, Exclude bottom 10 returns all but the bottom 10 percent.

- **Top**: Indicates a corresponding value. For example, Top 40 returns the 40 highest values for the selected metric.
Pattern operators

Pattern operators allow text strings to be compared. Pattern operators are case-sensitive. The following pattern operators are available in MicroStrategy Desktop:

- **Begins with**: Used to return a result set that starts with the specified letter or number. For example, Begins with J returns all values beginning with J, such as June.
- **Ends with**: Used to return a result set that ends with the specified letter or number. For example, End with r returns all values ending with r, such as September, and October.
- **Contains**: Used to return a result set that contains a specific value or expression. For example, Contains ua returns values that contain ua, such as January, and February.
- **Does not begin with**: Used to return a result set that does not start with the specified letter or number. For example, Does not begin with J returns only those values that do not begin with J, such as May, February, and October.
- **Does not end with**: Used to return a result set that does not end with the specified letter or number. For example, Does not end with R returns only those values that do not end with R, such as March, and April.
- **Does not contain**: Used to return a result set that does not contain a specific value or expression. For example, Does not contain ua returns only those values that do not contain ua, such as March, and May.

Qualification types

The qualification types are

- Attribute
- Metric
- Filter
- Advanced

Attribute qualification

Attribute qualifiers enable you to specify the condition for the attribute form that the attribute elements must satisfy in order to be included in the filter definition. For example, you can create an attribute qualification that qualifies on the attribute Month, so that the result set brings back only months beginning with the letter "J".
The following operators are available to create an attribute qualification using a numeric and date form:

- Between
- Exactly
- Greater than
- Greater than or equal to
- Less than
- Less than or equal to
- Different from
- Not between

For an explanation of these operators, refer to the section **Comparison operators** in this chapter.

You can add a value, a simple prompt, or an expression to your attribute qualifier.

<table>
<thead>
<tr>
<th>Select</th>
<th>Explanation</th>
<th>Example</th>
</tr>
</thead>
</table>
| Value        | Enter a numerical or string value, depending on the attribute form selected | Attribute form selected: Desc  
Attribute: Month  
Operator: Contains  
Value: M _ _  
Result set: May  

Attribute form selected: ID  
Attribute: Month  
Operator: Exactly  
Value: 10  
Result set: October |
| Simple prompt | Enter a simple value prompt that the user answers at run time | Attribute: Month  
Prompt: [for numeric value]  
Value: 5  
Qualification: Month Exactly 5  
Result set: May |
| Expression   | Enter a filter expression, or metric to metric, or metric to attribute form comparisons | ([ship date]@id < [date]@id + 1) |
Element list

You can specify distinct attribute element descriptions (for example, qualify the Region attribute to have Description equal to Northeast), distinct attribute element IDs (for example, qualify the Store attribute to have an ID less than 5), or distinct Elements (for example, qualify the Birthdate attribute to only display particular dates, such as 8/22/44, 8/22/45, and 8/22/46). You can specify distinct operators, values, simple prompts, expressions, or element lists for any attribute form you use. Element list allows you to qualify on specific elements of the attribute without needing to know the values for a certain form.

Element list with a prompt

To provide the analyst with more flexibility, you can also associate a prompt with an element list qualification. For example, instead of qualifying on Northeast Region, you can prompt on the region attribute to let the user pick from a list of region elements at runtime.

Single attribute qualification

A single attribute qualification allows you to qualify on an individual attribute. For example, you can qualify on the attribute Year, such that Year ID is Greater than 1997. If you add this qualification to a report, the results would bring back only the data for years 1998 or later.

Single attribute qualification with a prompt

You can also prompt the analyst to choose the value in which to qualify upon. For example, you can select to prompt on the attribute Category, where the form is Description, and the element value Exactly equals [electronics]. In this case, electronics would be the default value, but the analyst can choose another category at report run time.

Date qualification

Date qualification is used to display factual data associated with specific dates or days of the week, month, or year, based on the current date. You can qualify a static (fixed) or dynamic (changing) date. You can also prompt on a date qualification, again giving the analyst more flexibility in choosing the desired date at report run time.

Static dates

A static date is a fixed or un-changing date. For example, 8/25/67 is a static date.
Dynamic dates

Dynamic dates are a fixed set of dates or different ranges of dates that change through time. These dates are fixed offsets of the current date. For example, a dynamic date can be used in a report that examines sales in the previous two months. This would be represented as Today with an offset of two months. Dynamic date qualifications can be as specific as any of the following examples:

- an offset of 4 years, 3 months, 2 weeks, and 1 day from today
- Monday of this week
- Monday of this week with an offset of 2 days
- the 4th of this month
- the 4th Wednesday of this month
- May 5th of next year
- the 3rd Wednesday in May of this year

Attribute-to-attribute qualification

Attribute-to-attribute comparisons allows you to create reports that compare two attributes. For example, using attribute-to-attribute comparisons you can create a report that displays the orders that were shipped within a week of their order date, by comparing order date with ship date.

Metric qualification

Metric qualifiers enable you to restrict the metric values based on the value, rank or rank percentage. Metric qualifiers restrict the amount of data returned on a report by constraining the metrics. These metrics may or may not appear on the final report. For example, a store manager might want to see sales numbers for products whose current inventory levels fall below a certain level. The report would not, however, display the inventory figures for those products.

You can qualify on a particular function for the selected metric. The functions include:

- Metric value. The value you wish to qualify the metric on. For example, Metric value greater than or equal to 10, returns all values for that metric that are 10 or higher.
- Rank. The numeric rank of values. For example, Rank Top 40 returns the 40 highest values for the selected metric.
- Percent. Percentage of the values being ranked. For example, Percent Top 10 returns all values in the top 10% for the selected metric.
**Output level**

The output level is the final level you want the metric or relationship filter to evaluate to. This level may not necessarily be the same as the level of aggregation itself. For example, the output level of a report can be treated as the attribute level of the report itself, which may or may not be the same as the level of aggregation group by level of each metric in the report. However, if the level of aggregation is (~, +) then they are the same.

An example of a metric qualification output level follows:

Sum of Sales > 1 million

where the Sum of Sales metric is defined as

\[
\text{Sum(sales)} \{\text{Department}^*, ~, +\}
\]

Without output level, this expression would generate a list of departments from this qualification. In other words, this would produce a list of departments that have sales greater than one million dollars.

With output level set to report (not recommended), this expression would generate a list of template attributes from this qualification. Depending on what attributes are on the template, it could be store, region or even department whose department sales are greater than one million dollars.

You can also define output level as \{region\}, in which case this metric qualification would produce a list of regions that have department sales greater than one million dollars.

For more information on level of aggregation, or metrics in general, refer to the Concepts section

**Metrics**

**Break by**

Break by allows you to choose the attribute level at which to restart counting the rank or percentage for a metric. This level must be greater than or equal to the level of aggregation for the metric, as shown in the following example.
Example
You are given the following data:

<table>
<thead>
<tr>
<th>Region</th>
<th>Market</th>
<th>Store</th>
<th>Actual ($K) Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Baltimore</td>
<td>40</td>
</tr>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Philadelphia</td>
<td>30</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Boston</td>
<td>20</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Greenwich</td>
<td>10</td>
</tr>
</tbody>
</table>

If you specify **Break by Market**, the ranking counter is reset for each market (descending rank).

<table>
<thead>
<tr>
<th>Region</th>
<th>Market</th>
<th>Store</th>
<th>Actual ($K) Sales</th>
<th>Rank</th>
</tr>
</thead>
<tbody>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Baltimore</td>
<td>40</td>
<td>1</td>
</tr>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Philadelphia</td>
<td>30</td>
<td>2</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Boston</td>
<td>20</td>
<td>1</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Greenwich</td>
<td>10</td>
<td>2</td>
</tr>
</tbody>
</table>

If you specify “Break By Region”, then the ranking counter is reset for each region. In this example, there is only one region, so the counter is not reset.

<table>
<thead>
<tr>
<th>Region</th>
<th>Market</th>
<th>Store</th>
<th>Actual ($K) Sales</th>
<th>Rank</th>
</tr>
</thead>
<tbody>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Baltimore</td>
<td>40</td>
<td>1</td>
</tr>
<tr>
<td>Northeast</td>
<td>Mid-Atlantic</td>
<td>Philadelphia</td>
<td>30</td>
<td>2</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Boston</td>
<td>20</td>
<td>3</td>
</tr>
<tr>
<td>Northeast</td>
<td>New England</td>
<td>Greenwich</td>
<td>10</td>
<td>4</td>
</tr>
</tbody>
</table>
Continuation

Continuation allows you to extend the level of aggregation of a metric, giving you the flexibility to enhance the existing object without changing the object's original definition. Continuation is only available for upgraded filters that had a continuation defined before they were upgraded. The Continuation dialog is read only.

For example, assuming the level of aggregation is {market} and continuation is {store, year}, the following is true:

• **exclusive**: the result is {market, year} because we exclude the attribute (store) from the same hierarchy.

• **non-exclusive (or)**: the result is {market, store, year}, which is equivalent to {store, year}.

Filter qualification

Filter qualifiers allow you to qualify existing filters. For example, suppose you are a manager of a New England market, responsible for Boston, Providence and Greenwich stores. You have the filters “Stores in my Region” and “Women’s Clothing”, which are described by the following filter plans:

filter “Stores in my Region”:
[Store = “Boston” OR Store = “Greenwich” OR Store = “Providence”]
AND
filter “Women’s Clothing”:
[Class = “Blouses” OR Class = “Dresses”]

You also have a filter “All Days in Dec 94” that consists of a date range spanning all the days in the month of December 1994.

To study sales in these stores for these classes of women’s clothing in the month of December, you could use the following filter plan:

[“Stores in my Region” AND “Women’s Clothing” AND “All Days in Dec 94”]

This plan involves linking to the filters “Stores in my Region”, “Women’s Clothing”, and “All Days in Dec 94”. This linking is known as a **filter qualification**.
Advanced qualification

Advanced qualifiers allow you to create complex qualifications including custom expressions and joint element lists.

Custom expression

An advanced qualification allows you to create a custom expression to fit your particular needs. For example, you can create a relationship filter using the custom expression area of the advanced qualification window. For more information on relationship filtering, refer to the following topic in this chapter:

Relationship filtering

Please refer to the following appendix for more information on the syntax you need to know in order to create a custom expression:

Parser grammar Appendix

Joint element list

The joint element list allows you to choose attribute elements from different attributes in which to filter the report result set. Unlike the attribute qualification, it also allows you to join attribute elements and filter on that attribute result set. For example, if you choose the attributes Year and Store, you can further create a filter, using the joint element list, that allows you to filter on the following attribute elements:

<table>
<thead>
<tr>
<th>Year</th>
<th>Store</th>
</tr>
</thead>
<tbody>
<tr>
<td>1995</td>
<td>Baltimore</td>
</tr>
<tr>
<td>1995</td>
<td>Philadelphia</td>
</tr>
<tr>
<td>1995</td>
<td>Boston</td>
</tr>
<tr>
<td>1995</td>
<td>Greenwich</td>
</tr>
<tr>
<td>1996</td>
<td>Baltimore</td>
</tr>
<tr>
<td>1996</td>
<td>Philadelphia</td>
</tr>
<tr>
<td>1996</td>
<td>Boston</td>
</tr>
<tr>
<td>1996</td>
<td>Greenwich</td>
</tr>
</tbody>
</table>

As shown in the example, a joint element list allows you to filter not only on a particular year, but a particular store during that year.
Relationship filtering

Relationship filtering allows you to create a link between two attributes and place a filter upon that relationship. It allows you to create a set of elements from an attribute based on its relationship with another attribute. For example, relationship filtering allows you to create a report that could show you all the stores selling Nike shoes in the Washington, DC area, or all customers who have checking accounts but not saving accounts. Relationship filtering is a type of advanced qualification, created using the Custom Expression box of the Advanced Qualification window in the Filter Editor.

Relationship filtering syntax

Currently relationship filters are created using the Advanced Qualification dialog box in the Filter Editor. You must use the following syntax in that dialog box:

\[
\text{<relation; (filter qualification)>{list of output attributes}}
\]

where

- **relation** is a Fact, Table, or it can be Empty. The fact and table are the relationship between the attributes in Filtering Input and Output Level. The Relationship determines which table is used during SQL generation. Note: if the relationship is left empty, the schema is used to pick the appropriate table.
- **filter qualification** defines input filtering criteria. It consists of an attribute qualification, filter qualification, or metric qualification followed by a comma and an output level.
- **list of output attributes** is a comma-separated list of the attributes you want to filter on. The output level dictates the contents of the relationship filter output set.

For example, if you are creating a report that shows all stores selling Nike shoes in the DC area, the relationship filter syntax would look like this:

\[
\text{<[Fact Sales]; [Nike Shoes, Region]>{Stores}}
\]

where **Fact Sales** is the table name, **Nike Shoes** and **Region** are the filter qualification, and **Stores** is the attribute.
A VMall solution: Relationship filtering example—beer-making kit

**Scenario 1**

A company needs a list of catalogs that carry the item **Beer-Making Kit**. The relationship filtering syntax needed to extract this information is

\(<\text{REL\_CAT\_ITEM}; \text{(Item@Desc = "Beer-Making Kit"})\>{\text{Catalog}}\)

where Catalog is the template and Item\_Name = Beer-Making Kit is the filter.

**Scenario 2**

The company now needs a list of catalogs that carries the items **Bed Lounge** and **Beer-Making Kit**. To accomplish this, they would need to create two relationship filters, one for each item. Then they would need to apply the logical operator **AND** to group the sets of data from each of the relationship filters. The syntax would look like this:

\(<\text{REL\_CAT\_ITEM}; \text{Item@Desc = "Bed Lounge"})\>{\text{Catalog}}\)

AND

\(<\text{REL\_CAT\_ITEM}; \text{Item@Desc = "Beer-Making Kit"})\>{\text{Catalog}}\)

where Catalog is the template and Item\_Name = Bed Lounge and Item\_Name = Beer-Making Kit are the filters.

**Scenario 3**

The company now wants the same list of catalogs that carry the items **Bed Lounge** and **Beer-Making Kit**, but does not want to create two relationship filters.

To create one relationship filter that includes many items, they would need to apply the **IntersectIn** operator to create an attribute form qualification. The syntax would look like this:

\(<\text{REL\_CAT\_ITEM}; \text{Item@Desc} \text{Intersection} ("Bed Lounge", "Beer-Making Kit")\>{\text{Catalog}}\)

**Scenario 4**

The company also needs a list of catalogs that carry the items **Bed Lounge** but not **Beer-Making Kit**.
To accomplish this, they would need to create two relationship filters, one for each item. Then they would need to apply the logical operator AND NOT to eliminate the set of data they do not want—in this case, catalogs that carry the item **Beer-Making Kit**. The syntax would look like this:

```
<REL_CAT_ITEM; (Item@Desc = "Bed Lounge")>{Catalog}
AND NOT
<REL_CAT_ITEM; (Item@Desc = "Beer-Making Kit")>{Catalog}
```

---

**To learn about...**

...filter-related tasks you can perform using MicroStrategy Desktop, please see the Filter chapter of the How do I section in this guide.

...the Filter Editor, please see the Filter Editor chapter of the Interfaces section in this guide.
Metrics are analytical calculations performed against stored data to produce results that can then be either read as status material or analyzed for decision-making purposes.

You can define a metric within a report to specify what data you want to see displayed, or qualify a metric within an existing filter to limit the information shown.

Metric types

Metrics are report components that enable analytical calculations against warehouse data. Based on this definition, metrics can be categorized, according to how the analysis is performed, as belonging to one of the following types:

- simple aggregation metrics
- nested aggregation metrics
- compound metrics

The paragraphs that follow describe each of these metric types

Simple aggregation metrics

As the name implies, these are the simplest of metrics; metrics belonging to one of the other types use, in one form or another, simple aggregation metrics as part of their definition.
In their structure, simple aggregation metrics:

- are based on one or more metric functions
- include the specified level at which calculations are applied to the report
- may include conditions for applying calculations
- may include transformations to be done to the data prior to calculation
- are based on either a fact column or an attribute
- include in their expressions parentheses and other special characters that function as delimiters
- map multiple table rows to a single result

The graph shows the process to obtain a simple aggregation metric.

![Graph showing metric calculation process]

**Nested aggregation metrics**

This metric type provides a convenient way to use metric functionality when fact tables in the warehouse do not include attribute data at the level desired for specific analysis purposes. By using the result of a metric calculation as a temporary fact table from which to calculate another metric, you can obtain and analyze data not immediately available (for example, if you need time data aggregated at the month level, but existing fact tables provide only day-level information, you can use nested aggregation to obtain the results you are looking for).

In their structure, nested aggregation metrics:

- use the definition from another metric as part of the calculation
- include a level definition, and may also have conditions and transformations, which are independent from those of metrics being used as part of their calculation
Note: Although temporary tables built for nested aggregation purposes are used in the same manner as other fact tables, they serve the purposes of a specific nested aggregation only; they cannot be shared.

The graph shows the process to obtain a nested aggregation metric.

Compound metrics

Compound metrics are made of other metrics (which could, in turn, be simple aggregations, nested aggregations, or other compound metrics) and one or more mathematical operators.

In their structure, compound metrics:

• may contain prompts and constant numerical values, but do not include conditionality, level (dimensionality), or transformations, other than those that are already part of their simple-metric components
• map each table row to a specific row in the result
• are automatically updated when changes occur in the definitions of the metrics they include

The graph shows the process to obtain a compound metric.
Note: The portion of a metric definition that can be reused is called the base formula. Base formulae contain only calculation data; they do not include level information or conditionality, and cannot be used to perform transformations or find subtotals.

Metric composition

Metrics are constructed of components that not only allow differentiation of an individual metric from all others, but serve as criteria for defining the metric types described above as well. In general, metrics may consist of:

- a formula
- dimensionality (known as metric level)
- conditionality
- a transformation
The table that follows shows the basic function of each item on the preceding list.

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Formula¹</td>
<td>The portion of the metric that is included in the SQL Select clause; defines the data on which the metric is applied and the calculations to be performed on that information.</td>
<td>mandatory</td>
</tr>
</tbody>
</table>
| Level² (Dimensionality)       | Includes three parts:  
  • **Filtering**, which determines how the SQL Where clause is modified  
  • **Grouping**, which determines how the SQL Group by clause is modified  
  • **Target**, which determines at what level the criteria specified by Where and Group by are to be applied | mandatory |
| Conditionality                | Allows associating a filter to metric calculations. This filter modifies only the metric to which it is applied; it does not affect other metrics applied to the report. Advanced options for this component include specification of the interaction between the metric filter and the report filter. | optional |
| Transformation                | Applies offset values to selected attributes. Although transformations can be used with other hierarchies, they are most frequently applied to time. | optional |

¹Aggregation metric formulas can be either stored in metadata or embedded in the metric object itself (see nested aggregations). Complex metric formulas cannot be embedded in an object.

²In aggregation metrics, the level, or dimensionality, of the metric is an integral part of its definition. Compound metrics do not include a level, other than as part of other metrics in their definition.

**Metric operators and delimiters**

Operators enable calculation by providing the mathematical functions corresponding to each aggregation type. Closely associated with operators, delimiters show the structure of metric definitions by enclosing each metric component within recognizable symbols when displayed.
**Operators** available through the Metric Editor provide enablement for:
- arithmetic operations
- comparisons (including rank comparisons)
- logical functions

**Delimiters** provided by the Metric Editor include those for:
- object type ([ ])
- level (dimensionality) ({ })
- filter (< >)
- transformations ( || )

Operators and delimiters appear in a metric definition as follows:

```
SUM(F){Region}<Filter7>|Last Year |, where:
```

- **Sum** (F) = formula
- **Region** = level (dimensionality)
- **Filter** = conditionality
- **Last Year** = transformation

---

**Note:** The formula component of a metric can be either specified each time a metric is used or saved to be later shared with other metric definitions.

---

**Metric aggregation**

**Subtotals**

Using the Subtotals function set you can readily apply calculations to a metric definition by selecting a function from those available within the Metric Editor for the purpose.

The table that follows shows the basic subtotal types readily available on the Metric Editor user interface, and the results they yield.
The aggregation types included in the preceding table constitute only the basic functions directly accessible for calculation. In addition to these, the MicroStrategy 7 analytical engine has the capability to handle a large number of statistical, mathematical, financial, and OLAP calculations, all of which are also available for selection from the Metric Editor user interface.

### Applying subtotals to a metric

In the context of metrics, **Subtotals** permit computation and display of quantified data, gathered by MicroStrategy 7, along attribute groupings that you can specify dynamically for a report. MicroStrategy Desktop allows you to apply Subtotals using any one of a large number of

<table>
<thead>
<tr>
<th>Aggregation type</th>
<th>Yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td><strong>Sum</strong>[total] sum of input values</td>
</tr>
<tr>
<td>Count</td>
<td><strong>Count</strong>[count] number of input values</td>
</tr>
<tr>
<td>Average</td>
<td><strong>Avg</strong>[average] sum of input values divided by number of input values</td>
</tr>
<tr>
<td>Minimum</td>
<td><strong>Min</strong>[minimum] smallest input value</td>
</tr>
<tr>
<td>Maximum</td>
<td><strong>Max</strong>[maximum] largest input value</td>
</tr>
<tr>
<td>Product</td>
<td><strong>Product</strong>[product] all input values multiplied together</td>
</tr>
<tr>
<td>Median</td>
<td><strong>Median</strong>[median] middle value when all values are sorted</td>
</tr>
<tr>
<td>Mode</td>
<td><strong>Mode</strong>[mode] most frequently found input value</td>
</tr>
<tr>
<td>Standard deviation</td>
<td><strong>Stdev</strong>[standard deviation] distribution of input values</td>
</tr>
<tr>
<td>Variance</td>
<td><strong>Var</strong>[variance] square of the distribution of input values</td>
</tr>
<tr>
<td>Geometric mean</td>
<td><strong>Geomean</strong>[geometric mean] square root of the product of input values</td>
</tr>
</tbody>
</table>

**Note:** The aggregation types included in the preceding table constitute only the basic functions directly accessible for calculation. In addition to these, the MicroStrategy 7 analytical engine has the capability to handle a large number of statistical, mathematical, financial, and OLAP calculations, all of which are also available for selection from the Metric Editor user interface.
functions, each designed to yield a specific result. The behavior of subtotal aggregations is based on the types of data included in the metric to which the subtotal is applied.

You can dynamically select where subtotals are displayed on a report (you may, for example, select to have the subtotals for a given fact or attribute shown along the bottom of the report, those for a different metric displayed along the right margin, and so on).

**Metric Editor: general capabilities**

The tool used to define and edit metrics in a MicroStrategy Desktop environment is the Metric Editor. There are unique capabilities, available through the Metric Editor, associated with the definition and use of metrics. These serve, either individually or in combination, to:

- save calculations from existing metric definitions to create other metrics
- modify existing metrics by changing metric aggregation types or operators
- specify metric format properties such as the display of numeric values, font styles and sizes, and cell display colors
- dynamically update report information to reflect metric modifications
- validate defined metrics

**Metric Editor: menu capabilities**

The Metric Editor menu bar includes a number of options unique to metric creation and modification. Selections available provide the means to:

- dynamically update displayed values
- view applicable level (dimensionality) properties
- view and edit VLDB (very large database) settings as they apply to a given metric
- view and edit formatting properties
- select table join types

**To learn about...**

...metric-related tasks you can perform using MicroStrategy Desktop, please see the Metrics chapter of the How do I section in this guide.
To learn about...
A report is a request for specific, formatted data from the data warehouse. It consists of a template plus any desired filtering conditions. A template specifies which information is to be retrieved and how the results are displayed. A filter specifies the conditions that the data must meet in order to be included in the report results.

When a report is run, you obtain a formatted collection of all of the items (such as attributes and metrics) specified in the template layout that have satisfied the filtering conditions. For example, a report could show you a list of stores in a specific region, the price and volume of stock for a given period of time, or other important information. You can change the general presentation formats and specific formatting details to suit your requirements and preferences.

Reports are the focus of decision support investigations. They allow users to gather business insight through data analysis. The results from any MicroStrategy Desktop report can be a valid starting point for further business investigations.

The report design process begins by answering the following basic questions:

- What data is needed on the report?
- How will this data be formatted?
- How is the appropriate data selected?

The first two questions pertain to templates, the third, to filters.

### Designing reports

There are two critical parts to creating a report: creating one or more qualifiers, and creating the template.

In order to create a report, creating the template is the only necessary step; however most reports will also contain attribute, metric, or advanced qualifiers as well.
Filters

Filters allow you to limit the type and amount of data that is returned for a report. For example, if you are creating a report that contains the attribute Country, and you only want to bring back the results for France, you can accomplish this using filters. One way to do this is to qualify on the attribute Country, selecting France as the element that will appear on the report. Through the Report Editor, you can create the following qualifiers:

- Attribute Qualification
- Metric Qualification
- Advanced Qualification

Refer to the Filters chapter of the Concepts and How do I sections of this guide for additional information and step-by-step instructions on how to create and modify these qualifications.

Template

A template defines the layout of general categories of information in a report. In a template, you specify the information you would like to retrieve from the data warehouse and the way you want it to be displayed in each of the modes of reporting.

Templates can be created in both the Report Editor and the Template Editor. You create templates using the Template Editor if you want to save and reuse the template in other reports. You create a template directly in the Report Editor when you want to use the template only for that given report.

Refer to the Template chapter and the How do I section of this guide for additional information and step-by-step instructions on how to create and modify templates.

Replace a template with shortcut

Replacing a template with a shortcut ensures that the Report Editor maintains a link to the template in the metadata. Any changes done to the template from within the Report Editor are reflected in the template, and therefore all occurrences of the template. Similarly, if the template is changed using the Template Editor or another report that has a link to the template, it updates all of its occurrences.
Replace template with a copy

Replacing a template with a copy keeps a local copy of the template that resides only inside the Report Editor. Any changes done to this template are restricted to this report only.

Customizing reports

Sorting

Sorting allows you to specify the order that the data in a report for a particular row or column is presented in: either ascending or descending. You can select what objects you want to sort, the sorting criteria, and the sorting order.

Objects to sort

Any object that you can place in a template can be sorted. For a list of these objects, refer to the Templates chapter of the Concepts section.

Sorting criteria

The criteria in which to sort the object.

Sorting order

You can select for a row or column of data to be sorted in ascending or descending order. An ascending sort orders the data from smallest to largest, such as A - Z and 1 - 10. If you choose descending order then the data appears from largest to smallest, such as Z - A, and 10 - 1.

Wordwrap

You can set up your template to ensure grid labels will wrap when their length exceeds the width of the cell. This wrapping is referred to as wordwrap.

Autofit

You can set up your template to ensure the width of the cell will automatically adjust to fit the entire grid label. This is referred to as autofit.
**Banding formatting options**

You can apply banding to a report and customize its colors. Banding is a method of organizing (highlighting) values according to descriptive or meaningful data ranges. For example, if you have a table that contains the attributes State and City, and the element for State is NY, and for City is Albany, Buffalo, Syracuse, and Rochester, you can select to highlight the odd cities, in this case Albany and Syracuse, with colors to visually separate them from the other even NY cities, in this case Buffalo and Rochester. This highlighting is called banding.

**Metric properties formatting options**

You can apply the characteristics in the Metric Editor to the occurrence of the metric on the report. Refer to the Metrics chapter in this section for more information.

**Autostyles**

You can choose a different template style, changing the color and design of the template to match the needs of your report users.

**Page-by**

Page-by enables you to select and display subsets of your report data as separate pages.

The following objects can be used as page fields:

- Attributes
- Metrics
- Hierarchies
- Consolidations
- Custom Groups
- Object prompt (attribute)
- Object prompt (metric) - As long as the Row/Column does not contain a metric
- Object prompt (hierarchy)
- Object prompt (consolidation)
- Object prompt (custom group)
The order of the items in the page field can influence the list of elements displayed for subsequent items added to the page field. For example, suppose that a retailer sells sporting goods in the United States. Some items are available only in certain stores and not in others; for example, the stores in Alaska sell snowshoes instead of surfboards, whereas the stores in Hawaii sell surfboards instead of snowshoes. In a report with State and Item in the page field, the following results are possible:

- State first, then Item: If Alaska is selected for State, the list of elements for Item will not include surfboards. Similarly, if Hawaii is selected for State, the list of elements for Item will not include snowshoes.
- Item first, then State: If snowshoes are selected for Item, the list of elements for State will not include Hawaii. Similarly, if surfboards are selected for Item, the list of elements for State will not include Alaska.

Note: When creating an example such as the above using the Report Editor, you should also include a fact, such as Sales, in the report as well. The fact can either be in a metric on the template, or in a relationship filter.

View long name

When designing the template, it can be helpful to know what form the attribute displays. You can select to view the attribute form name in the template; this is referred to as viewing the long name of the attribute.

Lock row headers

You can set up your template so the row headers remain visible as the users scroll through a large report. This is known as locking the row headers.

Lock column headers

You can set up your template so the column headers remain visible as your users scroll through a large report. This is known as locking the column headers.
Report limits

The term **report limits** is actually applied to two different concepts, one dealing with the number of rows and columns that can be displayed at one time, and the other addressing metric conditionality applied to the report. A brief description of each follows.

MicroStrategy Desktop only displays up to 16384 rows, and 256 columns in a table. If you need to create a table that exceeds this limit, you can use the page-by functionality. Refer to **Page-by** in this chapter for additional information on this feature.

The Report Editor allows you to set limits on any metric you wish to apply to a report. Limit criteria for this purpose include **value** (for example, include only items greater than a specified value for the metric applied), **rank** (for example, include only the top ten items on a list), or **percent** (for example, include only those items whose value is in the top ten percent of the metric applied).

To learn about...

...report-related tasks you can perform using MicroStrategy Desktop, please see the Report chapter of the How Do I...? section in this guide.

...the Report Editor, please see the Report Editor chapter of the Interfaces section in this guide.
Prompts

You use prompts to enable metric, filter, template, custom group, or report modification. You implement this modification by applying certain conditions on one or more of the attributes, attribute elements, metrics, or other objects that the report may include. With prompts you can:

• Apply conditions or modify components in a report at run time, thus eliminating the need for preliminary definitions.
• Execute a report multiple times, selecting a different answer to a given prompt each time, and have, as result, a set of immediate answers to compare.

Properties

Although each of the prompt types available has distinct capabilities to provide a specific set of conditions, there are certain properties that all prompts share:

Title: user entry that identifies and differentiates the prompt
Description: user entry that indicates the nature or purpose of the prompt
Default: contains the default answer to the prompt (if one was specified)
Maximum and minimum: limit values to be allowed when the prompt is resolved.
Modify (Web options): allows style selection for a prompt.
Options

Conditions provided by a prompt depend on that prompt’s type. There are four major prompt types available for definition:

• filter definition prompts, with which you can qualify on:
  ◊ all attributes in a hierarchy
  ◊ a single attribute
  ◊ an attribute element list
  ◊ a metric
• object prompts
• value prompts
• level prompts

Filter definition prompts

Used for qualifying the value of attributes, attribute elements, and metrics, these prompts are described as follows:

Choose from all attributes in a hierarchy

• Used to select the elements included at run time, as part of filter criteria, for all attributes in a hierarchy.
• Can be used with any hierarchy in a project.
• Can be applied only within a filter or custom group.

Note: The following conditions apply to custom groups and consolidations:

• A custom group is a filter made up of an ordered collection of elements.
• Custom group elements can include a logical expression of attribute, metric, object, advanced, or custom group banding qualification.
• Custom group elements become attribute elements once the report is run.
• A consolidation is used within a template to specify the data to be viewed in a report.
• Consolidations allow the grouping of attribute elements in new ways without changing metadata or warehouse definitions.
• Consolidations permit combinations that provide row calculations among elements of a given attribute.
**CHAPTER 5**

---

**y on an attribute**

- Used to apply conditions or qualifications on an attribute form.
- Can be used with any attribute in a project.
- Can be applied only within a filter or custom group.

**Choose from an attribute element list**

- Used to restrict, at run time, the attribute elements from which the user can select for inclusion in a filter or custom group.
- Can be used with any attribute in a project.
- The list of elements from which the user may choose can be implemented by:
  - selecting all elements associated with an attribute
  - providing a filter on all elements associated with an attribute
  - providing a predefined list of elements from which the user can choose.

**Qualify on a metric**

- Used to limit, at run time, the selection of metrics that can be used to create qualifications for inclusion in a filter or custom group.
- Qualification can be implemented by:
  - specifying a single metric for run time use
  - specifying a search object to restrict the list of metrics from which the user can choose.

---

**Note:** All attributes in a hierarchy prompts, Attribute qualification prompts, and Metric qualification prompts are also referred to as Expression prompts. These can be given default values at creation time.
Object prompts

- Used to define the list of objects applicable to a report at run time.
- Defined by specifying either:
  ◦ a search object
  ◦ a pre-defined list of objects from which the user can choose.
- Allow specification of maximum and minimum values to be applied.

**Note:**
A search object defines the criteria (such as location, date, owner, and so on) for a list of objects to be generated.
A search becomes part of the metadata.
A search could specify, for example, display of all metrics that are contained in a certain folder and use a particular fact.

Value prompts

- Used when the information desired at run time is a single value of a specific data type.
- Data types available for single prompts include:
  ◦ date (any valid date format)
  ◦ numeric (for example, an integer)
  ◦ string (any type of text).
- Allow specification of maximum and minimum values to be applied.

**Note:** Although long prompts are not part of the options readily available for selection, you can enable them as part of your project preferences.
Level prompts

- Used to define dimensionality when two or more metrics differ only in level.
- Definition requires either a hierarchy or a list of attributes.
- Default output is at the report level.

To learn about...

...prompt-related tasks you can perform using MicroStrategy Desktop, please see the Prompts chapter of the How do I section in this guide.

...the Prompt Generation Wizard, please see the Prompt Generation Wizard chapter of the Interfaces section in this guide.
Custom Groups

A custom group is a special filter that can be placed on a template and is made up of an ordered collection of elements called custom group elements. Each custom group element can be labeled with a meaningful header and can include a logical expression of attribute, metric, object, advanced, or custom group banding qualifications. These qualifications will resolve into a list of attribute elements after the report is run. Custom groups, therefore, provide a way to group attribute elements from the same or different attributes to meet your reporting requirements.

For example, using the Custom Group Editor, you can create the custom group Store Inventory as follows:

**Store Inventory**

Small stores with low inventory

- Store Sales < 50
- AND
- Store Inventory < 200

Large stores with low inventory

- Store Sales > 50
- AND
- Store Inventory < 200
Depending upon the options you select in the **Custom Group Editor**, the custom group could appear on the report as shown here.

A custom group is composed of custom group elements and custom group element headers.

### Custom group elements

A custom group element is a logical expression of qualifications. A custom group element contains

- a name or header. This is an arbitrary name you define when you create the element. This name can be displayed on the report, and can be modified as desired. Because the custom group element can appear on the report, choose a significant name for the grouping of elements that you are defining.

- an expression of qualifications. You can define any qualification or logical expression of the qualification, or you can use previously created filters to build the custom group element.

You can create the custom group **Store Inventory** as follows:

**Store Inventory**

Small stores with low inventory

```
Store Sales < 50
AND
```
CHAPTER 6

Store Inventory < 200
Large stores with low inventory

Sales > 50
AND
Store Inventory < 200

The custom group elements in this example are:

**Small stores with low inventory**, which is a logical expression of the following two metric qualifications (MQ):

- Store Sales < 50 (MQ1)
- Store Inventory < 200 (MQ2)

and **Large stores with low inventory**, which is a logical expression of the following two metric qualifications:

- Stores Sales > 50 (MQ1)
- Store Inventory < 200 (MQ2)

**Custom group element headers**

A custom group is composed of one or more custom group elements and custom group element headers. For each individual grouping of custom group elements, there is a corresponding header. The header is used as an identifier on the report row or column. The Custom Group Editor provides you with different options for displaying the header.

**Qualification types**

The following qualification types can be applied to a custom group:

- Attribute
- Metric
- Filter
- Advanced
- Banding
Refer to the following topic for more information on attribute, metric, filter and advanced qualifications:

Filters

**Banding qualification**

Banding qualifiers enable you to create banding custom groups. Banding is a way of slicing a list, defined by the output level, of attribute elements using the values of a metric. For example, you can slice the list of stores (“Store” attribute elements) using the values of metric “Total Sales.” Suppose you have created a report that ranks stores by the revenue generated by each store. You might wish to group the stores by creating one group for the top 10 stores, a second group for stores 11-20, and another for 21-30. A custom group whose custom group elements are specified in this manner is called a banded custom group.

Different types of banding can be applied:

- **Band size:** Allows you to slice the range of metric values defined by “start at” and “stop at” values into a number of bands each the size defined by the parameter “step size.”
- **Band count:** Whereas band size allows you to define the size of each band, band count allows you to define the number of equal bands that you can slice the range of metric values into.

- **Banding points:** Allow you to specify the value where a band will be placed, and enables you to produce bands of different sizes.

![Diagram of banding qualification with step size, start at, stop at, and band count values](image-url)
Creating a report with two bands, the first band showing the top 10 stores and the second band showing stores 11-100, can be done by using banding points. To create two bands, you must create three points.

Banding Points = 1,10,100
Result:

```
1 10 100
```

**To learn about...**

...custom group-related tasks you can perform using MicroStrategy Desktop, please see the Custom Group chapter of the How do I section in this guide.

...the Custom Group Editor, please see the Custom Group Editor chapter of the Interfaces section in this guide.
Consolidations are used within templates to specify the data you want to view in your report. They allow you to group attribute elements in new ways without changing the metadata and warehouse definitions. Consolidations enable you to create customized groupings that allow row calculations between elements of a given attribute. This type of functionality is useful in financial reporting and analysis, for calculating totals and derived values, or for evaluating the relative worth of specific aspects of a business. It also enables you to perform comparisons of diverse production, promotions, or sales scenarios in one report.

For example, you have the following data in your warehouse:

<table>
<thead>
<tr>
<th>Manager</th>
<th>Year</th>
<th>Metrics</th>
<th>Sales ($)</th>
<th>Profit ($)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roe</td>
<td>1997</td>
<td></td>
<td>50</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td>1998</td>
<td></td>
<td>60</td>
<td>6</td>
</tr>
<tr>
<td>Becker</td>
<td>1997</td>
<td></td>
<td>55</td>
<td>7</td>
</tr>
<tr>
<td></td>
<td>1998</td>
<td></td>
<td>45</td>
<td>7</td>
</tr>
<tr>
<td>Kelter</td>
<td>1997</td>
<td></td>
<td>15</td>
<td>5</td>
</tr>
<tr>
<td></td>
<td>1998</td>
<td></td>
<td>25</td>
<td>3</td>
</tr>
</tbody>
</table>

Consolidations allow you to create a report showing the difference between the sales of the top two managers. To do so, you create a consolidation with one consolidation element (roe-becker). The formula is
Consolidation elements

Consolidation elements are attribute elements that define the consolidation. Consolidation elements can also be an expression of attribute elements that make up a consolidation. They can be defined from any of the following:

- elements of the same attribute
- attribute elements from different levels (such as Region and Country)
- elements from unrelated attributes (such as Country and Year)
- expressions of consolidation elements

Elements of the same attribute

A consolidation can contain elements of the same attribute, such as (Roe) and (Becker), both elements of the attribute Manager. Referring back to the previous example, consolidation elements allow you to expand the consolidation to see the values for each manager. For example, using elements of the same attribute you can modify the report result set as follows by adding the following three elements to the consolidation:

- Element 1 (roe)
  Manager=Roe
- Element 2 (becker)
  Manager=Becker
- Element 3 (roe-becker)
  {roe}-{becker}

With the use of consolidation elements, the report could now display the following:
**ssions of consolidation elements**

A consolidation can contain any expression on the pairs of elements, such as (Roe - Becker). Using another example, an element expression could also be [DC, 1997] / [DC, 1998].

**Elements from unrelated attributes**

A consolidation element can contain elements from different attributes. For example, you can calculate the difference every year for a particular manager in a particular year. For managers Roe and Becker the consolidation could contain the following elements:

- **Element 1 (Roe 1997-1998):**
  
  
  \[
  \text{[Manager=Roe AND Year =1997] - [Manager=Roe AND Year =1998]}
  \]

- **Element 2 (Becker 1997-1998):**
  
  \[
  \text {[Manager= Becker AND Year =1997] - [Manager= Becker AND Year =1998]}
  \]

The report now appears as follows:

<table>
<thead>
<tr>
<th>Top Manager</th>
<th>Metrics</th>
<th>Sales ($)</th>
<th>Profit ($)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Roe 1997-1998</td>
<td></td>
<td>10</td>
<td>-2</td>
</tr>
<tr>
<td>Becker 1997-1998</td>
<td></td>
<td>-10</td>
<td>0</td>
</tr>
</tbody>
</table>

**Import elements**

You can import consolidation elements from outside a consolidation. When a consolidation element is imported, a new consolidation element is created and embedded into the consolidation.
Evaluation order

If you desire to place two or more consolidations on a report, the order the engine evaluates them is significant and can change your result set. The evaluation order is set in the Report Editor when you create the report. Refer to the following sections for additional information and step-by-step instructions:

- Reports concept section
- Reports how do I section

To learn about...

...consolidation-related tasks you can perform using MicroStrategy Desktop, please see the Consolidation chapter of the How do I section in this guide.

...the Consolidation Editor, please see the Consolidation Editor chapter of the Interfaces section in this guide.
Documents

A document is a container for formatting, displaying and distributing multiple reports within a project. You can modify the appearance of a document to include text, images, hyperlinks, tables and one or more report objects.

Document layout

The document layout is used to position the reports inside the document. The layout is HTML-based, allowing you to insert images, text, tables, and hyperlinks; anything you can add to a Web page you can add to a document.

The document layout is an HTML file that includes special tags to identify the placement of the reports. Reports are represented by customized image tags. These images are replaced by the actual report when you execute the document in Document View, or via the Web.
Advanced concepts: XML and XSL

XML and XSL are advanced topics. You do not need to know anything about them in order to successfully create and view documents. However, the ability to customize the XSL provides additional functionality that you can use to create more personalized documents. Refer to the following sections for a high-level overview of XML and XSL:

- XML
- XSL

Refer to outside resources for more detailed information on these topics.

XML

XML is an acronym for eXtensible Markup Language. XML provides a standard set of rules for representing data via a textual representation. Like a database table, XML contains both data and information about that data. For a database table, this information takes the form of column names and data types. For XML, it is stored as tags and attributes. A tag in XML is similar to a tag in HTML: it is not in itself data to be displayed or used, but rather provides information about how to display the data. An attribute in XML is similar to an attribute in HTML: it provides characteristics about a tag, and also about the underlying data. In XML, each piece of underlying data is called an element.

XML can more easily represent a wider variety of data than can a simple relational table. This flexibility is one important part of what makes XML so powerful. The other part is the ability to make use of any custom tag within an XML document. Unlike HTML documents, which are limited to a predetermined set of tags, XML documents can include literally any tag within them; the interpretation of the tag is left to the XSL Stylesheet and the rendering application.

The XML generated for the document definition contains a pointer with a path to the HTML layout file. Therefore, the HTML file needs to be accessible from the MicroStrategy Intelligence Server and the MicroStrategy Desktop. This is also true for XSL files associated with the content elements. At run-time, the MicroStrategy Intelligence Server scans through the HTML layout file and replaces the image placeholders with the corresponding reports and applies the given XSL to each of the reports.

For more information on the MicroStrategy 7 XML tag definitions, please refer to the MicroStrategy SDK.
There are also several publications available that provide additional information about the XML standard. In addition, the World Wide Web consortium (W3C) publishes a set of Web pages at http://www.w3.org/XML/documenting the standard and listing additional resources. Please refer to these outside sources for more information on XML.

**XSL**

XSL is an acronym for eXtensible Stylesheet Language. XSL is what dictates the style (such as color and font) for a grid. Each report must have an XSL associated with it.

An XSL Stylesheet is a specific type of XML document, and therefore must observe the same set of rules as any other XML document. The XSL standard provides a set of special tags, rules and methods that can be used together to process XML documents and turn them into formatted output such as HTML.

For more information about the Extensible Stylesheet Language, please visit the W3C Web site at http://www.w3.org/Style/XSL/.

**XSL stylesheets**

XSL Stylesheets provide a very powerful means of controlling the output format for MicroStrategy grids. They can be used for much more than simple grid formatting control. For example, XSL Stylesheets can be used to control the insertion of images, phrases, or even frames.

For a list and description of the stylesheets that are installed with MicroStrategy 7.0 in the XSL folder within the application directory (Drive:/Program Files/MicroStrategy/Desktop/XSLs, assuming you installed in the default directory), refer to Appendix: XSL Stylesheets
To learn about...

...document-related tasks you can perform using MicroStrategy Desktop, please see the Document chapter of the How do I section in this guide.

...the Document Editor, please see the Document Editor chapter of the Interfaces section in this guide.
SECTION

Interface

Topics for this section include:
• Template Editor
• Filter Editor
• Metric Editor
• Report Editor
• Prompt Generation Wizard
• Custom Group Editor
• Consolidation Editor
• Document Editor
Template Editor

What is it?
The Template Editor allows you to create and modify templates.

How can I access it?
To access the Template Editor, from the File menu, point to New and then choose Template.

What can I do with it?
The Template Editor allows you to:
• add or hide pages
• create or modify a template
• lock row and column headers
• set auto styles, banding, sorting, and formatting options
• view the attribute forms, VLDB properties, and attribute options

For instructions on completing one of the above tasks, refer to the following How do I...? topic:
Templates
What should I know before I use it?

Before you begin using the Template Editor, you should:
• be familiar with the location of the objects within your project
• create attributes, metrics, and facts

For more information on the above topics, refer to the following Concepts section:
Templates

Template Editor layout

The template definition section allows you to specify the format of a template and the objects you want to appear in the template. To define the layout of the template, drag an object into the template definition area. A colored line appear in the template indicating formatting of the template; a horizontal line indicates a column, and a vertical line indicates the object will be placed as a row.

From this section you can access the following dialogs boxes:
• Attribute Display. Allows you to set the attribute form options.
• Subtotals. Allows you to select the desired subtotal and define the display options.
• Grid Options. Allows you to select your banding and metric options, as well as set your column and outline display.
• Report Data Options. Allows you to set, view and modify report limits, join types, evaluation order, metric alias and drilling.
• Metric Editor. Allows you to edit the selected metric using the Metric Editor. Refer to the Metric Editor Interface and How do I chapters for more information.
Template Editor toolbar and menu options

The following Template Editor specific menu bar options are available:

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Select to access the Page By functionality.</td>
</tr>
<tr>
<td>Show Pages</td>
<td></td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Insert</td>
<td>When an object is selected from the Object Browser, select this option to</td>
</tr>
<tr>
<td>Add to Template</td>
<td>add the object to the template as a row.</td>
</tr>
<tr>
<td>Add to Template Axis</td>
<td>When an object is selected from the Object Browser, select this option to</td>
</tr>
<tr>
<td></td>
<td>add the object to the template as a row, column, or page.</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Sorts alphabetically, numerically in ascending order (A to Z).</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts alphabetically, numerically in descending order (Z to A).</td>
</tr>
<tr>
<td>Clear Sorts</td>
<td>Clears the sorts.</td>
</tr>
<tr>
<td>Advanced Sorting</td>
<td>Opens the Sorting dialog box.</td>
</tr>
<tr>
<td>Subtotals</td>
<td>Opens the Subtotals dialog box.</td>
</tr>
<tr>
<td>Attribute Display</td>
<td>Opens the Attribute Display dialog box.</td>
</tr>
<tr>
<td>Report Data Options</td>
<td>Opens the Report Data Options dialog box.</td>
</tr>
<tr>
<td>VLDB Properties</td>
<td>Opens the VLDB Properties dialog box. VLDB engine related properties allow</td>
</tr>
<tr>
<td></td>
<td>you to customize the SQL generation based on your requirements/environment.</td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Grid</td>
<td></td>
</tr>
<tr>
<td>Move to Row</td>
<td>Moves a Column item to a Row.</td>
</tr>
<tr>
<td>Move to Column</td>
<td>Moves a Row item to a Column.</td>
</tr>
<tr>
<td>Move to Page</td>
<td>Moves a Row or Column item to a Page.</td>
</tr>
<tr>
<td>Move Left</td>
<td>Moves an item to the Left of the item next to it.</td>
</tr>
<tr>
<td>Move Right</td>
<td>Moves an item to the Right of the item next to it.</td>
</tr>
<tr>
<td>Options</td>
<td>Opens the Grid Options dialog box.</td>
</tr>
<tr>
<td>Display Outline Results *</td>
<td>Click to display the report result in outline mode.</td>
</tr>
<tr>
<td>Long Names</td>
<td>Shows the long names of Attributes.</td>
</tr>
<tr>
<td>Merge Header Cells</td>
<td>Merges the Header Cells into one Cell.</td>
</tr>
<tr>
<td>Lock Row Headers</td>
<td>Maintains display of row headers during horizontal scrolling.</td>
</tr>
<tr>
<td>Lock Column Headers</td>
<td>Maintains display of column headers during vertical scrolling.</td>
</tr>
<tr>
<td>Auto Style Selected</td>
<td>Allows you to select (or change) a display style from a list of available styles.</td>
</tr>
</tbody>
</table>

* Display Outline Results is enabled when the following conditions are met:

1. There is more than one attribute on the rows
2. Metrics are not on the rows.
Filter Editor

What is it?

The Filter Editor is used to create filter definitions.

How can I access it?

To access the Filter Editor, from the File menu, click New, then choose Filter.

What can I do with it?

The Filter Editor allows you to:

- create or modify filters
- create attribute, metric, advanced and/or filter qualifications
- add a prompt to a filter

For instructions on completing one of the above tasks, refer to the following How do I...? topic: Filters
What should I know before I use it?

Before you begin using the Filter Editor, you should:
• know the location of the objects within your project
• create attributes, metrics, and facts (for information on attributes, refer to the Project Designer guide)

For more information on the above topics, refer to the following Concept sections:
• Filters
• Metrics

Filter Editor layout

Filter definition

The Filter Editor enables you to add attribute, metric, advanced, and filter qualifications to your report without having to open another editor. Simple filters can be created by dragging and dropping objects from the Object Browser window into the Filters window. If an attribute, for example, is dragged into the Attribute Qualification window appears.

From this window you can also access the following windows:
• Attribute Qualification
• Metric Qualification
• Filter Qualification
• Advanced Qualification

Attribute Qualification

This window can be accessed by selecting Attribute Qualification from the Filtering Options window. This window allows you to choose the attribute to be qualified. You can drag an attribute into the Filters window,
enter the name of an attribute into the box, or click on the browse button to browse for an attribute. You can also choose to qualify on the attribute form. From this window you can access the following:

- **Select Objects.** Accessed by clicking Add or Modify when qualifying on the attribute elements, this dialog box allows you to select the elements you wish to qualify on.

- **Prompt Generation Wizard.** Accessed by clicking the Prompt button, this wizard allows you to define a prompt and set the prompts defaults.

- **Date Editor.** Accessed by dragging a time-based attribute (such as Date) into the Filter definition section of the editor. In the Attribute Qualification window, you need to qualify on the ID, and then the Date Editor button appears in the Operator section of the window. This editor allows you to qualify on a date.

Once you have decided which attribute you want to qualify, you have to choose the attribute form to qualify on. For an explanation of attribute forms, refer to the Project Designer guide.

**Metric Qualification**

This window can be accessed by selecting Metric Qualification from the Filtering Options window. This window allows you to choose the metric to be qualified, the function, operator, and the filter criteria. You can drag a metric into the Filters window, enter the name of a metric into the box, or click on the browse button to browse for a metric. From this window you can access the following:

- **Prompt Generation Wizard.** Accessed by clicking Prompt, this wizard allows you to define a prompt and set the prompts defaults.

- **Level Editor.** Allows you to set the dimensionality continuation, output level, and break by for the metric. This editor contains the following tabs:
  - **Output.** Allows you to set the rules to resolve the metric calculation.
  - **Break By.** When the Function selected is either Rank or Percent, the Break By tab is visible. This tab allows you to choose the attribute level at which to restart counting the rank or percentage for the metric.
  - **Continuation.** Visible when an upgraded filter has a continuation defined, this tab allows you to see the elements that affect the metric calculation. This tab is read-only.

**Note:** The Continuation tab is only visible if an upgraded filter has continuation defined, otherwise the tab is not available.
**Filter Qualification**

This window can be accessed by selecting **Filter Qualification** from the **Filtering Options** window. This window allows you to choose the filter to be qualified. You can drag a filter into the Filters window, enter the name of a filter into the box, or click on the browse button to browse for a filter. From this window you can access the following:

- **Prompt Generation Wizard.** Accessed by clicking the **Prompt** button, this wizard allows you to define a prompt and set the prompts defaults.

**Advanced Qualification**

This window can be accessed by selecting **Advanced Qualification** from the **Filtering Options** window.

Under **Choose an option**, you can either select **Custom Expression**, or **Joint Element List**.

- **Custom Expression.** If selected, you can enter a filter expression.
- **Joint Element List.** If selected the **Joint Element List** dialog box opens.

**Filter Editor toolbar and menu options**

The following Filter Editor specific toolbar and menu options are available:

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter</strong></td>
<td>Moves the selected qualification up in the definition.</td>
</tr>
<tr>
<td><strong>Move Up</strong></td>
<td>Moves the selected qualification down in the definition.</td>
</tr>
<tr>
<td><strong>Move Down</strong></td>
<td>Maximizes the Object Browser.</td>
</tr>
<tr>
<td><strong>Object Browser</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Insert</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Add to Filter</strong></td>
<td>Adds to the Filter.</td>
</tr>
<tr>
<td><strong>Filter Prompt</strong></td>
<td>Opens the <strong>Prompt Generation Wizard</strong>.</td>
</tr>
</tbody>
</table>
**Metric Editor**

**What is it?**

The Metric Editor is the tool that MicroStrategy Desktop makes available for the creation and modification of report metrics.

**How can I access it?**

To access the Metric Editor, from the File menu, point to New and then choose Metric.

**What can I do with it?**

With the Metric Editor, you can create and modify metrics by providing all the components of metric definition:

- aggregation function
- aggregation level (dimensionality)
- conditions
- transformations

For instructions on completing one or more of the above tasks, refer to the following How do I...? topic:

Metrics
What should I know before I use it?

Before you use the Metric Editor, you should familiarize yourself with:

- the purpose of metrics in reports
- metric components and their functions
- the various types of metrics available within MicroStrategy Desktop
- the relationship between metrics and other report components

For more information on the above topics, refer to the following Concepts section:

Metrics

Metric Editor layout

The Metric Editor includes four areas:

- a Formula tab (which includes the object browser, a view of the metric tree, and an expression box), used for metric definition
- a Subtotals tab, used to select, from a list of subtotal options available, one or more aggregation types to apply to a defined metric
- a menu bar that, in addition to the standard Windows NT options, provides access to functions specific to the Metric Editor
- a toolbar that provides shortcuts to a set of task-supportive functions unique to metric definition

The paragraphs that follow describe each of these areas.

The Formula tab

The functions associated with the Formula tab are used to create new metrics and reuse existing ones, as they provide the means necessary for metric definition and modification. A description of the format and contents of the Formula tab follows.
The primary components of the Formula tab include:

- **The Object Browser** window, which provides, as the name implies, the means to search for and locate objects, within the active project, to use for metric definition. The Object Browser, in turn, consists of:
  - The Location drop-down menu, which includes as options:
    - Folders containing public objects, schema objects, object templates, and so on
    - A list of the hierarchies, attributes, and facts identified for the project
    - A list of the operators and advanced functions that the analytical engine makes available for metric calculations.
  - The Find user-entry box, where you can enter the name of an object you want to use for metric definition.
  - A display box that shows all the objects within an object selected from the Location menu.

To facilitate recognition, metric components are color-coded, and accompanied by delimiters, when displayed in the metric definition area of the Formula tab.

The following are delimiters used by the Metric Editor:

<table>
<thead>
<tr>
<th>delimiter character</th>
<th>delimiter function</th>
</tr>
</thead>
<tbody>
<tr>
<td>[ ]</td>
<td>contains an object name</td>
</tr>
<tr>
<td>{ }</td>
<td>contains level (dimensionality)</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>contains conditionality</td>
</tr>
<tr>
<td>&quot;&quot;</td>
<td>contains a string</td>
</tr>
<tr>
<td>. .</td>
<td>contains a date</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
The table that follows lists the components available for metric definition, their format, and their default values.

<table>
<thead>
<tr>
<th>Component</th>
<th>Expression</th>
<th>Default Value</th>
<th>Default Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>name of the metric (blank if metric is new)</td>
<td>none</td>
<td>black</td>
</tr>
<tr>
<td>Aggregation type</td>
<td>[object name] (aggr. level)</td>
<td>varies by object type (see note)</td>
<td>black bold</td>
</tr>
<tr>
<td>Formula</td>
<td>aggregation [aggr. unit]</td>
<td>none</td>
<td>dark blue</td>
</tr>
<tr>
<td>Level (Dimensionality)</td>
<td>aggregation level report</td>
<td>yellow</td>
<td></td>
</tr>
<tr>
<td>Conditions</td>
<td>[filter name] [nothing] (empty filter)</td>
<td>green</td>
<td></td>
</tr>
<tr>
<td>Transformation</td>
<td>attribute being transformed [nothing] (no transformation)</td>
<td>light blue</td>
<td></td>
</tr>
</tbody>
</table>

**Note:** The default aggregation type depends on the type of object on which the metric is applied (for example, **SUM** is the default aggregation for facts; **COUNT** is the default aggregation for attributes).
Tab components

The primary elements of the Formula tab are:

- the **metric definition** boxes, which includes:
  - a box for display of metric components during definition, called the metric tree view (under New Metric (I) is defined as:)
  - a window for display of the metric expression (under Definition)
  - an Operators toolbar, displaying:
    -- selectable delimiters for metric definition ([ ]) 
    -- selectable mathematical operators for metric definition (+ - * /)
  - a set of command buttons (“Validate,” “Clear”)

- the **Object Browser**, which includes:
  - **Location**, a drop-down menu of the major selectable objects in the project
  - **Find**, a box where users can enter the name of an object for metric-related use
  - a window displaying the folders in the object selected from the Location menu

---

**Note**: If you wish to have the definition window occupy the entire display area during metric definition, you can hide the **Object Browser** section of the Formula tab by clicking the x next to the Object Browser title.

---

Tab usage

To create a new metric, use the **Object Browser** to select the report component (either a fact or an attribute) you want to use to apply the metric. The Metric Editor displays the default values for the metric components, color coded as defined, as well as the default aggregation for the report component (for the basic functions readily available under the Subtotals tab, usually either SUM or COUNT).

Metric components can be viewed or edited by selecting them on the display window, as follows:
<table>
<thead>
<tr>
<th>Component</th>
<th>Editing Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metric expression</td>
<td>Displays the current metric expression in a read-only mode.</td>
</tr>
<tr>
<td>Formula</td>
<td>Delimiters and operators (shown above the display window) allow modification of the metric expression formula (metric functions and associated arguments)</td>
</tr>
</tbody>
</table>
| Level (Dimensionality)  | • **Remove**: allows discarding the attribute selected  
|                         | • **Reset**: allows entering a new definition in the spaces provided  
|                         | • **Advanced**: allows accessing the “Dimensionality advanced options” window (see note 1 below) |
| Condition               | • **Browse**: allows accessing the “Select a filter...” window (see note 2 below)  
|                         | • **Edit**: allows access to the Filter Editor  
|                         | • **Clear**: removes the current filter  
|                         | • **Advanced**: allows accessing the “Condition advanced options” window (see note 3 below) |
| Transformation          | • **Remove**: allows discarding the transformation selected  
|                         | • **Reset**: allows entering a new definition in the spaces provided |
• Right-clicking the aggregation type displays the `<Aggregation>` Parameters dialog box, showing all parameters applicable to the aggregation. Identifying distinct data, fact IDs, and null values are examples of aggregation parameters (see the information under Subtotals, for a list of aggregation types).

• The **Level (Dimensionality) advanced options** window (accessed by clicking **Advanced**...on the “Level (Dimensionality)” window), provides check boxes through which you can add:
  ◊ units to a definition
  ◊ filter attributes to the current level.

• The **Select condition** window (accessed by clicking Browse on the Condition window), displays a list box from which you can choose a different filter for the metric you are defining.

• The **Condition advanced options** window (accessed by clicking **Advanced** on the Condition window), provides:
  ◊ a drop-down list window from which you can select the following alternatives to add restrictions to the metric:
    -- “Merge report filter into metric”
    -- “Merge into new (object)”
    -- “Merge metric condition into report”
  ◊ a check box providing the choice to remove related report filter elements.

You can accept defaults or you can modify them by selecting a different aggregation type, or by choosing different values for some or all of the metric components.

When you have completed metric definition, a statement on the bottom-left corner of the dialog box shows the validity status. Clicking **Validate** allows you to check that the metric you have defined is applicable. When the Metric Editor shows the definition to be in error, you can discard it by clicking **Clear**, and then redefine the metric.

If you wish to store a newly defined metric for future use, select **Formula** from the component display window. When the Metric Editor displays **Store in** window, you can specify how and where the metric is to be filed.

To reuse an existing metric definition, select the metric on the **Object Browser**, and then highlight **Formula**. When the Metric Editor displays the definition, you can either accept it as is, or modify it to suit your purposes.
The Subtotals tab

The **Subtotals** tab is used to select a metric function for calculation from the list of those readily available. You can apply subtotals to a defined metric in several ways, each designed to yield a specific result. The behavior of subtotals is based on the types of calculations that can be applied to a given metric.

### General

Following is a description of the various types of calculations available under the **Subtotals** tab.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Expression</th>
<th>Evaluation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total</td>
<td>SUM[Total]</td>
<td>sum of input values</td>
</tr>
<tr>
<td>Count</td>
<td>COUNT[Count]</td>
<td>number of input values</td>
</tr>
<tr>
<td>Average</td>
<td>AVG[Average]</td>
<td>sum of input values divided by count of input values</td>
</tr>
<tr>
<td>Minimum</td>
<td>MIN[Minimum]</td>
<td>lowest input value</td>
</tr>
<tr>
<td>Maximum</td>
<td>MAX[Maximum]</td>
<td>highest input value</td>
</tr>
<tr>
<td>Product</td>
<td>PRODUCT[Product]</td>
<td>multiplication of all input values together</td>
</tr>
<tr>
<td>Median</td>
<td>MEDIAN[Median]</td>
<td>middle value when input values are sorted</td>
</tr>
<tr>
<td>Mode</td>
<td>MODE[Mode]</td>
<td>most frequent input value</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>STDEV[Standard Deviation]</td>
<td>spread of input values</td>
</tr>
<tr>
<td>Variance</td>
<td>VAR[Variance]</td>
<td>square of the spread of input values</td>
</tr>
<tr>
<td>Geometric Mean</td>
<td>GEOMEAN[Geometric Mean]</td>
<td>square root of subtotals product</td>
</tr>
</tbody>
</table>
Note: The functions readily selectable under the Subtotals tab reflect only the most frequently used, basic metric calculations. A large number of statistical, mathematical, financial, and OLAP functions, from simple to highly complex, are also available for selection under, Functions and Operators, from the Location drop-down menu on the Formula dialog.

Tab components

The Subtotals tab includes:

- a list of all available subtotal functions (on the left side of the window)
- a list of available subtotals selected for a given metric (on the right side of the window)
- a description of the subtotal expression currently highlighted
- a drop-down box to Allow Smart Totals (the default value for this selection is “no”)

Note: You can also access and define subtotals directly from a report.

Tab usage

To see a list of subtotal functions, use the display window within the tab (the contents of this list will be based on the metrics that have already been defined).

From the list of subtotals available, you can select one or more to apply to a specific metric by highlighting the subtotal expression(s) and then clicking the transfer arrow (>) (alternatively, you can transfer all subtotal expressions to the selection area by clicking the double arrow (>>) and then deselecting those expressions you do not want).

Once you have selected the subtotal functions you want to apply to the report, you can either return to the Formula tab, or exit the Metric Editor. To exit the Metric Editor, click Save and Close.

In addition to the aggregation functions readily available from the Subtotals tab, MicroStrategy 7 provides a number of others. For a complete list of analytical functions, see:

Analytical Functions in MicroStrategy 7
Subtotals at runtime

In addition to the function provided by the Metric Editor, you can define subtotals dynamically. The paragraphs that follow describe the handling of subtotals directly from a displayed report.

You can access Subtotals from an open report by selecting Data, and then Subtotals.

The Subtotals Options window has two tabs:

• the Definition tab to define the metric for which you want to display subtotals
• the Display options tab to specify the format in which results are displayed

Within the Definition tab you can select:

• the metrics for which you want to display subtotals
• the type of aggregation you want each subtotal to reflect
• (by clicking Details) the grouping criteria you want reflected by the subtotal results

The Metrics window provides a menu that shows all the fact columns used in the report (for example, Sum_Order_Amt, Sum_Ship_Charge, and so on), as well as an option to select all applicable metrics.

The Subtotals window allows you to select how you want subtotal aggregations grouped.

Details provides access to a window on which you can specify the grouping criterion for the display. Grouping options on this window are:

• by position (totals by row, column, or page)
• by hierarchy level (for example by store, or by product category)

The Details window also displays a list of available aggregation types, highlighting the selection you made in the Subtotals display. On this display window you can change your previous selection, add to it, or leave it unchanged.

The Display Options tab allows you to determine the display position (both by row and by column) of the subtotal(s) you have selected. In addition to the text associated with each option, there is a dynamic icon that indicates graphically their relative display position.

With the Display Options tab you can determine:

• the position of subtotal data with respect to the columns and rows in the report
• whether you want the report to show subtotals when first displayed.
Column-related options for subtotal display:

- at the left end of the report
- at the left end of each grouping level in the report
- at the right end of the report
- at the right end of each grouping level in the report

Row-related options for subtotal display:

- at the top of the report
- at the top of each grouping level in the report
- at the bottom of the report
- at the bottom of each grouping level in the report

Unique menu options

The Metric Editor provides a set of unique toolbar functions designed to facilitate the tasks associated with metric definition and modification. The table that follows shows the task associated with each function supported.

<table>
<thead>
<tr>
<th>Menu selection</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>View /</td>
<td>• display / hide dimensionality level, filters, &amp; grouping</td>
</tr>
<tr>
<td>• Show Level (Dimensionality)</td>
<td>• display / hide current metric values</td>
</tr>
<tr>
<td>Properties</td>
<td>• hide / display object browser</td>
</tr>
<tr>
<td>• Show / Hide Function Parameters</td>
<td>• redisplay metrics with updated values</td>
</tr>
<tr>
<td>• Object Browser</td>
<td>Tools /</td>
</tr>
<tr>
<td>• Refresh</td>
<td>• Formatting</td>
</tr>
<tr>
<td></td>
<td>• Metric Join Type</td>
</tr>
<tr>
<td></td>
<td>• Advanced Settings /</td>
</tr>
<tr>
<td></td>
<td>-- VLDB Options</td>
</tr>
<tr>
<td></td>
<td>-- Formula Join Type</td>
</tr>
<tr>
<td></td>
<td>• Options</td>
</tr>
</tbody>
</table>

The paragraphs that follow describe the windows associated with the functions listed above.
View menu: Show Dimensionality Properties

When you click the Show Dimensionality Properties icon, the Metric Editor displays the following data for the metric being created or edited:

- dimensionality level
- filtering options
- grouping options, if applicable

Clicking the icon again hides the Dimensionality Properties.

View menu: Show/Hide Function Parameters

When you click the Show Function Parameters icon, the Metric Editor displays function parameters not using default values. When you click the icon again, those values are hidden.

View menu: Object Browser

When you click the Object Browser icon, the Metric Editor reverses the display state of the Object Browser within the Formula tab: if the Object Browser is displayed, clicking this icon hides it; if it is hidden, clicking this button displays it.

View menu: Refresh

When you click Refresh from the View menu, the Metric Editor redisplay the screen reflecting new values for metric components that were just modified.

Tools menu: Formatting

When you select the Format properties, the Metric Editor shows the Format properties window for the metric currently open, which consists of

- three tabs, each corresponding to an editing dialog
- a set of (2) radio buttons that allow you to specify whether the properties you define correspond to a metric header or a metric value
- a Preview area showing:
  - the font, size, cell pattern, and cell color for metric header(s)
  - the format and color of metric values
**Note:** This window can also be accessed from the Metric Editor toolbar.

Metric property tab functions are as follows:

- the **Number** tab allows you to select a number *category*, and determine the way in which numbers will be displayed for the metric
- the **Font** tab allows you to select the style, size, and color in which data will be displayed
- the **Pattern** tab allows you to select the pattern and color that cells for metric values will have when displayed

The table that follows shows the values for each of these format properties.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Property</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>category</td>
<td>fixed</td>
<td>• decimal places&lt;br&gt;• separators&lt;br&gt;• negatives</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>currency&lt;br&gt;• decimal places&lt;br&gt;• currency symbol&lt;br&gt;• symbol position&lt;br&gt;• negatives</td>
</tr>
<tr>
<td></td>
<td>date</td>
<td>formatting type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>time</td>
<td>formatting type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>percentage</td>
<td>decimal places&lt;br&gt;formatting type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>fraction</td>
<td>formatting type</td>
<td></td>
</tr>
<tr>
<td></td>
<td>scientific</td>
<td>decimal places</td>
<td></td>
</tr>
<tr>
<td></td>
<td>custom</td>
<td>custom format</td>
<td></td>
</tr>
<tr>
<td>Font</td>
<td>name</td>
<td>(49 available)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>style</td>
<td>regular&lt;br&gt;b&lt;br&gt;bold&lt;br&gt;i&lt;br&gt;italic&lt;br&gt;b&lt;br&gt;i&lt;br&gt;b&lt;br&gt;i</td>
<td></td>
</tr>
<tr>
<td></td>
<td>size</td>
<td>(from 6 to 72)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>highlighting</td>
<td>underline&lt;br&gt;strike-through</td>
<td></td>
</tr>
</tbody>
</table>
Tools menu: Metric Join Type

When you select **Metric Join Type** a dialog box appears and you have the option to select an Inner or Outer Join. An Inner Join includes only the elements common to both tables, an Outer Join includes all of the elements in both tables.

Tools menu: Advanced Settings/ VLDB Properties

When you select **VLDB Options**, the Metric Editor shows the **VLDB Properties (Metric) - New Metric** window, which consists of:

- a list of folders that contain VLDB settings for:
  - indexing
  - joins
  - metrics
  - pre / post statements
  - query optimizations
  - select / insert
  - tables

- a display showing a description of the folder currently selected
- a **SQL Preview** area showing, when applicable, the SQL code corresponding to the setting currently selected.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Property</th>
<th>Type</th>
<th>Modifiers</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>alignment</td>
<td>left center right</td>
<td></td>
</tr>
<tr>
<td></td>
<td>script</td>
<td>Western Greek</td>
<td>Baltic C. European Cyrillic</td>
</tr>
<tr>
<td></td>
<td>color</td>
<td>(64 available)</td>
<td>pattern color</td>
</tr>
<tr>
<td></td>
<td>Pattern</td>
<td>(18 available)</td>
<td>fill color</td>
</tr>
</tbody>
</table>
Tools menu: Advanced Settings/Metric Join Type

When you select Metric Join Type, the Metric Editor shows the Metric Join Type dialog box, on which you can select the type of join (inner or outer) to apply to tables affected by the metric.

When you click Advanced Settings, the Metric Editor displays a menu from which you can select:

- VLDB properties
- metric formula joint type (default, inner, or outer)

For information on the purpose and function of the Metric Editor, see the chapter on Metrics in the Concepts section.

For information on the use of the Metric Editor, see the chapter on Metrics in the How Do I...? section.
CHAPTER 12

Report Editor

What is it?

The Report Editor is used to create and modify reports. It is a combination of the Filter Editor, Template Editor, and Object Browser which enables you, through one editor, to create your template and filters for a specific report.

How can I access it?

To access the Report Editor, from the File menu, point to New and then choose Report.

What can I do with it?

Through the Report Editor, you can:
• create or modify a report
• add attribute, metric and/or filter qualifiers
• add objects, a page, prompt, subtotal, or template to a report
• remove an object from a report
• run a report
• set VLDB options for report

For instructions on completing one of the above tasks, refer to the following How do I...? topic:
Reports

What should I know before I use it?

Before you begin using the Report Editor, you should:
• be familiar with the location of the objects within your project
• have attributes, metrics, and facts available in your project
• know what a qualification is and why you might want to apply one
• be familiar with the concepts of filters and templates
For more information on the above topics, refer to the following Concepts sections:
- Reports
- Filters
- Templates

**Report Editor layout**

The Report Editor is divided into the following sections:
- Filter definition
- Template definition

**Filter**

The Filter definition section enables you to add attribute, metric, and advanced qualifications, as well as a shortcut to a filter without having to open another editor. Simple filters can be created by dragging and dropping objects from the Object Browser window into the Filters window. If an object is dragged into the Filter definition section, the Qualification dialog box that corresponds to the object appears.

The following windows are opened by dragging and dropping an object into the Filter definition section:
- Attribute Qualification
- Metric Qualification

**Template**

The Template definition section is composed of the Template Editor. Drag and drop objects into this section to define your report layout. If you have already created a template in the Template Editor, you can use that template in the Report Editor. Navigate to the templates location in the Object Browser, right-click and then drag and drop the template into the Template definition area. In the dialog box that appears, click Replace template with shortcut or Replace template with a copy.
Report Editor toolbar and menu options

The following menu bar options provide specific Report Editor functions:

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Displays template and filter specifics for the report. You must have owner privileges to change settings in this view.</td>
</tr>
<tr>
<td>Design View</td>
<td>Displays a report in grid mode.</td>
</tr>
<tr>
<td>Grid View</td>
<td>Displays a report in graph mode.</td>
</tr>
<tr>
<td>Graph View</td>
<td>Displays the SQL code for a report.</td>
</tr>
<tr>
<td>SQL View</td>
<td>Runs the report.</td>
</tr>
<tr>
<td>Run Report</td>
<td>When applicable, displays a list of pages associated with a report.</td>
</tr>
<tr>
<td>Show Pages</td>
<td>Displays the filter definition for a report.</td>
</tr>
<tr>
<td>Show Filter Details</td>
<td>Hides/shows the Object Browser window</td>
</tr>
<tr>
<td>Object Browser</td>
<td></td>
</tr>
<tr>
<td>Insert</td>
<td></td>
</tr>
<tr>
<td>Add to Filter</td>
<td>Display a dialog box in which you can add restrictions to an existing filter definition.</td>
</tr>
<tr>
<td>Filter Prompt</td>
<td>When applicable, displays a filter prompt associated with a report.</td>
</tr>
<tr>
<td>Add to Template</td>
<td>Displays a dialog box from which you can select attributes to add to an existing template.</td>
</tr>
<tr>
<td>Add to Template Axis</td>
<td>Displays a dialog box that permits adding rows, columns or pages to an existing report.</td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Data</td>
<td>Applies ascending sort to a selected column in a report.</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Applies descending sort to a selected column in a report.</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Clears an existing sort in a report.</td>
</tr>
<tr>
<td>Clear Sorts</td>
<td>Displays a dialog box where you can specify sorting order, criteria, and positioning for rows, columns, and report pages.</td>
</tr>
<tr>
<td>Advanced Sorting</td>
<td>Displays a dialog box containing all subtotals applied to an existing report. You can specify additional subtotal aggregations or clear existing ones using this dialog.</td>
</tr>
<tr>
<td>Subtotals</td>
<td>Shows the Attribute Display dialog box, in which you can specify display of default settings for a selected attribute, as well as see its current form as used in the report.</td>
</tr>
<tr>
<td>Attribute Display</td>
<td>Displays the Report Data Options dialog box, where you can view, modify, or clear report limits, as well as view or modify join types and evaluation order for report metrics.</td>
</tr>
<tr>
<td>Report Data Options</td>
<td>Displays the VLDB Properties dialog box, in which you can see the VLDB settings for a report.</td>
</tr>
<tr>
<td>VLDB Properties</td>
<td>Displays the Export Options dialog box, where you can select the application type, destination, and formatting options for exporting a report.</td>
</tr>
<tr>
<td>Export Options</td>
<td>Allows you to select the document type in which you want to export a report.</td>
</tr>
<tr>
<td>Export To</td>
<td></td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Filter</td>
<td>Displays the Attribute Qualification dialog box.</td>
</tr>
<tr>
<td>Edit</td>
<td>Increases the indent of an item in a filter.</td>
</tr>
<tr>
<td>Increase Indent</td>
<td>Decreases the indent of an item in a filter.</td>
</tr>
<tr>
<td>Decrease Indent</td>
<td>Moves the selected qualification up in the definition.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Moves the selected qualification down in the definition.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Used when a column or row is selected, it displays, for modification purposes, the editor (Metric Editor, Filter Editor, Custom Group Editor, and so on) applicable to that column or row.</td>
</tr>
<tr>
<td>Grid</td>
<td>Flips a column to a row position.</td>
</tr>
<tr>
<td>Edit</td>
<td>Flips a row to a column position.</td>
</tr>
<tr>
<td>Move to Row</td>
<td>Moves a column or row to an existing report page.</td>
</tr>
<tr>
<td>Move to Column</td>
<td>Moves a column one position to the left.</td>
</tr>
<tr>
<td>Move to Page</td>
<td>Moves a column one position to the right.</td>
</tr>
<tr>
<td>Move Left</td>
<td>Displays the Grid Options dialog box.</td>
</tr>
<tr>
<td>Move Right</td>
<td></td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Display Outline Results*</td>
<td>Click to display the report result in outline mode.</td>
</tr>
<tr>
<td>Merge Header Cells</td>
<td>Hides/shows full column and row headers.</td>
</tr>
<tr>
<td>Lock Row Headers</td>
<td>Combines together identical row or column headers.</td>
</tr>
<tr>
<td>Lock Column Headers</td>
<td>Allows continued display of row headers while scrolling right or left across a report.</td>
</tr>
<tr>
<td>Auto Style Selected</td>
<td>Allows continued display of column headers while scrolling up or down on a report.</td>
</tr>
</tbody>
</table>

*Display Outline Results is enabled when the following conditions are met:

1. There is more than one attribute on the rows
2. Metrics are not on the rows.

**Page Setup window, Header/Footer tab controls**

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose font</td>
<td>Opens a standard font selection window, which enables you to make changes to the currently selected text. If no text is selected, the changes are used as the default for the Header/Footer tab.</td>
</tr>
<tr>
<td>Insert page number</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current page number when printed.</td>
</tr>
<tr>
<td>Insert number of pages</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the total number of pages when printed.</td>
</tr>
<tr>
<td>Insert date</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current date when printed.</td>
</tr>
<tr>
<td>Insert time</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current time when printed.</td>
</tr>
<tr>
<td>Insert project name</td>
<td>Inserts at the cursor location the name of the current project.</td>
</tr>
<tr>
<td>Insert report name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current report name when printed.</td>
</tr>
<tr>
<td>Insert template name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current template name when printed.</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Insert filter name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current filter name when printed.</td>
</tr>
<tr>
<td>Insert filter details</td>
<td>Inserts filter details at the cursor location.</td>
</tr>
<tr>
<td>Insert image</td>
<td>Opens a file selection window that allows you to locate and select an image file (.bmp, .gif, or .wmf) to be inserted at the cursor location. No resizing of the image is performed. For example, if the left header box contains an image that spans the entire page, the image will overwrite any text you type in the center and right header boxes.</td>
</tr>
</tbody>
</table>
The Prompt Generation Wizard

What is it?

The Prompt Generation Wizard is the tool that MicroStrategy Desktop makes available for prompt creation.

How can I access it?

To access the Prompt Generation Wizard, from the File menu, point to New and then choose Prompt.

What can I do with it?

With the Prompt Generation Wizard you can:
• create and name a new prompt
• set conditions for prompt usage
• display and review a prompt

For instructions on completing one of the above tasks, refer to the following How do I...? topic:
Prompts
**What should I know before I use it?**

Before you use the Prompt Generation Wizard, you should familiarize yourself with:

- the purpose of prompt generation
- the definition of an object in the context of MicroStrategy 7
- attribute hierarchies and attribute elements
- the nature and purpose of search objects
- qualifying information in terms of:
  - attribute forms
  - metric values
  - rank or percent

For more information on the above topics, refer to the following Concepts section:
Prompts

**Prompt Generation Wizard layout**

The Prompt Generation Wizard consists of:

- a primary page
- a series of secondary pages

**The primary page**

The Prompt Generation Wizard primary page consists of three areas:

- A list from which you can select the type of prompt to create. Prompt-type options include:
  - filter definition
  - object
  - value
  - level

- A description area that explains the function of the prompt type currently selected from the list

- A set of buttons (Help, Cancel, Back, Next, and Finish) to enable navigation across the various prompt-definition pages
Prompt definition pages

Each prompt-type option includes:

- One or more pages to search and select desired prompt components
- A page to specify general properties for the prompt

**Note:** Filter definition prompts include an option for allowing the user to select default answers for the prompt. Prompts for which you have this option are called expression prompts.

Defining prompts

The information that follows describes the format and flow of each of the prompt-definition options available.

Filter definition prompts: Choose from all attributes in a hierarchy

These prompts allow users to qualify on attributes and elements from a specific hierarchy, all hierarchies in the project, or hierarchies returned by a search object to reduce the number of attributes available at run time.

With this type of prompt, you can either qualify on one or more attribute elements or identify elements in (or not in) a list.

When you select this prompt type and press Next, the Prompt Generation Wizard displays a page on which you can select a hierarchy for run-time qualification by doing one of the following:

- entering the name of a hierarchy
- clicking the browse button and then selecting a hierarchy from a list
- entering the name of a search object
- clicking the browse button and then selecting a search result
- choosing the Select all hierarchies option, which displays all attributes

This page also provides an option for choosing default answers for the prompt.
After you select a hierarchy for report qualification, clicking Next takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

Once you are done defining the prompt, clicking Finish takes you to the Save As dialog, where you can select where you want to save the prompt definition.

**Filter definition prompts: Qualify on an attribute**

With these prompts you can qualify on an attribute and a specific form for that attribute.

When you select this prompt type and press Next, the Prompt Generation Wizard displays a page on which you can select an attribute for run-time qualification by doing one of the following:

- entering the name for the attribute
- clicking the browse button and selecting an attribute from those available
- entering the name of a search object
- clicking the browse button and then selecting a search object.

This page also provides an option for choosing default answers for the prompt.

After you select an attribute for qualification, clicking Next takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

Once you are done defining the prompt, clicking Finish takes you to the Save As dialog, where you can select where you want to save the prompt definition.

**Filter definition prompts: Choose from an attribute element list**

Attribute element lists allow you to create an in-list filter that allows users to decide at run time which elements to include. You limit run-time user choices by using one of the following element-list options:

- all-inclusive
- filtered
- predefined
When you select this prompt type and click **Next**, the Prompt Generation Wizard shows a page on which you can select an attribute for run time qualification by either

- entering an attribute name
- clicking the browse button and selecting an attribute

Once you have selected an attribute for the element list, clicking **Next** takes you to the page in which you can select how to limit element availability. On this page, you also have the option to check the **Choose default prompt answers** box.

When you have selected a list of element for qualification, clicking **Next** takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

Once you are done defining the prompt, clicking **Finish** takes you to the **Save As** dialog box.

**Filter definition prompts: Qualify on a metric**

You select metric qualification when you want to either apply a specific metric or use a search object to qualify on one.

When you select this prompt type and click **Next**, the Prompt Generation Wizard shows a page where you can do one of the following:

- enter the name of a metric object you wish to use
- use the browse button to select a metric object from a list
- enter the name of a metric search object
- use the browse button to select a metric search object from a list

This page also provides an option for choosing **default answers** for the prompt.

When you have selected a metric for qualification, clicking **Next** takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

Once you are done defining the prompt, clicking **Finish** takes you to the **Save As** dialog, where you can select where you want to store the prompt you have just defined.
Object prompts

Object prompts allow you to use either a pre-defined list or the results of a search to limit the number of objects available at run time.

When you select this prompt type and click Next, the Prompt Generation Wizard shows a page from which you can select to use either a search result or a predefined object list to restrict the number of objects displayed at run time. This page also provides an option for choosing default answers for the prompt.

Note: Restricting the number of objects to be displayed can serve a number of purposes, including:

- performance improvement
- security
- display simplification

Once you have either created a predefined list or selected a search object, Next takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

When you are done defining the prompt, clicking Finish takes you to the Save As dialog, where you can select where you want to store the prompt you have just defined.

Value prompts

You select value prompts when you want to use date, numeric, or string data values.

When you select this prompt type and click Next, the Prompt Generation Wizard shows a page where you can select a data type on which to prompt. Data-type choices include Date, Numeric, and String prompts. The paragraphs that follow describe these prompt selections.

Date: to qualify on date or time intervals, choose Date prompt and click Next. The Report Generation Wizard takes you to a page where you can set the default date to be used at run time, as well as acceptable minimum and maximum (earliest and latest) values for date-related data.
**Note:** If you click the **Calendar** icon at the right end of the **Default value** entry area of this page, you access the **Date Editor**. Using the Date Editor, you can select either:

- a **static** date (that is, a fixed point in time)
- a **dynamic** date (that is, either a date or a time range meeting specific offset conditions)

---

**Numeric:** If you elect to qualify on a numeric value for a metric, choose **Numeric prompt** and click **Next**. The Report Generation Wizard takes you to a page where you can set the default numeric value to be used at run time, as well as acceptable minimum and maximum (highest and lowest) values for numeric data.

**Text:** If you elect to qualify report information on **attribute forms**, choose **Text prompt** and click **Next**. The Report Generation Wizard takes you to a page where you can set the default text length to be used at run time, as well as acceptable minimum and maximum (longest and shortest) values for text strings.

After you have set default, minimum, and maximum values, clicking **Next** takes you to a page where you can enter the general properties for the prompt you are defining (title, description, modifications to existing web options, and whether an answer at run time is to be mandatory).

Once you are done defining the prompt, clicking **Finish** takes you to the **Save As** dialog, where you can select where you want to store the prompt you have just defined.

---

**Note:** Although **long** prompts are not available as a selection within the Prompt Generation Wizard, you can enable them through the check box available for the purpose under **Prompts** in the **Project Preferences** dialog box.

---

**Level (dimensionality) prompts**

You select a level prompt when you want to prompt on the dimensionality of a metric. This option allows you to use a pre-defined list, the results of a search, or a complete list of available attributes and hierarchies to define the level prompt.
When you select this prompt type and click Next, the Prompt Generation Wizard shows a page from which you can select to use either a search result, a predefined list, or all attributes and hierarchies available to define the prompt. This page also allows you to specify whether default values are to be selected as answers.

After you have created a predefined list, selected a search object, or opted to include all attributes and hierarchies, clicking Next takes you to a dialog where you can.

Once you are done defining the prompt, clicking Finish takes you to the Save As page, where you can select where you want to store the prompt you have just defined.
**Custom Group Editor**

**What is it?**

The **Custom Group Editor** allows you to create and modify custom groups.

**How can I access it?**

To access the **Custom Group Editor**, from the **File** menu, point to **New** and then choose **Custom Group**.

**What can I do with it?**

Through the Custom Group Editor, you can:

- create a custom group
- create a custom group banding qualification
- create a custom group element
- create a filter, metric, advanced or attribute qualification

For instructions on completing one of the above tasks, refer to the following **How do I...?** topic:

Custom Groups

**What should I know before I use it?**

Before you use the Custom Group Editor, you should familiarize yourself with:

- the purpose of custom groups
- the various parts of a custom group - the elements and header
- the purpose and use of the qualification types

For more information on the above topics, refer to the following **Concepts** section:

Custom Groups
Custom Group Editor layout

The Custom Group Editor is comprised of the following areas:

• A Custom Group Definition area, used to display the custom group definition.
• A Custom Group Options window, used to select the type of qualification.
• An Attribute qualification window, used to define an attribute qualification
• A Metric qualification window, used to define a metric qualification
• A Shortcut to a Filter window, used to create a shortcut to an existing Filter
• An Advanced qualification* window, used to define an advanced qualification
• A Custom Group Banding qualification window, used to define a custom group banding qualification

Note: The Advanced qualification option is not shown as default. To view the advanced qualification option, your administrator must select the option from the Editors tab of the Project Preferences dialog box.

Custom Group Definition

The Custom Group Definition window displays the custom group elements for a defined custom group. Within this window you can see the custom group element headers and their associated qualifications. From this area you can access the following dialog boxes:

• Custom Group Options

You can also drag and drop objects from the Object Browser directly into this window. Depending upon the object dragged, one of the following dialog boxes can be accessed directly from this area:

• Attribute Qualification
• Metric Qualification
• Shortcut to a Filter
• Advanced Qualification
• Custom Group Banding Qualification
Custom Group Options

To view this dialog box, double-click the phrase [Add Qualification] in the Custom Group Definition window. From this window you can select the type of qualification you wish to add to the custom group. Any of the following windows can be accessed from this area:

- Attribute Qualification
- Metric Qualification
- Shortcut to a Filter
- Advanced Qualification
- Custom Group Banding Qualification

Attribute Qualification

The Attribute Qualification window displays three option boxes. The first option box, labeled Attribute, displays the name of the attribute you are qualifying on. A browse button on the right-hand side of the blank allows you to change the attribute.

The second option box, labeled Qualify On, is a drop-down list displaying the available items to qualify on, for example, Elements, ID, DESC.

The third option box is where the Operator is selected. If you select Elements from the Operator box, you must first Add elements to the Elements List. Select In list if you want only the elements that you added to the Elements List, but select Not in list if you want all of the elements not added to the Elements List.

Additionally the Prompt button, when selected, opens the Prompt Generation Wizard.

Metric Qualification

From the Metric Qualification window you can choose a metric, the function to qualify on and the operator. You can also select a value, simple prompt, or expression to define the selected metric.
Any of the following windows can be accessed from this area:

- Open: allows you to select an attribute to qualify on.
- Prompt Generation-Choose a Prompt: part of the Prompt Generation Wizard, allows you to prompt on the selected attribute.
- Level: use to set the output level and break by.
  - Output Level: use to set the rules to resolve the metric qualification.
  - Break By: use to choose the attribute level at which to restart counting the rank or percentage for a metric.

**Filter Qualification**

From this window you can choose a filter and modify its definition.

- Open: allows you to select an attribute to qualify on.
- Prompt Generation-Choose a Prompt: part of the Prompt Generation Wizard, allows you to prompt on the selected attribute.

**Advanced Qualification**

From this window you can qualify on either a Custom Expression or a Joint Element List.

**Custom Group Banding Qualification**

From this window you can choose a metric, the function to band on, and the banding type. Depending on the type you select, you also must define the start at and stop at numbers, the step size, the band count, and the banding points.

Any of the following windows can be accessed from this area:

- Open: Allows you to select an attribute to qualify on.
- Level: Use to set the output level and break by.
  - Output Level: Use to set the rules to resolve the metric qualification.
  - Break By: Use to choose the attribute level at which to restart counting the rank or percentage for a metric.

This window is accessed by clicking within the Custom Group Definition area of the editor, and allows you to name the header and set the custom group display options.
CHAPTER 15

Consolidation Editor

What is it?
The Consolidation Editor allows you to create, modify and delete consolidations.

How can I access it?
To access the Consolidation Editor, from the File menu, point to New and then choose Consolidation.

What can I do with it?
Through the Consolidation Editor, you can:
• create a consolidation
• create an element expression
• create a new consolidation element
• delete a consolidation element
• import a consolidation element
• validate a consolidation element expression

For instructions on completing one of the above tasks, refer to the following How do I...? topic:
Consolidations

What should I know before I use it?
Before you use the Consolidation Editor, you should familiarize yourself with:
• the purpose of consolidations
• consolidation elements
• element expressions

For more information on the above topics, refer to the following Concepts section:
Consolidations

Consolidation Editor layout

The Consolidation Editor is comprised of the following areas:

- Elements for this consolidation
- Selected element

Elements for this consolidation

This section lists the names and expressions for the consolidation elements. You can also choose to hide the expression and only view the name of the element. From within this section you can also rename, reposition, add, delete, or import elements. When you select an element or its expression, the Selected element section displays the expression and allows you to edit it.

From this section you can also select Import Elements to access the Select a Consolidation dialog box. This dialog box allows you to import a consolidation element into the Elements for this consolidation section, which adds the imported element to the consolidation.

Selected element

This section allows you to create, modify, clear and validate consolidation expressions. When opening this editor to create a new consolidation, the Selected element section is activated by clicking in the Elements for this consolidation section. Once activated, you can create an expression by dragging and dropping an attribute element from the Object Browser into this section. If you right-click an attribute element and drag it into this section, a pop-up menu appears with common expressions that you can select from. You may also type in the expression, or use the drag-and-drop along with manually typing in the remainder of the expression. You can validate the expression you create by clicking Validate, or remove the expression by clicking Clear.
Consolidation Editor toolbar and menu options

The following Consolidation Editor specific toolbar and menu options are available:

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>Click to validate the expression</td>
</tr>
<tr>
<td>Validate</td>
<td>Adds the selected element as a new consolidation element</td>
</tr>
<tr>
<td>Add as Element</td>
<td>Adds selected element into the selected expression</td>
</tr>
<tr>
<td>Add into expression</td>
<td></td>
</tr>
<tr>
<td>Elements</td>
<td></td>
</tr>
<tr>
<td>Add Element</td>
<td>Creates a new, empty consolidation element</td>
</tr>
<tr>
<td>Delete Element</td>
<td>Deletes the selected element</td>
</tr>
<tr>
<td>Rename Element</td>
<td>Click to rename the element</td>
</tr>
<tr>
<td>Import Element</td>
<td>Opens the Select a consolidation element dialog box.</td>
</tr>
<tr>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Collapse All</td>
<td>Collapses the list of elements, hiding the expression.</td>
</tr>
<tr>
<td>Expand All</td>
<td>Expands the list of elements, showing the expression.</td>
</tr>
</tbody>
</table>

Consolidation Editor toolbar and menu options 111
What is it?

The Document Editor allows you to create and modify documents by adding and removing reports from it and modifying its HTML layout.

How can I access it?

To access the Document Editor, from the File menu, point to New and choose Document.

Important: The Administrator must set a default directory for the Document layout file and XSLs before you can view the Document Editor. The Administrator must also grant you permission to access this default directory. If you receive an error message not allowing you access to the editor, please consult your Administrator.

What can I do with it?

Through the Document Editor, you can:
- add reports to a document
- modify the appearance of the document
- create a hyperlink
- create or modify a table
- edit the layout file’s source code directly (HTML)
- insert an image
- modify the object's view and XSL
- preview a document
- view hidden elements, and toolbar borders

For instructions on completing one of the above tasks, refer to the following How do I...? topic:
What should I know before I use it?

Before you use the Document Editor, you should familiarize yourself with:

• the definition of documents

For more information on the above topics, refer to the following Concepts section:
Documents

Document Editor layout

The Document Editor is comprised of the following main sections:

• Document Content
• Layout

Document Content

This pane allows you to see the characteristics of the reports contained within the document. When you create a new document, this pane is empty. To populate it, you must drag and drop a report object into the Layout pane. That object then appears under Document Content.

When an object is selected from either this pane or the layout pane, the following characteristics for the object are displayed under Document Content:

• the object name
• the view, such as grid or graph
• banding*
• the selected XSL

* This banding flag specifies whether or not banding should be applied to the report. The expected outcome is as follows:
You can modify all the above characteristics by right-clicking on the report object and then selecting the desired option.

### Layout

The **Document Editor** opens with an empty layout for new documents. You can use this layout, or replace it with one of your own; for example, you could import a layout from another product, such as FrontPage or HoTMetaL.

Depending on the view selected from the **View** menu, the pane could appear in one of the following formats:

- **Normal.** Provides the WYSIWYG (what you see is what you get) HTML editing. You can drag and drop tables, text, images and report objects, and you may also type directly in the layout pane. The HTML is generated automatically for you. Note that when you drag and drop report objects while in this view, they are displayed with an icon placeholder. This placeholder is replaced with the report when you select **Document** from the View menu, or execute the document in MicroStrategy Web.

- **HTML.** Displays the HTML source code for the document. Any edits made in the source code are immediately reflected in the Normal view. This source code can also be edited using third party tools, such as Microsoft FrontPage, and then imported into the Document Editor via the File menu.

- **Document.** Displays the document and executes the reports. To print the document showing the report data, not the placeholders, you must print in this view.

The interface of this editor can be customized to maximize usability, the HTML display area, or provide the best balance between these two extremes. From the **View** menu, the **Document Content** and **Object Browser** panes can be hidden to increase the usable workspace. Each of
the four toolbars can also be toggled on or off from the View menu. Because every toolbar button has a corresponding entry in the menu, the full functionality of the editor is available with all toolbars disabled.

The layout pane allows you to insert, modify, and delete the following items:

- report objects
- text
- images
- hyperlinks
- tables

You can also edit the color, font, alignment, indentation, bullets, numbering, and other formatting options for selected portions of the layout.

From this pane you can access the following dialog boxes:

- **Picture.** From the Insert menu choose Insert Picture; allows you to select the image, alternate text, layout, and spacing to be inserted.
- **Hyperlink.** From the Insert menu choose Hyperlink; allows you to select the hyperlink type and enter a URL.
Document Editor toolbar and menu options

The following Document Editor specific toolbar and menu options are available:

<table>
<thead>
<tr>
<th>Location and Name</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td></td>
</tr>
<tr>
<td>Import Layout File</td>
<td>Click to display the Open dialog box.</td>
</tr>
<tr>
<td>Save Layout File As</td>
<td>Saves the Layout file in the name and folder that you select.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td></td>
</tr>
<tr>
<td>Desktop Object View</td>
<td>Choose to display the report in either grid or graph mode.</td>
</tr>
<tr>
<td>Desktop Object Banding</td>
<td>Choose to add Banding to the report.</td>
</tr>
<tr>
<td>Desktop Object XSL</td>
<td>Click to display the Open dialog box.</td>
</tr>
<tr>
<td>Delete Desktop Object</td>
<td>Click to remove the object from the Document Editor.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td></td>
</tr>
<tr>
<td>Normal Edit View</td>
<td>Click to view the HTML WYSIWYG editing interface</td>
</tr>
<tr>
<td>HTML Edit View</td>
<td>Click to view the HTML source code for the document</td>
</tr>
<tr>
<td>Document View</td>
<td>Click to view a preview of the document</td>
</tr>
<tr>
<td>Run Document</td>
<td>Click to Run the document</td>
</tr>
<tr>
<td>Object Browser pane</td>
<td>Click to view or hide the Object Browser pane</td>
</tr>
<tr>
<td>Document Content Pane</td>
<td>Click to view or hide the Document Content pane</td>
</tr>
<tr>
<td>Standard Toolbar</td>
<td>Click to view or hide the Standard toolbar</td>
</tr>
<tr>
<td>Object Toolbar</td>
<td>Click to view or hide the Object toolbar</td>
</tr>
<tr>
<td>Format Toolbar</td>
<td>Click to view or hide the Format toolbar</td>
</tr>
<tr>
<td>Table Toolbar</td>
<td>Click to view or hide the Table toolbar</td>
</tr>
<tr>
<td>Hidden Table Borders</td>
<td>Click to view or hide the hidden table borders</td>
</tr>
<tr>
<td>Show / Hide Elements</td>
<td>Click to view or hide the hidden elements</td>
</tr>
<tr>
<td>Location and Name</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------</td>
</tr>
<tr>
<td><strong>Insert</strong></td>
<td>Click to open the <strong>Picture</strong> dialog box</td>
</tr>
<tr>
<td><strong>Insert Picture</strong></td>
<td>Click to open the <strong>Hyperlinks</strong> dialog box</td>
</tr>
<tr>
<td><strong>Hyperlink</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Format</strong></td>
<td>Click to choose your text formatting options and view the Font dialog box</td>
</tr>
<tr>
<td><strong>Font</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Alignment</strong></td>
<td>Click to align the text <strong>Left</strong>, <strong>Center</strong>, or <strong>Right</strong></td>
</tr>
<tr>
<td><strong>Decrease Indent</strong></td>
<td>Click to move selected text or object to the left</td>
</tr>
<tr>
<td><strong>Indent</strong></td>
<td>Click to move the selected text or object to the right</td>
</tr>
<tr>
<td><strong>Font Color</strong></td>
<td>Click to open the <strong>Color</strong> dialog box</td>
</tr>
<tr>
<td><strong>Highlight Color</strong></td>
<td>Click to open the <strong>Color</strong> dialog box</td>
</tr>
<tr>
<td><strong>Numbered List</strong></td>
<td>Click to create or remove a numbered list</td>
</tr>
<tr>
<td><strong>Bulleted List</strong></td>
<td>Click to create or remove a bulleted list</td>
</tr>
<tr>
<td><strong>Table</strong></td>
<td>Click to open the <strong>Create Table</strong> dialog box</td>
</tr>
<tr>
<td><strong>Create</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Insert Row</strong></td>
<td>Click to insert a row directly under the selected row</td>
</tr>
<tr>
<td><strong>Delete Row</strong></td>
<td>Click to delete the selected row</td>
</tr>
<tr>
<td><strong>Insert Column</strong></td>
<td>Click to add a column directly to the left of the selected column</td>
</tr>
<tr>
<td><strong>Delete Column</strong></td>
<td>Click to delete the selected column</td>
</tr>
<tr>
<td><strong>Insert Cell</strong></td>
<td>Click to insert a cell</td>
</tr>
<tr>
<td><strong>Delete Cell</strong></td>
<td>Click to delete a cell</td>
</tr>
<tr>
<td><strong>Merge Cells</strong></td>
<td>Click to combine selected cells into a single cell</td>
</tr>
<tr>
<td><strong>Split Cells</strong></td>
<td>Click to separate the selected cells</td>
</tr>
</tbody>
</table>
How do I...?

The topics in this section include:

- Templates
- Filters
- Metrics
- Reports
- Prompts
- Custom Groups
- Consolidations
- Documents
Add pages to the template

**Steps**

1. Open the Template Editor.
2. From the View menu, choose Show Pages. The page section appears under Template definition.
3. From the Object Browser, select the object you wish to include in the page section, and drag and drop it into the section labeled Drop Page Fields Here. Refer to the section below entitled Rules for a list of objects that can be used as page fields.

**Rule**

Only the following objects can be used as page fields:

- Attributes
- Metrics
- Hierarchies
- Consolidations
- Object Prompts (Attribute)
- Object Prompts (Metric) - This object type can only be used as a page field if the row or column does not have a metric.
- Object Prompts (Hierarchy)
- Object Prompts (Consolidation)
**Change the evaluation order from the Template Editor**

**Steps**

1. Open the Template Editor.
2. Add a metric to the Template definition area. If you are using a previously saved template with a metric already in the Template definition area, continue with step three.
4. Select the Evaluation Order tab.
5. Clear the Show consolidations only checkbox.
6. Click the cell under the Evaluation Order column for the metric you wish to change. A drop-down arrow appears. Click the drop-down arrow and then select from the menu that appears.
7. Click OK.

**Clear report limits from the Template Editor**

**Steps**

1. Open an existing template that contains a set report limit.
2. From the Data menu, choose Report Data Options.
3. From the Report Limit tab, choose Clear Report Limit. All listed limits are cleared.
Create a report limit from the Template Editor

Steps

1. Open the Template Editor.
2. If a metric is not already on the template, add a metric to the Template definition area.
3. From the Data menu, choose Report Data Options.
5. Double-click in the Limit Definition area of the editor. The Metric Qualification dialog box opens.
6. Add a metric to the Metric box.

Do one of the following:

- In the Metric box, type in the desired metric name. Click OK. A new Metric Qualification dialog box opens.
- Click the browse button. The Open dialog box opens. Navigate to the desired metric’s location and select the metric. Click OK. A new Metric Qualification dialog box opens.
- From the Object Browser pane, navigate to the metric’s location. Drag the metric into the Metric box. A new Metric Qualification dialog box opens.

7. In the Function box, select Metric Value, Rank, or Percent.
8. From the Operator box, select an operator.
9. From the Value box, select value, simple prompt, or custom. If you select custom or expression, enter an expression or value in the box. If you select simple prompt complete the simple prompt definition when the Prompt Generation Wizard opens.
10. Click OK.
11. To save and name your new report limit, from the File menu, click Save.
Create a template using the Template Editor

**Steps**

1. Open the Template Editor.
2. From the Object Browser, navigate to the object you wish to place on the template. Refer to the Concepts chapter on Templates for a list of acceptable objects.
3. Following the rules for template object placement, drag and drop, or double-click the desired objects to move them onto the template (see Rules).
   - To create a crosstab template, drag and drop the objects into the template as both row and column headers.
   - To create a tabular template, double-click an object to have it automatically placed in the template in a tabular format. If you prefer to drag and drop the objects, place them in the template in the column header position.
4. When you are satisfied with the layout of your template, from the File menu, click Save. The Save Template As dialog box opens.
5. Using the Save in box, navigate to the location you wish to save the template. In the Object name box, type a name to identify the new template, and click Save.

Hide pages

**Steps**

1. Open the Template Editor.
2. From the View menu, choose Show Pages. The page section is removed from Template definition.
Lock column headers

Steps

1. Open the Template Editor.
2. From the Grid menu, choose Lock Column Headers.

Note: If the button already appears selected (a box appears around the icon), then the headers are already locked. Selecting the icon in this state unlocks the column headers.

Lock row headers

Steps

1. Open the Template Editor.
2. From the Grid menu, choose Lock Row Headers.

Note: If the button already appears selected (a box appears around the icon), then the headers are already locked. Selecting the icon in this state unlocks the row headers.
Merge header cells on a template

**Steps**

1. Open the Template Editor.
2. From the Grid menu, choose Merge Header Cells.

Modify a template

**Steps**

1. Open the Template Editor.

**Add another object to the template**

**Steps**

1. From the Object browser box, navigate to the object you wish to place on the template. Refer to the Concepts chapter on Templates for a list of acceptable objects.
2. Following the rules for object template placement, drag and drop, or double-click the desired object to move it onto the template.
3. When you are satisfied with the layout of your template, under File, click Save. The Save Template As dialog box opens.
4. Using the Save in box, navigate to the location you wish to save the template. In the Object name box, type a name to identify the new template, then click Save.

**Remove an object from the template**

**Steps**

1. In the template (under Template definition), select the object you wish to remove. The selected object changes to blue to indicate it is selected.
2. Either drag and drop the object back to the Object browser, or press DELETE. If you press DELETE, a dialog box opens asking if you are sure you wish to remove the object. Click Yes.

**Note:** When you drag and drop the object into the Object browser to remove it from the template, you do not have to first navigate to the objects folder. Objects can be removed from the Template definition section by dropping them anywhere in the Object Browser.

---

**Modify report limits from the Template Editor**

**Steps**

1. Open an existing template that contains a set report limit.
2. If a metric does not already appear on the template, add a metric to the template.
3. From the Data menu, choose Report Data Options.
5. Double-click the limit in the Limit Definition area of the editor. The Metric Qualification dialog box opens.
6. (Optional) Select a new metric.

Do one of the following:

- In the Metric box, type in the desired metric name. Click OK.
- Click the browse button. The Open dialog box opens. Navigate to the desired metric’s location. Click OK.
- From the Object Browser pane, navigate to the metric’s location. Drag the metric into the Metric box. Click OK.
7. (Optional) Modify the function. In the Function box, select Metric Value, Rank, or Percent.
8. (Optional) Select a different operator. From the **Operator** box, choose an operator.

9. (Optional) Select a different value. From the **Value** box, select value, simple prompt, or custom. Enter an expression or value in the box, or complete the simple prompt definition.

10. Click **OK**.

11. To save and name your modified report limit, from the **File** menu, click **Save**.

---

**Open the Report Limit Editor**

**Steps**

1. Open the **Template Editor**.

2. If a metric is not already on the template, add a metric to the Template definition area.

3. From the **Data** menu, choose **Report Data Options**. The **Report Data Options** dialog box opens.

4. From the Report Limit tab, click **Modify**. The **Report Limit Editor** opens.

---

**Restore metric defaults from the Template Editor**

**Steps**

1. Open the **Template Editor**.

2. If a metric is not currently on the template, using the **Object Browser**, navigate to the desired metric’s location and then drag and drop a metric onto the template definition area.

3. From the **Data** menu, choose **Report Data Options**. The **Report Data Options** dialog box opens.

4. Click the Join Type tab, then click **Restore Metric Defaults**.
Select autostyles

Steps
1. Open the Template Editor.
2. From the Grid menu, choose Auto Style Selected, then select the desired style. The template immediately reflects the change in style.

Set banding options

Steps
1. Open the Template Editor.
2. From the Grid menu, select Options. The Grid Options dialog box opens.
3. From the General tab choose one of the banding options. If you choose Custom Banding, the Settings button is enabled. Click Settings to open the Banding Settings dialog box. If you choose No Banding, or Autostyle Banding, click OK to apply your banding choice and return to the Template Editor.
4. Select a banding preference.

Note: The banding criteria options vary slightly, depending upon what you select for the banding preference.

- If you select By rows for your Banding Preference: Select one of the following options for the banding criteria:
  - By number of rows: If this option is selected, specify the following settings:
    - Apply first color every ___ rows: Specifies the number of bands of the first color that will be put on the grid going down.
– **Apply second color every ** __ rows: Specifies the number of bands of the second color that will be put on the grid going down. The two colors are used alternately.

◊ **By row header:** If this option is selected, choose the desired header from the list. The bands that go down the grid are colored according to the groupings on the selected row.

• If you select **By columns** for your Banding Preference: Select one of the following options for the banding criteria:

◊ **By number of columns:** If this option is selected, specify the following settings:

– **Apply first color every ** __ columns: Specifies the number of bands of the first color that will be put on the grid going across.

– **Apply second color every ** __ columns: Specifies the number of bands of the second color that will be put on the grid going across. The two colors are used alternately.

◊ **By column header:** If this option is selected, choose the desired header from the list. The bands that go across the grid are colored according to the groupings on the selected column.

5. Regardless of what you select for the banding preference, the **Banding Colors** section lets you specify the two colors to be used for banding. For each color, click on the drop-down arrow to access a palette of color options. To apply these colors to the headers, select **Apply banding colors to headers**.

6. Click **OK** to apply your selections and return to the Grid Options dialog box. Click **OK** again to return to the Template Editor.

---

**Set metric formatting options**

**Steps**

1. Open the **Template Editor**.

2. From the **Grid menu** select **Options**. The **Grid Options** dialog box opens.

3. From the General tab, in the Metric headers and Metric values section select the options you wish to apply to the metric headers and values, then click **OK**.
Set the join type from the Template Editor

Steps
1. Open the Template Editor.
2. If metric is not already on the template, using the Object Browser, add a metric to the template definition area.
4. Select the Join Type tab.
5. Click the desired row under Join Type then select the desired join type from the drop-down menu.
6. Click OK.

Sort the data from the Template Editor

Steps
1. Open the Template Editor.
2. If an object does not already appear on the template, using the Object Browser, add an object to the template definition area.
3. From the Data menu, choose Advanced Sorting. The Sorting dialog box opens.
4. The Sorting dialog box has the following tabs: Rows and Columns. Click a tab to open it. Both tabs contain the same information, but one is applied to the columns, and one to the rows.
5. From the desired tab, click Add. One of the objects from the report appears under Sort By. Click Add again to add another row or column to sort by. For example, if you wish to sort by three objects, click Add three times.
6. To change the object listed under the Sort by, Order, Criteria, or Total Position column, click in the cell of the object you wish to change. A drop-down list box appears. From the list, select the object you wish to sort by.
7. If you have more than one object listed, the up and down arrows become active. Highlight a row and click the up or down arrow to move it up or down in the table.

8. To remove an object from the Row or Column sorts, select the object and click Remove.

Once the sort order is defined to your satisfaction, click OK.

View the attribute forms in the template

**Steps**

1. Open the Template Editor.

2. From the Grid menu, choose Long Names. The attribute forms appear in the template.

3. To turn off the long names, from the Grid menu, choose Long Names again.

---

**Notes:**

- This procedure assumes that you can not currently see the attribute forms (long names).
- To see an attribute form, an attribute must appear on the template.

---

View VLDB properties

**Steps**

1. Open the Template Editor.

2. From the Data menu, choose VLDB Properties. The VLDB Properties dialog box opens.
3. Under VLDB Settings, navigate to the desired VLDB option. The options and SQL, if applicable, appear in the right side of the dialog box.

View or modify attribute options

Steps
1. Open the Template Editor.
2. If an attribute is not already on the table, using the Object Browser, add an attribute to the template definition area.
3. From the Data menu, choose Attribute Display. The Attribute Display dialog box opens.
4. In the Attribute box, select the desired attribute whose form you wish to view or modify.
5. To use the default forms, select Use the attribute’s default display settings. The default form appears under Displayed forms. If you wish to use another form, select Use the following attribute forms.
6. Select the form of the attribute you wish to use from the available forms box.
7. Click the add (>) button to move the form to the Displayed forms box.
8. Click OK to apply your changes and return to the Template Editor.
Access the Level Editor

**Steps**

1. Open the Filter Editor.
2. Double-click in the **Filter definition** area. The **Filtering Options** dialog box opens.
3. Select **Add a metric qualification** and click **OK**. The **Metric Qualification** dialog box opens.
4. Add a metric to the **Metric** box by doing one of the following:
   - In the **Metric** box, type a metric name and click **OK**.
   - Click **...** to browse for a metric. Locate the metric you wish to use and click **OK**.
   - If you have the **Object Browser** visible, select and drag to the **Metric** box a metric from the **Object Browser**.
5. Click **Level** to access the **Level Editor**.
Activate advanced qualification options

Steps
1. Right-click a project and choose Preferences. The Project Preferences dialog box opens.
2. On the Editors tab, click Filter Options. The Filter Options dialog box opens.
3. Select the Show Advanced Qualification check box and click OK. You are returned to the Project Preferences dialog box.
4. Click OK.

Allow view of buttons for simple prompts

Steps
1. Right-click the desired project on the Folder List display of the MicroStrategy Desktop main window.
2. Select Preferences. The Project Preferences dialog box opens.
3. Select the Editors tab.
4. Click Filter Options. The Filter Options dialog box opens.
5. Select Show all available prompt buttons, and click OK.
Change the logical operator for a filter with multiple qualifications

To change the logical operator, you must first create two or more qualifications. Refer to the following How do I...? topics for step-by-step instructions:

- Create an attribute qualification
- Create a metric qualification
- Create an advanced qualification
- Create an object qualification

Steps
1. Open the filter in the Filter Editor.
2. In the Filter definition area, select the logical operator you wish to change.
3. On the Filter menu, point to Toggle Operator, then choose the desired logical operator.
4. Save the filter.

Create a filter

This procedure requires you to first create a qualification. Refer to the following How do I...? topics for step-by-step instructions for creating the following:

- Create an attribute qualification
- Create a metric qualification
- Create an advanced qualification
- Create an object qualification

Steps
1. Open the Filter Editor.
2. Double-click in the Filter definition area. The Filtering Options dialog box opens.
3. Select an option and click OK. The selected dialog box associated with the selected qualification opens.
4. When you have completed the qualification, click OK.

Create a metric prompt qualification

Steps
1. Open the Filter Editor.
2. Double-click in the Filter definition area. The Filtering Options dialog box opens.
3. Select Add a Metric Qualification and click OK. The Metric Qualification (Choose a Metric) dialog box opens.
4. Click either the Prompt icon or the Prompt button to open the Prompt Generation Wizard - (Choose a Prompt) dialog box.
5. Define the metric as described in:
   Create a “Qualify on a Metric” prompt

Create a metric qualification

Steps
1. Open the Filter Editor.
2. Double-click in the Filter definition area. The Filtering Options dialog box opens.
3. Select Add a Metric qualification, and click OK. The Metric Qualification dialog box opens.
4. Add a metric to the Metric box:
Do one of the following:

• Enter the name of a metric in the Metric box and click OK.
• Click browse. The system displays the Open dialog box, showing a list of available metrics. Select a metric and click OK.
• Select and drag a metric from the Object Browser box to the Metric box.

The system displays the name of the metric selected next to Metric, and shows boxes for Function and Operator entries.

5. Enter data for Function and Operator:

• For Function, select Metric Value, Rank, or Percent.
• For Operator, select an operator from the drop-down list.
• For Value, select Value, Simple Prompt, or Custom and enter a value or custom expression.

• The Prompt Generation Wizard opens when you click on either Simple Prompt, the Prompt button, or the prompt icon.

Click OK.

6. To save and name your new metric qualification, from the File menu, click Save. The Save Filter As dialog box opens.

7. Select a folder to save your new qualification, enter a name for it in the Object Name box, and click Save.

---

**Create a simple prompt metric qualification**

**Steps**

1. Open the Filter Editor.

2. Double-click Filter Definition. The Filtering Options dialog box opens.

3. Select Metric Qualification, and click OK. The Metric Qualification (Choose a Metric) dialog box opens.
4. **Add a metric** to the Metric box:

Do one of the following:
- Enter the name of a metric in the Metric box and click OK.
- Click **browse**, select a metric from the Open dialog box, and click OK.
- Select and drag a metric from the Object Browser to the Metric box.

The **Function** and **Operator** drop-down menus open.

5. Complete metric qualification as follows:

- For **Function**, select either **Metric Value**, **Rank**, or **Percent**.
- For **Operator**, select an operator from the drop-down list.
- For **Value**, select **Value**, **Simple prompt**, or **Custom**.

Click either **Simple Prompt**, **Prompt**, or the prompt icon. The system displays the Prompt Generation Wizard primary page.

6. **Select defaults and limits**:

   The Prompt Generation Wizard provides pages on which you can specify default values and valid input ranges for the prompt, as well as project level data (name, description, and answer options).

7. Click **Finish**, then **OK**.

8. To save and name a new metric qualification, Click **Save** from the **File** menu. The **Save Filter As** dialog box opens. Select a folder for the qualification, enter a name in the **Object Name** box, and click **Save**.

---

**Create an advanced qualification using the Filter Editor**

You must first enable the advanced qualification option from the Project Preference dialog box. For step-by-step instructions, see the following how do I in this chapter:

Activate advanced qualification options

**Steps**

1. Open the **Filter Editor**.
2. Double-click in the Filter definition area. The Filtering Options dialog box opens.

3. Select Add an Advanced qualification and click OK. The Advanced Qualification dialog box opens.
Under **Choose an option**, select an option to qualify on:

- For **Custom expression**, you can do one of the following:
  
  ◊ Drag and drop filter, metric, or attribute objects from the **Object Browser** into the **Custom expression** box.
  
  ◊ Enter a filter expression in the **Custom expression** box.

You can either select operator buttons to place in your expression, or enter operators manually. Click **Validate** to validate the expression, **Clear** to delete the expression.

- For **Joint element list**, do as follows:
  
  ◊ Use the transfer (>) button to move selected attributes from the **Available attributes** list to the **Selected attributes** box.

  Selected attributes are automatically added to the **Element list**. To modify the **Element list**, do as follows:
  
  – -- click the **Add** icon to add elements to the Element list
  
  – -- select an element and click the **Modify** icon to modify an element in the list
  
  – -- click the **Remove** icon to remove the attribute element(s) from the **Element list**

5. Click **OK**.

6. To save and name an attribute qualification, do as follows:

   - select **Save** from the **File** menu. The **Save Filter As** dialog opens.
   
   - select a folder to save the qualification, enter a name for the qualification in the **Object Name** box, and click **Save**.

---

**Create an attribute qualification**

**Steps**

1. Open the **Filter Editor**.

2. Double-click in the **Filter definition** area. The **Filtering Options** dialog box opens.
3. Select **Add an Attribute qualification**, and click OK. The **Attribute Qualification** dialog box opens.

4. **Add an attribute** to the Attribute box:

Do one of the following:

- Enter the name of an attribute in the **Attribute** box and click OK.
- Click **browse** and select an attribute from the list, then click OK.
- Select and drag an attribute from the **Object Browser** to the **Attribute** box.

The system displays the **Qualify on** and **Operator** option areas.

5. Complete the attribute qualification as follows:

- for **Qualify On**, select a **form** for the attribute. If you select elements, you must add elements to the **Element List** section. The value box does not appear if you select elements.
- for **Operator**, select the desired operator. The list of available operators change based on what form you choose to qualify on.
- for **Value**, select **Value**, **Simple Prompt**, or **Custom**

Click OK when you have completed the attribute’s specification.

6. Save and name the attribute qualification:

- Select **Save** from the **File** menu, select a folder for the qualification, enter a name for the qualification, and click **Save**.

---

Create an attribute-to-attribute qualification

**Steps**

1. Open the **Filter Editor**.

2. Double-click in the **Filter definition** area. The **Filtering Options** dialog box opens.

3. Select **Add an Attribute qualification** and click OK. The **Attribute Qualification** (Choose an Attribute) dialog box opens.

4. **Add an attribute** to the Attribute box:
Do one of the following:

- Enter the name of an attribute in the Attribute box and click OK.
- Click browse and select an attribute from the list, then click OK.
- Select and drag an attribute from the Object Browser to the Attribute box.

The system displays the Qualify on and Operator option areas.

5. Complete the attribute qualification as follows:

- for Qualify On, select a form for the attribute. If you select elements, you must add elements to the Element List section. The value box does not appear if you select elements.
- for Operator, select the desired operator. The list of available operators change based on what form you choose to qualify on.
- for Value, select Value, Simple Prompt, or Custom

Click OK when you have completed the attribute’s specification.

6. Repeat steps 2 through 4 to complete qualification of the second attribute.

---

**Note:** The two qualifications, as shown under Filter definition, are separated by AND, which is the filter logic that the system applies to this type of qualification.

---

**Create an attribute qualification prompt**

**Steps**

1. Open the Filter Editor.

2. Double-click in the Filter definition area. The Filtering Options dialog box opens.
3. Select **Add an Attribute qualification** and click **OK**. The **Attribute Qualification** dialog box opens.

4. Identify an attribute for qualification:
   Do one of the following:
   • enter the name of an attribute in the **Attribute** box and click **OK**.
   • click **browse**, select an attribute from the list shown in the **Open** dialog box, and click **OK**.
   • select and drag an attribute from the **Object Browser** to the **Attribute** box.

5. Click **Prompt**. The **Prompt Generation Wizard** opens.

6. Ensure the desired attribute is listed in the **Attribute** box, then click **Next**.

7. TBD

8. Select **File / Save As** to provide an name and a folder location for the qualification.

---

**Create a filter qualification**

**Steps**

1. Open the **Filter Editor**.

2. Double-click in the **Filter definition** area. The **Filtering Options** dialog box opens.

3. Select **Shortcut to a Filter** and click **OK**. The **Shortcut to a Filter** dialog box opens.

4. Select a filter to qualify on:
Do one of the following:

- Enter the name of a filter in the Filter box and click OK.
- Click browse, select a filter from the list shown in the Open dialog box, and click OK.
- Select and drag a filter from the Object Browser to the Filter box.
- The system displays the filter selected under Filter definition.

5. Click OK.

6. To save and name the qualification, click Save As from the File menu. Select a folder, name the qualification, and click Save.

Create a filter qualification prompt

Steps

1. Open the Filter Editor.

2. Double-click in the Filter definition area. The Filtering Options dialog box opens.

3. Select Add a Shortcut to a Filter and click OK. The Shortcut to a Filter dialog box opens.

4. Click Prompt. The Prompt Generation Wizard opens.

5. Select a means of qualification:

Note: At this time, you can either select a filter or create a prompt. The results are identical.
Do one of the following:

- Select **Use a Pre-defined list of objects** and click **Add**. The **Select Objects** dialog box opens.
  - If you are using a predefined object list, select objects from the list displayed under **Available objects**, use the transfer button (>) to move them under **Selected objects** on the right, and click **OK**. The names and descriptions of objects selected are shown under **Use a Pre-defined list of objects**.

---

**Note:** The pre-defined list of objects cannot be empty; you must add one or more objects before continuing.

- Select **Use the results of a search object** and click **browse**. The **Open** dialog box opens.
  - If you are using the results of a search, select a search object and click **OK**. The name of the search object selected is shown under **Use the results of a search object**.

Click **Next**. The system displays a window in which you can provide a **title** and a **description** for the qualification, any necessary **modifications** to existing Web options, and expected actions for **prompt resolution**.

6. Click **Finish**. Check the prompt definition. If it is correct, click **OK**. If you need to edit the prompt definition, click **Edit Prompt**.

---

**Create an operator prompt**

**Steps**

1. Open the **Filter Editor**.
2. Double-click in the **Filter Definition** area. The **Filtering Options** dialog box opens.
3. Select **Add a Metric qualification** and click **OK**. The **Metric Qualification** dialog box opens.
4. Enter a metric for qualification:
   Do one of the following:
   • enter the name of a metric in the Metric box
   • click browse and select a metric from the list shown in the Open dialog box
   • select and drag a metric definition from the Object Browser to the Metric box

5. Enter function and operator data as follows:
   • for Function, select Metric Value, Rank, or Percent
   • for Operator, click the Prompt Generation Wizard - (Choose an operator prompt) icon. The system displays the Prompt Generation Wizard primary page.

6. Select a means to qualify objects:
   Do one of the following:
   • Select Use a Pre-defined list of objects and click Add. The Select Objects dialog box opens. Select objects for inclusion as follows:
     ◊ use the transfer arrow (> ) to move objects from the Available objects list to the Selected objects area on the right
     ◊ click OK. The objects you have selected appear in the Pre-defined list of objects box
**Set the break by for a metric’s rank operator**

**Steps**

1. Open the Filter Editor.
2. Double-click **Filter Definition**. The **Filtering Options** dialog box opens.

3. Select **Add a Metric Qualification** and click **OK**. The **Metric Qualification** (Choose a Metric) dialog box opens.

4. Add a metric to the **Metric** box:
   - Do one of the following:
     - enter the name of a metric in the **Metric** box
     - click **browse** and use the list in the **Open** dialog box to select a metric
     - select and drag a metric definition from the **Object Browser** to the **Metric** box
     - Click **OK**. The system redisplay the Metric Qualification dialog box, showing entry spaces for **Function** and **Operator** information

5. Enter function data: select either **Rank** or **Percent**.

6. Click **Level**. The **Level Editor** opens.

7. Select the **Break By** tab.

8. Select **Attributes** in the **Location** box. The list of attributes for the project is shown.

9. Select attributes by using the transfer arrow (>) to pass them from the Available objects list to the Selected objects area on the right

10. Click **OK**.

---

**Set default filter options**

By default, the settings are automatically checked. You would only have to set them if you had previously deselected them.

**Steps**

1. From the primary window **Folder List**, right-click your project name and select **Preferences**. The **Project Preferences** dialog box opens.

2. Select the **Editors** tab and click **Filter Options**. The **Filter Options** dialog box opens.
3. Select any of the following default settings:
   • show advanced qualification
   • show all available prompt buttons
   • show tips box on the qualification dialogs
   • trim leading spaces of a value

Click OK. Click OK again to close the Project Preferences dialog box.

**Trim leading spaces of a value**

By default, the setting is automatically checked. You only have to set them if you had previously deselected them.

**Steps**

1. Right-click a project on the Folder List display of the MicroStrategy Desktop main window.
2. Select Preferences. The Project Preferences dialog box is displayed.
3. Select the Editors tab. The tab options (Document, Filter, and Custom group) are shown.
4. Click Filter Options. The Filter Options dialog box opens.
5. Check Trim leading spaces of a value.

**Use the Level Editor to calculate output levels**

**Steps**

1. Open the Level Editor.

**Note:** The Level Editor is accessible from the Filter Editor only after you have selected a metric for qualification.
2. Select a level for output calculation:

Use the selection buttons to request one of the following options for output calculation:

- default dimensionality level (previously set)
- report level
- attribute list level

3. Click OK.
Create a metric

Steps

1. Open the Metric Editor.

2. From the Object Browser, double-click the object on which you want to apply the metric. The system displays default values for each of the four metric components (Formula, Level, Condition, and Transformation) in the Metric New Metric is defined as box.

3. Click each of the components applicable to the metric you want to define. The Metric Editor shows the corresponding component windows, where you can enter the appropriate definition values.

- Click Formula to identify the facts on which to apply the metric, and the type of aggregation the metric is to have. Enter values for this component as follows:
  - Operators and delimiters available on the selection bar ([], +, -, *, and /), as applicable, to define (or redefine) the metric.
  - Clear (if necessary) to discard an existing aggregation component value and enter a new one.
  - Validate to check the validity of your newly-defined metric (the Metric editor displays Valid expression, as a default, on the low-left corner of the Definition window).
• Click **Level (Dimensionality)** = to specify the attribute level at which the metric is to be applied. When entering values for this component:

• Double-click an object displayed on the **Object Browser** to add it to the Level window.
  ◊ Click **Remove** to discard the selected attribute level.
  ◊ Click **Reset** to apply the default level after discarding a specified level in a metric definition.
  ◊ Click **Advanced** to access the **Level (Dimensionality) advanced options** window, in which you can:
    – - allow other users to add extra units to this definition
    – - add attributes in the filter to the level (dimensionality)

• Click **Condition** = to specify what filter(s) you want to apply to the metric. When entering values for this component:
  ◊ Click **Browse** to open the **Select a Filter** dialog box, in which you can select a filter from the list displayed.
  ◊ Click **Edit** to modify the selected filter.
  ◊ Click **Clear** to discard the current filter.
  ◊ Click **Advanced** to access the **Condition advanced options** window, which allows you to select the embedding method and remove related report filter elements.

• Click **Transformation** = to apply an attribute-element offset for fact-comparison purposes (although transformations can be applied to any attribute hierarchy, the one on which offsets are used most often is **Time**, in which case the difference may be set as a fixed number of days, weeks, months or years). When entering values for this component you can use previously-set element-related information, or enter your own in the space provided.

  ◊ Double-click a transformation in the **Object Browser** to add it to the Transformation window.
◊ Click **Remove** to discard the current transformation definition.
◊ Click **Reset** to apply the default level after discarding a specified level in a metric definition.
◊ Use the directional arrows to change the position of transformation data being edited.

4. When you have completed the metric definition, select it under **Metric New Metric is defined as**, then click **Validate**. The **Metric Editor** displays a status message, at the bottom of the Definition area, showing whether the new metric definition is correct (Valid expression).

5. Click **Save and Close**. The **Metric Editor** displays the **Save As** dialog box, where you can specify in what folder and under what name you want the new metric saved.

---

**Display or hide the (metric) Object Browser**

**Steps**

1. Open the **Metric Editor**.
2. From the **View** menu, choose **Object Browser**.

If the window is hidden, the **Metric Editor** displays it; if the window is displayed, the **Metric Editor** hides it.

---

**Note:** The Object Browser by default is viewable.
Enable subtotals using the Metric Editor

**Steps**

1. Open an existing metric.

2. Select the Subtotals tab. The **Metric Editor** displays all available subtotal expressions.

3. Select one or more subtotal aggregations. Use the transfer arrows (>) and (>>) to select which of the applicable subtotals to enable (to select subtotals individually, click the single transfer arrow (>), to select all the subtotals available, click the double transfer arrow (>>).

4. When you have selected all the subtotals you wish to apply to the metric, click **Save and Close** on the **Metric Editor** toolbar. The **Metric Editor** saves your selection, which can now be applied whenever the metric is used.

Modify an existing metric

**Steps**

1. Open an existing metric.
2. Edit metric component values as necessary.
   • Click Formula to modify the aggregation type or aggregation components.
   • Click Level (Dimensionality) to modify the attribute level at which the metric is to be applied.
   • Click Condition to modify the definition of any filters applied to the metric.
   • Click Transformation to apply an attribute-element offset to the metric.
3. Click Save and Close. The system displays the Save As dialog box, where you can specify a location to save the modified metric.

Notes
   • Only the creator or “owner” of a metric can modify the definition of that metric. If you modify a metric that belongs to another user, you must save it under a different name, otherwise the Metric Editor will not accept it for saving.
   • When you create a new metric definition by extending the definition of an existing metric object, the newly-defined metric is considered to be an instance of the original one.

Select a join type for a metric

Steps
1. Open the Metric Editor.
2. Select Tools on the menu bar.
3. Select Metric join type from the Tools menu. The Metric Editor displays the Metric join type selection box.
4. Click either inner or outer.
5. Click OK. Your selection is saved as the default value for the metric join.
Select an advanced function for a metric

**Steps**

1. Open the **Metric Editor**.
2. Select the **Formula** tab (as this is the default tab for this editor, it should already be open).
3. Open the **Location** drop-down menu in the Object Browser.
4. Select **Functions and Operators**. The Metric Editor displays the Functions and Operators folders: Functions, Operators, and Plug-in-Packages.
5. Select a function from either the **Functions** folder or the **Plug-in-Packages** folder. The function you select is displayed in the Definition box.

**Note:** The **Functions** folder contains Rank and OLAP functions; the **Plug-in-Packages** folder contains statistical, mathematical, and financial functions.

Update a metric’s displayed values

**Steps**

1. Open an existing metric.
2. From the **View** menu, choose **Refresh**. The **Metric Editor** updates displayed values dynamically.
Use metric formatting functions: fonts

Steps

1. Open an existing metric.
2. From the Tools menu, choose Formatting. The Metric Editor displays the Formatting dialog box.

Note: You can also access the Formatting dialog box by clicking the Show Metric Format Properties Editor icon on the Metric Editor toolbar.

3. Select the Font tab. The Metric Editor shows the window in which you can define such font characteristics as name, style, type size, and alignment for the font to be applied to the metric you have selected.
4. Apply font properties as follows:
   • Select whether the font definition is to apply to the numeric values in
     the metric, or to the metric header.
   • Select the name, style, and size of the font to be applied (for example,
     for a header you could select Arial Bold 10 as the font).
   • If applicable, select a highlight style for the text (either underlined or
     strikethrough).
   • Select the alignment for displayed text (right, left, or center).
   • If applicable, select an alphabet for displayed text (Western, Greek,
     Cyrillic, and so on).
   • Select the color in which the text is to be displayed.

5. Save the font properties.
   Click OK. The Metric Editor saves the font definition you have entered.

Use metric formatting functions: numbers

Steps

1. Open an existing metric.

2. From the Tools menu, choose Formatting. The Formatting dialog box opens.

   **Note:** You can also access the Formatting dialog box by clicking the
   Show Metric Format Properties Editor icon on the Metric Editor toolbar.

3. Select the Number tab. The Metric Editor shows the window where
   you can define the way in which numbers are displayed on a selected
   metric.
4. Select a format from the list under Category. The Metric Editor shows the modifiers available for that number category (for example, if you select Fixed as the number category, you can determine the number of decimal places to be displayed, whether you want numbers to be separated every three decimal places, and whether negative numbers are to be allowed; if you select Currency as the category, you can determine the number of decimal places to be displayed, and choose the currency symbol from a list).

5. Click OK. The Metric Editor saves the display properties you have specified.

**Note**

If you wish to custom-define a number category, the Custom option allows you to enter the format of your choice for number display.

---

**Use metric formatting functions: patterns**

**Steps**

1. Open an existing metric.
2. Select a metric for formatting.
3. From the Tools menu, choose Formatting. The Formatting dialog box opens.

**Note:** You can also access the Formatting dialog box by clicking the Show Metric Format Properties Editor icon on the Metric Editor toolbar.

4. Select the Pattern tab. The Metric Editor shows the window where you can define the patterns to be displayed on a selected metric.
5. Define metric pattern properties.
   - Select whether the pattern definition is to apply to the cells containing numeric values for the metric, or to those containing the metric header.
   - Select the pattern that cells will contain from the 3 x 6 array of patterns displayed. Or if desired, select None.
   - Select a color for the cell pattern.
   - Select a color for the cell background.
   6. Click OK. The Metric Editor saves the pattern definition you have entered.

View a metric’s VLDB settings

**Steps**

1. Open an existing metric.
2. From the Tools menu, choose Advanced Settings, then click VLDB Properties. The VLDB Properties (Metric) - New Metric dialog box opens.
3. Expand the folder and then click the VLDB setting you want to view. The Metric Editor shows current values for that setting in the display area of the window, and the corresponding SQL code under SQL Preview.

View metric level (dimensionality) properties

**Steps**

1. Open the Metric Editor.
2. From the View menu, click **Show Level (Dimensionality)** Properties. The Metric Editor displays the metric level, filters, and grouping, if any.

**Note**

If the metric level (dimensionality) properties are visible, the View menu option will read **HideLevel (Dimensionality) Properties**.
Add a filter to a report

This procedure assumes that a filter has already been created. For instructions on how to create a filter, refer to the following How do I...? topic in the Filters chapter:

How do I create a filter

Steps

1. Open the report in the Report Editor.
2. Using the **Object Browser**, locate the filter you wish to add to the report and do one of the following to add the filter to the report:

◊ Double-click the filter to move it to the **Filter definition** area.

◊ Hold down the left mouse button and drag the filter from the **Object Browser** to the **Filter definition** area.

◊ Hold down the right mouse button and drag the filter from the **Object Browser** to the **Filter definition** area. Select one of the following options from the menu that appears:
  
  – **Add to Filter with shortcut**: Select this to add an object qualification with a shortcut (link) to the filter definition.

  – **Replace Filter with shortcut**: Select this to remove the current filter from the report and replace it with a shortcut (link) to this filter. Any changes made to the section are reflected on the original filter. For example, changing the contents of the filter is the same as opening the **Filter Editor** and modifying it.

  – **Replace Filter with a copy**: Select this to create a copy of the dragged filter that resides inside the report definition. The current filter is removed from the report definition and replaced with a copy of this filter.

3. Save the report.

---

**Add a page to a report**

**Steps**

1. Open the report using the **Report Editor**.

2. From the **View** menu, choose **Show Pages. Drop Page Fields Here** appears in the **Template definition** section.

3. From the **Object Browser**, select the object you wish to include in the page section, and drag and drop it into the section labeled **Drop Page Fields Here**. Refer to the Rule below for a list of objects that can be used as page fields.

4. Save the report.
**Rule**

Only the following objects can be used as page fields:

- Attributes
- Metrics
- Hierarchies
- Consolidations
- Object Prompts (Attribute)
- Object Prompts (Metric) - This object type can only be used as a page field if the row or column does not have a metric.
- Object Prompts (Hierarchy)
- Object Prompts (Consolidation)

**Add a template to a report**

This procedure assumes that a template has already been created. For instructions on how to create a template, refer to the following How do I...? topic in the Filters chapter:

How do I create a template

**Steps**

1. Create a template.
2. Open the report in the Report Editor.
3. Using the Object Browser, locate the template you wish to add to the report.
4. Select the template and drag it over to the Template definition section. The template is added to the report.
5. Save the report.

**Apply banding to a report**

**Steps**

1. Open the report.
2. From the Grid menu choose Options. The Grid Options dialog box opens with the General tab selected.

3. The default banding is Autostyle banding. To turn banding off, select No banding. To apply custom banding, click Custom banding then click Settings. The Banding Settings dialog box opens.

4. Depending on what you select for the banding preference, the banding criteria options vary slightly:
   - **By rows.** If you select By rows, you can select one of the following options for the banding criteria:
     - **By number of rows:** If this option is selected, specify the following settings:
       - **Apply first color every __ rows:** Specifies the number of bands of the first color that will be put on the grid horizontally.
       - **Apply second color every __ rows:** Specifies the number of bands of the second color that will be put on the grid horizontally. The two colors are used alternately.
     - **By row header:** Choose the desired header from the list. The horizontal bands on the grid are colored according to the groupings on the selected row.
   - **By columns.** Select one of the following options for the banding criteria:
     - **By number of columns:** Specify the following settings:
       - **Apply first color every __ columns:** Specifies the number of bands of the first color that will be put on the grid vertically.
       - **Apply second color every __ columns:** Specifies the number of bands of the second color that will be put on the grid vertically. The two colors are used alternately.
     - **By column header:** Choose the desired header from the list. The vertical bands on the grid are colored according to the groupings on the selected column.

5. You can specify the two colors to be used for banding in the Banding colors box. For each color, click on the drop-down arrow to access a palette of color options.

6. To apply colors to the headers, select Apply banding colors to headers.

7. Click OK. You are returned to the Grid Options dialog box.

8. Click OK.
Apply metric formatting options to a report

Steps
1. Open the report.
2. From the Grid menu, choose Options. The Grid Options dialog box opens.
3. Select the options you wish to apply to the metrics, then click OK.

Change the evaluation order from the Report Editor

Steps
1. Open the Report Editor.
2. Add a metric to the Template definition area of the report. If you are using a previously saved report with a metric already in the Template definition area continue with step three.
4. Select the Evaluation Order tab.
5. Clear the Show consolidations only check box.
6. Click the cell under the Evaluation Order column for the metric you wish to change. A drop-down arrow appears. Click the drop-down arrow and then select from the menu that appears.
7. Click OK.

Clear report limits

This procedure assumes a limit has already been set.

Steps
1. Open an existing report in the Report Editor.
2. From the Data menu choose Report Data Options.
3. From the Report Limit tab click Clear Report Limit. All listed limits are cleared.

Clear the sorts for a report

Steps
1. Open the report you wish to clear the sorts for in the Report Editor.
2. From the Data menu choose Clear Sorts.

Create a report

This procedure requires you to add or create a template or filter. For step-by-step instructions, refer to the Template and Filter How do I...? chapters.

Steps
1. Open the Report Editor.
2. Add or create a template.
3. If desired, add or create a filter.
4. From the File menu choose Save. The Save Report As dialog box opens. Navigate to the desired folder location, name the report and click Save.

Create a report limit

Steps
1. Open the Report Editor.
2. Using the Object Browser, add a metric to the Template definition area of the report. If you are using a previously saved report with a metric already in the Template definition area, continue with step three.
3. From the Data menu, choose Report Data Options.

5. Double-click in the Limit Definition area of the editor. The Metric Qualification dialog box opens.

6. Add a metric to the Metric box. Do one of the following:
   • In the Metric box, type in the desired metric name. Click OK. A new Metric Qualification dialog box opens.
   • Click the browse button. The Open dialog box opens. Navigate to the desired metric’s location. Click OK. A new Metric Qualification dialog box opens.
   • From the Object Browser, navigate to the metric’s location. Drag the metric into the Metric box. A new Metric Qualification dialog box opens.

7. In the Function box, select Metric Value, Rank, or Percent.

8. From the Operator box, select an operator.

9. From the Value box, select value, simple prompt, or custom. Enter an expression or value in the box, or complete the simple prompt definition.

10. Click OK.

Create a template using the Report Editor

Steps

1. Open the Report Editor.

2. Following the rules for object template placement (see Rule below), drag and drop, or double-click the desired objects to move them onto the template.
   • To create a crosstab template, drag and drop the objects onto the template as both row and column headers.
   • To create a tabular template, double-click an object. It is automatically placed in the template in a tabular format. If you want to drag and drop objects, place them in the column header position of the template.
**Note**

When you drag an object onto the template a horizontal or vertical line appears. A horizontal line indicates you are placing the object as a column header, and a vertical line indicates a row header.

**Rule**

Adding components successfully to a template’s layout requires that you become familiar with some basic template placement rules. The **Object** column lists the objects that can be used on a template. The **Rules** column lists the template placement rules for that object.

<table>
<thead>
<tr>
<th>Object</th>
<th>Rules</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attribute:</strong></td>
<td>Represents a specific level of data calculation or aggregation.</td>
</tr>
<tr>
<td>Examples:</td>
<td>• Region</td>
</tr>
<tr>
<td></td>
<td>• Week</td>
</tr>
<tr>
<td></td>
<td>• Department</td>
</tr>
<tr>
<td></td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td><strong>Consolidation:</strong></td>
<td>Custom grouping of attributes. Allows for “row math” between attributes.</td>
</tr>
<tr>
<td>Examples:</td>
<td>• Holiday colors</td>
</tr>
<tr>
<td></td>
<td>• Actual – Planned Sales</td>
</tr>
<tr>
<td></td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td><strong>Hierarchy:</strong></td>
<td>Enables dynamic substitution of attributes in a report.</td>
</tr>
<tr>
<td>Examples:</td>
<td>• Geography</td>
</tr>
<tr>
<td></td>
<td>• Product</td>
</tr>
<tr>
<td></td>
<td>• Time</td>
</tr>
<tr>
<td></td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td><strong>Metric:</strong></td>
<td>A calculation built from facts in the data warehouse.</td>
</tr>
<tr>
<td>Examples:</td>
<td>• Total Sales ($)</td>
</tr>
<tr>
<td></td>
<td>• Profit ($)</td>
</tr>
<tr>
<td></td>
<td>• Inventory (units)</td>
</tr>
<tr>
<td></td>
<td>Can be placed in a row, column or as a page.</td>
</tr>
<tr>
<td></td>
<td>All the metrics are grouped together and bound to one axis. You cannot have a metric as both a row and a column.</td>
</tr>
</tbody>
</table>
Embed a template in a report

This procedure requires that a template already be created. For instructions on how to create a template, refer to the How do I...? topic in the Templates chapter:

Create a template

**Steps**

1. Create a template.
2. Open the Report Editor.
3. Using the Object Browser, navigate to your template location.
4. Right-click the desired template, and drag it over to the Template definition section. A pop-up menu appears. Select Replace template with a copy.
Link a template to a report

This procedure requires that a template already be created. For instructions on how to create a template, refer to the How do I...? topic in the Templates chapter:

Create a template

Steps

1. Create a template.
2. Open the Report Editor.
3. From the Object Browser, navigate to your template location.
4. Right-click the desired template, and drag it over to the Template definition section. A pop-up menu appears. Select Replace template with shortcut.

Merge header cells on a report

Steps

1. Open the Report Editor.
2. From the Grid menu, choose Merge Header Cells.

Modify the attribute display

Steps

1. Open the Report Editor.
2. Using the Object Browser, add one or more attributes to the template. Refer to the topic “Create a template” located in the Templates chapter of the How do I...? section for step-by-step instructions.
3. From the Data menu, choose Attribute Display. The Attribute Display dialog box opens.
4. Select the desired attribute for the form you wish to view or modify from the Attribute drop-down list.

5. To modify the default setting, select Use the following attribute forms.

6. Select the form of the attribute you wish to use from the Attribute forms window then click the add (>) button to move the form under Displayed forms. You can remove a form from Displayed forms using the remove (<) button.

7. You can rearrange the order of the forms under Displayed forms by selecting a form then clicking the up or down arrow on the right hand side of the box.

8. Click OK.

Modify the Page Setup options

Steps
1. Open the Report Editor.
2. From the File menu, choose Page Setup.
3. The following buttons appear on each tab in the Page Setup window:
   • Print: Opens the Print dialog box.
   • Print Preview: Allows you to preview your report before printing.
   • Options: Opens a dialog box where you can view and configure the advanced settings for the selected printer.
4. On the Page tab, your options are:
   - **Orientation**: Select either **Portrait** or **Landscape**. The default is Portrait.
   - **Scaling**: Your options are:
     - “**Adjust to __% normal size**”: Scales the report by a percentage of its original size, from a minimum of 10% to a maximum of 400%. The default is 100%.
     - “**Fit to __ page(s) wide by __ page(s) tall**”: Scales the report to fit to a certain number of pages horizontally by a certain number of pages vertically.
   - **Page Numbering**: This option is used only with a header or footer that displays page numbers. It numbers the pages either automatically or starting with a page number that you specify. The default is **Automatic**, which starts with 1 and increases sequentially in increments of one.

5. On the Margin tab, your options are:
   - **Center on Page**: Select **Horizontally**, **Vertically**, or both. If neither option is selected, the report is positioned at the top left corner of the page.
   - **Margins**: The default page margins (Top, Left, Right, and Bottom) are all set to one inch. You can change some, all, or none of these margins as desired. These margins do not affect the placement of the header and footer.
6. On the Header/Footer tab, your options are:

- **Edit**: You can specify formatting options for both a header and a footer if desired.
- **Line Width**: Select the width of the line that appears beneath the header or above the footer (depending upon which one is currently selected). Your choices are:
  - None
  - Thin
  - Thick
- In the Header or Footer section are the following text boxes that correspond to a specific portion of the header or footer:
  - **Left Section**: Text is left-justified with respect to the width of the page.
  - **Center Section**: Text is centered with respect to the width of the page.
  - **Right Section**: Text is right-justified with respect to the width of the page.

At the bottom of this section is a list that contains up to 15 of the most recently used lines of custom text, as well as some lines that have been predefined. When more than one text box is used, the text for each box is separated by a comma.

Wordwrap occurs within each text box whenever more than one is used. If only one of the text boxes is used, wordwrap occurs only if the length of the text exceeds the width of the page.

- The toolbar enables you to create custom headers and footers easily. Each button is described in the table that follows this series of steps.

7. On the Grid tab, your options are:

- **Page Fields**: This option is available only when a report that has one or more page field items is being printed. Your options are:
  - **Displayed page field**: Only the information for the currently displayed page field item(s) of the report is printed. This is the default.
  - **Expand All page fields**: All pages of the report are printed. If the report has more than 10 attribute elements (for example, if you page by the Week attribute for an entire year of data), a warning message asks you to confirm that you want to print all of the pages of the report.
For either of these options, you can enable or disable the **Show page field titles** option.

- **Print on Each Page**: Select **Row Headings**, **Column Headings**, or both. For reports that span multiple pages, these options control whether the attribute headers are to be included on every page.

- **Print**: You can enable either, both, or neither of the following options:
  ◦ **Gridlines**: If enabled, this option displays gridlines in the printout.
  ◦ **Black and white**: If enabled, this option allows you to print in black and white on a color printer.

- **Page Ordering**: When a report spans multiple pages horizontally and vertically, you can choose the order in which the pages are printed. Your options are:
  ◦ **Down, then over**: One vertical series of pages is printed before moving to the top of the next vertical series of pages to be printed. This is the default.
  ◦ **Over, then down**: One horizontal series of pages is printed before moving to the beginning of the next horizontal series of pages to be printed.
### Page Setup window, Header/Footer tab

<table>
<thead>
<tr>
<th>Choose font</th>
<th>Opens a standard font selection window, which enables you to make changes to the currently selected text. If no text is selected, the changes are used as the default for the Header/Footer tab.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert page number</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current page number when printed.</td>
</tr>
<tr>
<td>Insert number of pages</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the total number of pages when printed.</td>
</tr>
<tr>
<td>Insert date</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current date when printed.</td>
</tr>
<tr>
<td>Insert time</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current time when printed.</td>
</tr>
<tr>
<td>Insert project name</td>
<td>Inserts at the cursor location the name of the current project.</td>
</tr>
<tr>
<td>Insert report name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current report name when printed.</td>
</tr>
<tr>
<td>Insert template name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current template name when printed.</td>
</tr>
<tr>
<td>Insert filter name</td>
<td>Inserts at the cursor location a placeholder that will be replaced by the current filter name when printed.</td>
</tr>
<tr>
<td>Insert filter details</td>
<td>Inserts filter details at the cursor location.</td>
</tr>
<tr>
<td>Insert image</td>
<td>Opens a file selection window that allows you to locate and select an image file (.bmp, .gif, or .wmf) to be inserted at the cursor location. No resizing of the image is performed. For example, if the left header box contains an image that spans the entire page, the image will overwrite any text you type in the center and right header boxes.</td>
</tr>
</tbody>
</table>
Modify the report limits

This procedure assumes a report limit has previously been set.

Steps

1. Open the Report Editor.
2. From the Data menu, choose Report Data Options. A qualification or metric must be added to the report for this option to be selectable.
3. From the Report Limit tab select the desired limit. Click Modify. The Report Limit Editor opens.
4. Double-click the limit in the Definition area of the editor. The Metric Qualification dialog box opens.
5. (Optional) Choose a different metric. Do one of the following:
   • In the Metric box, type in the desired metric name. Click OK.
   • Click the browse button. The Open dialog box opens. Navigate to the desired metric’s location. Click OK.
   • From the Object Browser pane, navigate to the metric’s location. Drag the metric into the Metric box.
6. (Optional) Modify the function. In the Function box, select Metric Value, Rank, or Percent.
7. (Optional) Select a different operator. From the Operator box, choose an operator.
8. (Optional) Select a different value. From the Value box, select value, simple prompt, or custom. Enter an expression or value in the box, or complete the simple prompt definition.
9. Click OK.

Open the Report Limit Editor

Steps

1. Open the Report Editor.
2. Add a metric to the Template definition area of the report. If you are using a previously created report with a metric already in the Template definition area continue with step three.


Preview a report before printing

Steps
1. Open the Report Editor.
2. From the File menu, choose Print Preview. The preview window opens displaying how your report will print.
3. The Print Preview window contains the following options:
   • Print: Click to view the Print dialog box.
   • Setup: Click to view the Page Setup dialog box.
   • Previous: Click to view the previous page.
   • Next: Click to view the next page.
   • Two Page: If two pages need to be printed, click to view both pages.
   • Zoom In: Click to enlarge the page in the preview window.
   • Zoom Out: Click to reduce the page in the preview window.
   • Close: Click to close the preview window and return to the Report Editor.

Remove a page field from a report

This procedure assumes the page fields are currently displayed.

Steps
1. Open the desired report in the Report Editor.
2. From the View menu, choose Show Pages. The Drop Page Fields Here section is removed from the Template definition section.

**Restore metric defaults from the Report Editor**

**Steps**

1. Open the Report Editor.
2. If a metric is not currently on the report, use the Object Browser to navigate to the desired metric’s location and then drag and drop a metric onto the Template definition area.
4. From the Join Type tab click Restore Metric Defaults.

**Run a report**

**Steps**

To run any report within the Reports folder of a project, perform one of the following actions:

- Double-click on a report.
- Right-click on a report and then choose Run Report.
- Select one or more reports and then click the Run Report button located in the toolbar.
- Select the desired report and from the File menu, choose Run Report.
Set the default presentation of graph report results

Steps
1. From the primary window Folder List, right-click on your project name and choose Preferences. The Project Preferences dialog box opens.
2. From the Reports tab choose Graph Options. The Graph Options dialog box opens.
3. From the Graph Options dialog box you can select the graph type and style, the font and line resizing options, default scrolling options, the graph width and height ratio, and the default Web display options.
4. Make your selections and click OK.

Select an autostyle for the report format

Steps
1. Open the Report Editor.
2. From the Grid menu, choose Auto Style Selected then select the desired style. The Template definition area changes to reflect your selected style.

Set the default presentation of grid report results

Steps
1. From the primary window Folder List, right-click on your project name then click Preferences. The Project Preferences dialog box opens.
2. From the Reports tab, choose Grid Options. The Grid Options dialog box opens.
3. This dialog box contains two tabs: General, and Drilling, described in detail below. From each tab you can make changes and then click OK to return to the Project Preferences dialog box. Click OK again to close the dialog box and return to the primary window.

**General.** From the General tab, you can choose the following defaults:
- report style
- minimum column width (in characters)
- wordwrap
- open the report in regular mode
- display long names
- merge header cells
- open the report in outline mode

**Drilling.** From the Drilling tab, you can choose the following defaults:
- enable report drilling
- choose the drilling options: drill anywhere, or drill down only
- choose to keep parent while drilling

---

**Set the join type using the Report Editor**

**Steps**

1. Open the Report Editor.
2. If there is no metric in the report, use the Object Browser to add a metric to the template definition area of the report.
3. From the Data menu, click Report Data Options. The Report Data Options dialog box opens.
4. Select the Join Type tab.
5. Click the desired row under Join Type and then select the desired join type from the drop-down menu.
6. Click OK.
Sort the data in a report using the Report Editor

**Steps**

1. Open the Report Editor.
2. If there is no object in the report, use the Object Browser to add an object to the Template definition area of the report.
3. From the Data menu, choose Advanced Sorting. The Sorting dialog box opens.
4. Select the desired tab based on what you would like to sort.
5. Click the Add button in the desired section. One of the objects from the report appears. Click Add again to add another row or column to sort by. For example, if you wish to sort by three objects, click Add three times.
6. To change the object listed under the Sort by, Order, Criteria, or Total Position column, click in the cell of the object you wish to change. A drop-down list box appears. From the list, select the object you wish to sort by.
7. If you have more than one object listed, the up and down arrows become active. Highlight a row and click the up or down arrow to move it up or down in the table.
8. To remove an object, select the object and click Remove.
9. Once the sort order is defined to your satisfaction, click OK.

View long names in the Report Editor

**Steps**

1. Open the Report Editor.
2. From the Grid menu, choose Long Names. The long names appear when an attribute is present in the template.
View a report as a graph

Steps
1. Open the Report Editor.
2. If there is no object in the report use the Object Browser to add an object to the Template definition area of the report.
3. From the View menu, choose Graph View. The report changes to the default graph view.

View a report as a grid

Steps
1. Open the Report Editor.
2. If there is not one already, using the Object Browser, add an object to the Template definition area of the report.
3. From the View menu, choose Grid View. The report changes to the default grid view.

View the report limit settings from the Report Editor

Steps
1. Open the Report Editor.
2. If there is not one already, using the Object Browser, add a metric to the template definition area of the report.
4. On the Report Limit tab, the report limit settings are listed under Report Limit settings.
CHAPTER 20
Create a “Choose from all attributes in a hierarchy” prompt

You use Choose from all attributes in a hierarchy filter definition prompts at runtime to restrict the set of attributes and elements available.

Steps
1. Open the Prompt Generation Wizard.
2. Select Filter definition prompt then Choose from all attributes in a hierarchy and click Next. The system displays a page on which you can select a hierarchy for qualification.
3. Do one of the following:

• Select **Choose a hierarchy object** and enter the name of the hierarchy you want to use for qualification.

• Select **Choose a hierarchy object** and click the (hierarchy) browse button. The **Open** dialog box opens, from which you can select a hierarchy for prompt use.

• Select **Use the results of a search object** and enter the name of the search object you want to use for qualification.

• Select **Use the results of a search object** and click the browse button. The **Open** dialog box opens, from which you can select a search object for prompt use.

• Select **List all hierarchies (no restrictions).**

4. (Optional) Check **Choose default prompt answers.** The wizard displays a page on which you can set default-answer conditions, including the minimum and maximum number of answers to be allowed.

5. Click **Next.** The wizard displays a page on which you can enter project-level data to identify the prompt:

• a title

• a description

• modifications to current web options

• whether an answer is to be required at run time

**Note:** If **Minimum qualifications** is a value other than 0, answering the prompt is not an option: the **Prompt answer is required** check box is grayed out.

6. Click **Finish** when you have completed prompt identification. The **Save As** dialog opens.

7. Enter a name and location for the prompt, and click **Save.** The prompt is saved in the folder you selected.
Create a “Choose from an attribute element list” prompt

The attribute element list prompt allows you to restrict the attribute elements displayed to the user at run time. You implement this restriction either through the use of a filter or by creating a predefined list.

Steps

1. On the File menu, point to New, then choose Prompt. The Prompt Generation Wizard opens.

2. Select Filter definition prompt.

3. From the list of filter definition prompts, select Choose from an attribute element list and click Next.

4. Select an attribute for qualification. Do one of the following:
   ◊ Enter the name of the attribute on which you want to qualify and click Next.
   ◊ Click ... to select an attribute from a list of available attributes. Select an attribute and click OK. Click Next.

5. Select how you wish to restrict the list of attribute elements. Do one of the following:
   ◊ Select List all elements (no restrictions).
   ◊ Select Use a filter to reduce the number of elements and enter a filter name in the entry box (or browse for one by clicking ...).
   ◊ Select Use a pre-defined list of elements and click Add. The Select Elements dialog box opens, where you can choose which elements to make available to the user at run time.
6. If you wish to specify default answers for the prompt, check the **Choose default prompt answers** check box and click **Next**. You have the option to do the following:

◊ To specify default prompt answers, click **Add**. The **Select Objects** dialog box opens. From the list of available objects, select the attribute elements to be used as default values for the prompt and click > to add the to the list of selected objects. Click **OK** when you are finished.

◊ If you wish limit the minimum and maximum number of elements a user allowed to choose, check the appropriate check box and set the limit.

7. Click **Next**.

8. Enter the following information about the prompt:

◊ a title

◊ a description

9. Click **Modify** to determine how the prompt will appear in MicroStrategy Web. The **Choose a Prompt Style** dialog box opens. Select a prompt style and click **OK**.

10. If you wish for this prompt to require an answer, select the **Prompt answer is required** check box.

---

**Note:** If **Minimum qualifications** is a value other than 0, answering the prompt is automatically required and the **Prompt answer is required** check box is grayed out.

---

11. Click **Finish** and save the prompt.

---

**Create a Level prompt**

**Steps**

1. Open the **Prompt Generation Wizard**.

2. Select **Level prompt** and click **Next**. The **Prompt Generation Wizard** displays a page on which you can enter specifics to reduce the number of attributes and hierarchies available at run time.
3. Select how to reduce the number of attributes and hierarchies available at run time. Do one of the following:

- Select **Use a pre-defined list of objects** and click **Add** to select objects.
- Select **Use the results of a search object** and enter the name of a search object you wish to use.
- Select **Use the results of a search object** and click the browse button. The **Open** dialog box opens, from which you can select a search object.
- Select **Use the results of a search object** and click **New**. The **Search for Objects** dialog box opens, where you can specify search criteria and save your entry as a new search object.
- Select **List all attributes and hierarchies (no restrictions)**.

4. (Optional step). Check **Choose default prompt answers** and click **Next** to specify default values for the prompt.

- If you wish to specify one or more objects to be used as default, click **Add**. The wizard displays the **Select Objects** dialog box, on which you can select objects, from the list of those available, to use as default values for the prompt.
- If you wish to specify limits to the number of answers allowed, check the **minimum** and **maximum** boxes, and set the values for selection limits.

5. When done, click **Next**. The wizard displays a page on which you can enter general information associated with the prompt.

6. Enter project-level data to identify the prompt:

- a title
- a description
- modifications to current web options
- whether an answer is to be required at run time

**Note:** If **Minimum qualifications** is a value other than 0, answering the prompt is not an option: the **Prompt answer is required** check box is grayed out.

- Click **Finish** when you have completed prompt identification. The **Save As** dialog box opens.
8. Enter a name and location for the prompt, and click Save. The prompt is saved in the folder you selected.

Create a “Qualify on a metric” prompt

Steps

1. Open the Prompt Generation Wizard.

2. Select Filter qualification prompt and then Qualify on a metric and click Next. The wizard displays a page on which you can select a metric.

3. Do one of the following:
   - Select Choose a metric object and enter the name of a metric to use for qualification.
   - Select Choose a metric object and click the browse button to select a metric object from those available.
   - Select Use the results of a search object and enter the name of a search object to use.
   - Select Use the results of a search object and click the browse button to select a search object. The wizard displays the Open dialog box, where you can select an object from the list of those available.
   - Select Use the results of a search object and click New. The wizard displays the Search for Objects dialog box, with which you can specify search criteria and save your entry as a new search object.

4. (Optional step). Check Choose default prompt answers and click Next to specify default values for the prompt.
   - If you wish to specify one or more objects to be used as default, click Add. The wizard displays the Select Objects dialog box, on which you can select objects, from the list of those available, to use as default values for the prompt.
   - If you wish to specify limits to the number of answers allowed, check the minimum and maximum boxes, and set the values for selection limits.
Create a “Qualify on an attribute” prompt

You use Qualify on an attribute prompts to set filter criteria to restrict, at run time, the set of elements available for a given attribute (for example, you can define the prompt so that the attribute Customer is displayed by last name and zip code only). Following is a description of the associated page.

Steps

1. Open Prompt Generation Wizard.

2. Select Filter definition prompt and Qualify on an attribute and click Next. The Prompt Generation Wizard displays a page on which you can specify an attribute or attribute search object for qualification.
3. Select an attribute for qualification. Select one of the following:
   • **Choose an attribute** and enter the name of the attribute on which you wish to qualify.
   • **Choose an attribute**, click the **browse** button to select an attribute from the list of those available.
   • **Use the results of a search object** and enter the name of a search object to use for qualification.
   • **Use the results of a search object** and click the browse button to select a search object from those available.
   • **Use the results of a search object** and click **New**. The **Search for Objects** dialog box opens, where you can specify search criteria and save your selection as a new search object.

4. (Optional step) Check **Choose default prompt answers** and click **Next** to specify default values for the prompt.
   • If you wish to specify one or more objects to be used as default, click **Add**. The wizard displays the **Select Objects** dialog box, on which you can select objects, from the list of those available, to use as default values for the prompt.
   • If you wish to specify limits to the number of answers allowed, check the **minimum** and **maximum** boxes, and set the values for selection limits.

5. When done, click **Next**. The wizard displays a page on which you can enter general information associated with the prompt.

6. Enter project-level data to identify the prompt:
   • a title
   • a description
   • modifications to current web options
   • whether an answer is to be required at run time

**Note:** If **Minimum qualifications** is a value other than 0, answering the prompt is not an option: the **Prompt answer is required** check box is grayed out.

• Click **Finish** when you have completed prompt identification. The
7. Click Finish when you have completed prompt identification. The Save As dialog box opens.

8. Enter name and location for the prompt, and click Save. The prompt is saved in the folder you have selected.

**Create a Value prompt**

Value prompts allow you to use dates, numeric values, or text expressions as qualifiers for metrics, attribute description, or attribute IDs in a report.

**Steps**

1. Open the Prompt Generation Wizard.
2. Select Value prompt and click Next. The Prompt Generation Wizard displays a page from which you can select a value prompt for qualification.
3. Select one of the following value prompts:
   - Date prompt to qualify either on a date or a range of dates
   - Numeric prompt to qualify on a numeric value
   - Text prompt to qualify on a text expression
4. Click Next. The Prompt Generation Wizard displays a page on which you can enter specific data for the value prompt you have selected.
5. Enter the criteria for qualification:

- If you select **Date prompt**, you can specify a default date, and minimum and maximum values for valid answers to the prompt (you can also click the calendar icon to access the Date Editor, which you can use to specify either static or dynamic date information).

- If you select **Numeric prompt**, you can specify a default value, and minimum and maximum values for valid answers to the prompt.

- If you select **Text prompt**, you can specify a default value, and the minimum and maximum number of characters allowed for valid answers to the prompt.

6. Click **Next**. The **Prompt Generation Wizard** displays a page on which you can enter general information to be associated with the prompt.

7. Enter project-level data to identify the prompt:

   - a title
   - a description
   - modifications to current web options
   - whether an answer is to be required at run time

   **Note:** An answer is always required for a value prompt; the **Prompt answer is required** check box is grayed out in all cases.

8. Click **Finish** when you have completed prompt identification. The
   - Click **Finish** when you have completed prompt identification. The

9. Enter a name and location for the prompt, and click **Save**. The prompt is saved in the folder you have selected.
Create an Object prompt

You use Object prompts to allow run-time selection of one or more objects meeting specific criteria (for example, a search could request return of all metrics contained in a given folder and using a specific fact).

Steps

1. Open the Prompt Generation Wizard.
2. Select Object prompt and click Next. The wizard displays a page from which you can select criteria for display restriction.
3. Do one of the following to specify an object prompt:
   - Select Use a pre-defined list of objects and click Add. The wizard displays the Select Objects dialog box, on which you can specify search criteria and save your entry as a new object.
   - Select Use the results of a search object and enter the name of an object.
   - Select Use the results of a search object and click the browse button. The wizard displays the Open dialog box, on which you can choose an object from those available.
   - Select Use the results of a search object and click Add. The wizard displays the Search for Objects dialog box, on which you can specify search criteria and save your entry as a new object.

Note: Once you have selected one or more objects, the Add button on the Select Objects dialog box changes to Modify, to allow changes to your current selection.

- Select Use the results of a search object and enter the name of an object.
- Select Use the results of a search object and click the browse button. The wizard displays the Open dialog box, on which you can choose an object from those available.
- Select Use the results of a search object and click Add. The wizard displays the Search for Objects dialog box, on which you can specify search criteria and save your entry as a new object.

4. (Optional step). Check Choose default prompt answers and click Next to specify default values for the prompt.
   - If you wish to specify one or more objects to be used as default, click Add. The wizard displays the Select Objects dialog box, on which you can select objects, from the list of those available, to use as default values for the prompt.
   - If you wish to specify limits to the number of answers allowed, check the minimum and maximum boxes, and set the values for selection limits.
5. When done, click Next. The wizard displays a page on which you can enter general information associated with the prompt.
6. Enter project-level data to identify the prompt:
   • a title
   • a description
   • modifications to current web options
   • whether an answer is to be required at run time

   **Note:** If **Minimum qualifications** is a value other than 0, answering the prompt is not an option: the **Prompt answer is required** check box is grayed out.

   • Click **Finish** when you have completed prompt identification. The
   7. Click **Finish** when you have completed prompt identification. The **Save As** dialog box opens.
   8. Enter a name and location for the prompt, and click **Save**. The prompt is saved in the folder you have selected.

### Select a prompt type

Prompt types available for qualification through the **Prompt Generation Wizard** include:
• filter definition
• object
• value
• level

**Steps**

1. Open the **Prompt Generation Wizard**.
2. Click the prompt type you want to use for qualification. The wizard displays the page on which you can begin prompt definition by selecting one of the following:
   • Filter definition prompt
   • Object prompt
   • Value prompt
   • Level prompt
Custom Groups

Add a custom group to a report

Steps

1. Use the Custom Group Editor to create a custom group. Refer to the How do I...? called Create a custom group in this chapter for details.

2. Save the custom group in the desired folder within your project.

3. Open the Report Editor by doing one of the following:
   - If you are adding a custom group to a new report: From the File menu, point to New, then choose Report. The Report Editor opens.
   - If you are adding a custom group to an existing report: From the Folder List of the primary window of MicroStrategy Desktop, locate and select the desired report. From the File menu, choose Edit. The Report Editor opens.

4. Locate the custom group you wish to add using the Object Browser.

5. Select the custom group and drag it onto the template.

6. Save the report.
Create a custom group

During this procedure you have to create one of the following qualifications. Refer to the following procedures in this chapter for step-by-step instructions:

- Create an attribute qualification using the Custom Group Editor
- Create a metric qualification using the Custom Group Editor
- Create a custom group banding qualification using the Custom Group Editor
- Create an advanced qualification using the Custom Group Editor

**Steps**

1. Open the Custom Group Editor.
2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group element name appears.
4. Select the desired qualification type you wish to add and click OK.
5. Create the desired qualification.
6. Add another qualification or custom group as desired. From the File menu choose Save. Save your new custom group to the desired location.

**Note**

It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called:

Rename a custom group element
Create a custom group banding qualification using the Custom Group Editor

Steps

1. Open the Custom Group Editor.
2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group element name appears.
4. Select Add a Custom Group Banding qualification and click OK. The Custom Group Band Qualification dialog box opens.
5. Add a metric to the Metric box using any of the following methods:
   • In the Metric box, type in the desired metric name. Click OK. A new Custom Group Band Qualification dialog box opens.
   • Click the browse button. The Open dialog opens. Navigate to the desired metric’s location. Click OK. A new Custom Group Band Qualification dialog box opens.
   • From the Object Browser, navigate to the metric’s location. Drag and drop the metric into the Metric box. A new Custom Group Band Qualification dialog box opens.
6. In the Band on box, select Metric Value, Rank, or Percent.
7. Select a banding type:
   • If you select Band Size, enter the start at, stop at, and step size.
   • If you select Band Count, enter the start at, stop at, and band count.
   • If you select, Banding Points, enter the banding points. If desired, select Create an extra band for values not in the range.
8. Click Level. The Level dialog box opens.
9. Select the attribute(s) that will determine the output level and click OK to close the dialog box and save your selection.
10. Click OK.
-Create a metric qualification using the Custom Group Editor

Steps

1. Open the Custom Group Editor.

2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group element name appears.


4. Select Add a Metric qualification and click OK. The Metric Qualification dialog box opens.

5. Add a metric to the Metric box. Do one of the following:
   - In the Metric box, type in the desired metric name. Click OK.
   - Click the browse button. The Open dialog box opens. Select a metric and click OK.
   - Select a metric from the Object Browser, and drag it to the Metric box.

Notes

- It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called: Rename a custom group element
- For more information on what an output level is, refer to the following Concept chapter: Filters
- You can define display options for the custom group element. For instructions, see the how do I in this chapter called: Show display options
- You can name the bands you create. For instructions on how to do so, see the how do I in this chapter called: Name custom group element bands
Create a shortcut to a filter using the Custom Group Editor

Steps
1. Open the Custom Group Editor.
2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group element name appears.

6. In the Function box, select Metric Value, Rank, or Percent.
7. In the Operator box, select an operator
8. Select value, simple prompt, or custom, and add a value, custom expression, or answer the prompt, depending upon your selection.
9. Click Level. The Level dialog box opens.
10. Select the attribute(s) that will determine the output level and click OK to close the dialog box and save your selection.
11. Click OK.

Notes
• It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called:
  Rename a custom group element
• For more information on what an output level is, refer to the following Concept chapter:
  Filters
• You can define display options for the custom group element. For instructions, see the how do I in this chapter called:
  Show display options
• You can name the bands you create. For instructions on how to do so, see the how do I in this chapter called:
  Name custom group element bands

4. Select Add a Shortcut to a Filter and click OK. The Shortcut to a Filter dialog box opens.

5. Add a filter to the Filter box by doing one of the following:
   • In the Filter box, type in the desired filter name. Click OK. A new Shortcut to a Filter dialog box opens.
   • Click the browse button. The Open dialog box opens. Navigate to the desired filter’s location. Click OK. A new Shortcut to a Filter dialog box opens.
   • From the Object Browser, navigate to the filter’s location. Drag the filter into the Filter box. A new Shortcut to a Filter dialog box opens.

6. Click OK.

Notes

• It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called:
  Rename a custom group element
• You can define display options for the custom group element. For instructions, see the how do I in this chapter called:
  Show display options

Create an advanced qualification using the Custom Group Editor

By default, the option to add an advanced qualification is disabled. To enable this option, complete the instructions in the following How do I...? in this chapter:

Set the default custom group options

Steps

1. Open the Custom Group Editor.
2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group name appears.


4. Select Add an advanced qualification, and click OK. The Advanced Qualification dialog box opens.

5. In the Option box, select the option you wish to qualify on:
   - If you choose Custom expression, you can do the following:
     - Drag and drop an object from the Object Browser into the Custom Expression box. You can drag filter, metric, or attribute objects. If you drag an object with a right-click, when you drop it in the box a list of the most often used expressions appear to select from.
     - Type a filter expression in the Custom expression box.
     You can select the operator buttons to place them in your expression, or you can type the operators in manually. Click Validate to validate the expression, and Clear to delete the expression.
   - If you choose Joint element list, complete the following:
     - From the Available attributes box, select the desired attributes and click the add > button to move them to the Selected attributes box and onto the Element list.
     - Next to the Element list, click the add button to add elements to the list. To modify the list of elements, click the modify button. The Select Element List dialog box opens. Select the desired element(s). Click the add button to move the new element into the Selected elements list box, replacing the current element. Click OK.
     - To delete the attribute element(s) from the Element list, click the delete button.

6. Click OK.
Notes

- It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called:
  Rename a custom group element
- You can define display options for the custom group element. For instructions, see the how do I in this chapter called:
  Show display options

Create an attribute qualification using the Custom Group Editor

Steps
1. Open the Custom Group Editor.
2. Double-click in the Custom Group definition area of the Custom Group Editor. A default custom group element name appears.
4. Select Add an Attribute qualification and click OK. The Attribute Qualification dialog box opens.
5. Add an attribute to the Attribute box. Do one of the following:
   - In the Attribute box, type in the desired attribute name and click OK.
   - Click the browse button. The Open dialog box opens. Navigate to the desired attribute’s location and click OK.
   - From the Object Browser, navigate to the attribute’s location. Drag and drop the attribute into the Attribute box.
6. For **Qualify On**, choose the attribute form on which you wish to qualify.

   • If you choose to qualify on the form **Elements**, you can do one of the following:
     ◊ From the **Operator** box, select **in list** or **not in list**.
     ◊ Drag and drop elements from the **Object Browser** into the **Element List** box.
     ◊ Click **Add**. The **Select Objects** dialog box opens. Select the elements from the left then click the add button (>) to move them to the right. Click **OK**. The selected elements appear in the **Element List** section.

   • If you choose to qualify on any other form, complete the following:
     ◊ For **Operator**, select the desired operator.
     ◊ For **Value**, select either **value**, **simple prompt**, or **expression**. Enter an expression or value in the box, or complete the simple prompt definition.

   7. Click **OK**.

---

**Notes:**

• It is recommended that you rename the custom group element default name. For instructions on renaming it, see the how do I in this chapter called: Rename a custom group element

• You can define display options for the custom group element. For instructions, see the how do I in this chapter called: Show display options

---

**Name custom group element bands**

**Steps**

1. Open the Custom Group Editor.
2. Create a custom group banding qualification, or a metric qualification using the Custom Group Editor. For instructions, refer to the following how do Is in this chapter:
   • Create a custom group banding qualification
   • Create a metric qualification
3. Select the custom group element name in the **Custom Group definition** section of the editor.
4. From the Custom Group menu, choose **Show Band Names Editor**. The Band Names dialog box opens.
5. Click **Add** to add a band name.
6. Click **Edit** to name the band.
7. Click **OK**.

---

**Rename a custom group element**

**Steps**

1. Open the **Custom Group Editor**.
2. Create a custom group. For instructions, refer to the Create a custom group How do I...? in this chapter.

---

**Note**: You do not have to create an entire custom group before renaming the element. You may rename it as soon as the default name appears.

---

3. Select the default custom group element name in the **Custom Group definition** section of the editor.
4. From the **Custom Group** menu, choose **Rename**. You can now type in the new name for the custom group element.
CHAPTER 22

Set the default custom group options

Steps

1. Under List, on the MicroStrategy Desktop primary window, right-click on your project name and select Preferences. The Project Preferences dialog box opens.

2. Select the Editors tab, and click Custom Group. The Custom Group Options dialog box opens.

3. You can select the following default settings:
   - show advanced qualification
   - show all available prompt buttons
   - show tip box on the qualification dialogs
   - trim leading spaces of a value

Select the desired options and click OK. Click OK again to close the Project Preferences dialog box and return to the primary window.

Show display options for a custom group element header

Steps

1. Open the Custom Group Editor.

2. Create a custom group. For instructions, refer to the Create a custom group How do I...? in this chapter.
**Note:** You do not have to create an entire custom group before selecting its display options. You may set the display options as soon as the default custom group element name appears.

3. Select the custom group element name in the Custom Group definition section of the editor.

4. From the Custom Group menu, choose Show Display Options. The Choose a display option dialog box opens.

5. Choose a display option and click OK.
Consolidations

Create a consolidation

**Steps**

1. Open the Consolidation Editor.

2. Create at least one new consolidation element using one of the following methods:
   - From the Object Browser, drag and drop an attribute element into the Elements for this consolidation section.
   - Under Elements for this consolidation, click Click here to add new consolidation element.
   - Under Elements for this consolidation, right-click and select Add Element.
   - On the toolbar, click add element.
   - From the Elements menu, select Add Elements.

3. Name or rename the consolidation element. Select the consolidation element name, right-click and choose Rename. Type the desired name.

4. Add or modify the expression. Refer to the Create an element expression located in the How do I...? section for step-by-step instructions.
5. From the File menu, choose Save. The Save Consolidation As dialog box opens. Navigate to the desired folder location, type a name for your new consolidation, and then click Save.

Create a new consolidation element

**Steps**
1. Open the Consolidation Editor.
2. Refer to the How do I...? steps for the following task:
   Create a consolidation

Create an element expression

**Steps**
1. Open the Consolidation Editor.
2. Refer to the How do I...? steps for the following task:
   Create a consolidation
3. Create an expression using one of the following methods:
   • From the Object Browser, drag and drop an attribute element into the Selected element section.
   • From the Object Browser, right-click and drag and drop an attribute element into the Selected element section. A pop-up menu opens. Select one of the options.
4. If desired, click on any operator to insert it into the expression.
   OR
   From the Object Browser, select another attribute element, right-click and drag it into the Selected element section.
5. Click Validate to determine if the expression is valid.
Import a consolidation element

Steps
1. Open the Consolidation Editor.
2. From the Elements menu, choose Import Elements. The Select a Consolidation dialog box opens.
3. Navigate to and select the desired consolidation. Click Open. The Import Consolidation Elements dialog box opens.
4. Select the desired consolidation element and click OK. The consolidation element appears under Elements for this consolidation.

Validate a consolidation expression

Steps
1. Open the Consolidation Editor.
2. Refer to the How do I...? steps for the following task:
   Create a consolidation
3. To validate the consolidation, do one of the following:
   • Under **Selected element**, click **Validate**
   • Under **Selected element**, right-click and then click **Validate**.
Add a report to a document

Steps

1. Open the Document Editor.

2. Select Normal Edit from the View menu (Normal Edit is the default option for this menu; in most cases it should be readily available).

   Note: reports can only be added in Normal Edit view.

3. Use the Object Browser to select your report.

4. Double-click and navigate to the desired location in the document layout area of Normal Edit View (the right portion of the window). An icon placeholder appears indicating the position of the report.
**Note:**
To reposition the report within the layout, you can do one of the following:
- Select the report and place it in the desired location.
- Use the **indent** buttons (refer to the **How do I...?** in this section for more information)

---

### Add or remove a bulleted list in a document

**Steps**

1. Open the **Document Editor**.
2. Select **Normal Edit** from the **View** menu (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. Position the cursor in the layout area where you wish to either add or remove the bulleted list.
4. From either the toolbar or the **Format** menu, click **Bulleted List**.

### Add or remove a numbered list in a document

**Steps**

1. Open the **Document Editor**
2. From the **View** menu, choose **Normal Edit** (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. Position the cursor in the layout area where you wish to either add or remove the numbered list.
4. From either the toolbar or the **Format** menu, click **Numbered List**.
Change the font color in a document

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, select the text you wish to change.
4. From either the toolbar or the Format menu, click Font Color. The Color dialog box opens.
5. Select a basic or custom color and click OK.

Change the highlight color in a document

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, select the text you wish to highlight.
4. From either the toolbar or the Format menu, click Highlight Color. The Color dialog box opens.
5. Select a basic or custom color and click OK. The text is highlighted the color you selected.

Choose a different XSL

Steps
1. Open the Document Editor.
2. Insert a report into the document.
3. Select the report you have just inserted.

Change the font color in a document
4. From the Edit menu, choose Desktop Object XSL. The Open dialog box opens.
5. Click one of the options listed and click Open.

Create a hyperlink in a document

Steps

1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, place the cursor where you want to create the hyperlink.
4. Enter the text you want to display for the hyperlink and highlight it.
5. On the Insert menu, click Create Hyperlink. The Hyperlink dialog box opens.
6. Select the desired protocol (for example, http), and enter the URL for the link destination in the URL box.
7. Click OK.

Create a table in a document

Steps

1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, place the cursor where you want to create the table.
4. From the Table menu, choose Create. The Create Table dialog box opens.
5. Enter the number of rows and columns, the attributes for the table and its cells, and if desired, a caption.
6. Click OK.

Decrease the indent in a document

**Steps**
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, place your cursor in front of, on, or directly after the indented text or image you wish to indent.
4. From the Format menu or toolbar, click Decrease Indent.

Edit the HTML in a document

The Document Editor provides a WYSIWYG interface so you do not have to know HTML in order to create a document object. However, if you prefer working directly with the HTML source code, refer to the following steps to locate the HTML.

**Steps**
1. Open the Document Editor.
2. Select the desired HTML layout. On the File menu, click Import Layout File. Navigate to the desired layout and then click OK. Or, accept the default layout and continue to the next step.
3. From the View menu, choose HTML Edit. You can edit the HTML with this view. Your edits automatically appear in the Normal Edit and Document Preview views.
Format the font in a document

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, select the text you wish to format.
4. From the Format menu, choose Font, and select one of the following:
   • Select: Opens the Font dialog box. From this dialog you can select the font, style, size, color, effects, and view a sample of the text. Click OK once you have made your selections.
   • Bold: Select to bold the text.
   • Italic: Select to italicize the text.
   • Underline: Select to underline the text.

Indent text or images in a document

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. In the layout area, place your cursor in front of, on, or directly after the text or image that you want to indent.
4. From the Format menu or toolbar, click Indent.

Insert an image in a document

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).

3. In the layout area, place the cursor where you would like to insert the image.

4. From the Insert menu, choose Picture. A Picture dialog box opens.

5. Enter the full URL for the image file into the Picture Source box. The Browse button can be used to help you locate the file name, but the actual image source must be referenced through the HTTP protocol.

6. If desired, add a text string for the Alternate Text display.

7. Define the Layout and Spacing as needed for the image. Click OK.

**Insert or delete table cells in a document**

**Steps**

1. Open the Document Editor.

2. If a table is not already created, create one. Refer to the How do I...? topic in this chapter called Create a table, for step-by-step instructions.

3. Place the cursor within the desired cell of the table.

4. From the Table menu, choose Insert Cell (to insert a cell), or Delete Cell (to delete the cell).

**Insert or delete table columns in a document**

**Steps**

1. Open the Document Editor.

2. If a table is not already created, create one. Refer to the How do I...? in this chapter called Create a table, for step-by-step instructions.

3. Place the cursor within the desired cell of the table. The new column is placed to the left of your cursor’s location. If you wish to delete a column, place the cursor in a cell within the column you wish to delete.
4. From the Table menu, choose **Insert Column** (to insert a column) or **Delete Column** (to delete a column).

## Insert or delete table rows in a document

**Steps**

1. Open the **Document Editor**.

2. If a table is not already created, create one. Refer to the How do I...? in this chapter called **Create a table**, for step-by-step instructions.

3. Place the cursor within the desired cell of the table. The new row is placed directly above your cursor’s location. If you wish to delete a row, place the cursor in a cell within the row you wish to delete.

4. From the Table menu, choose **Insert Row** (to insert a row) or **Delete Row** (to delete a row).

## Merge table cells in a document

This command is only available when two or more cells are selected, and the selected cells form a rectangle.

**Steps**

1. Open the **Document Editor**.

2. From the View menu, choose **Normal Edit** (Normal Edit is the default option for this menu; in most cases it should be readily available).

3. If a table is not already created, create one. Refer to the How do I...? in this chapter called **Create a table**, for step-by-step instructions.

4. In the layout area, select a row, column, or more than one cell.

5. From the Table menu, choose **Merge Cells**.
Modify the report object to grid or graph

Steps
1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. Add a report to the document. Refer to the How do I...? in this chapter by the same name for step-by-step instructions on adding a report to a document.
4. From the Edit menu, point to Desktop Object View, and click the desired view. You will not be able to see the changes until you preview the document.

Preview a document

Steps
1. Open the Document Editor and run a document.
2. From the View menu, choose Document View to see a preview of the document.

Set default document options

Steps
1. From the primary window Folder List, right-click on your project name and choose Preferences. The Project Preferences dialog box opens.
2. Select Editors. The Editors dialog box opens.
3. Click Display HTML update messages under Document.
4. Click OK.
Split table cells in a document

**Steps**

1. Open the Document Editor.
2. From the View menu, choose Normal Edit (Normal Edit is the default option for this menu; in most cases it should be readily available).
3. If a table is not already created, create one. Refer to the How do I...? in this chapter called Create a table, for step-by-step instructions.
4. In the layout area, select a row, column, or more than one cell.
5. From the Table menu, choose Split Cells.

View hidden elements

**Steps**

1. Open the Document Editor.
2. From the View menu, choose Show/Hide Elements.

View hidden table borders

**Steps**

1. Open the Document Editor.
2. From the View menu, choose Hidden Table Borders.

View the HTML source code for a document

**Steps**

1. Open the Document Editor.
2. From the View menu, choose HTML Edit. The HTML source code is displayed in this view.
Appendixes

Topics included in this section:
• Project Preferences
• XSL Stylesheets
• Analytical Functions
Project Preferences

What is it?
The Project Preferences dialog box allows you to set the default options for various editors.

How can I access it?
To access the Project Preferences dialog box, from the MicroStrategy Desktop primary window Folder List, right-click on your project name and choose Preferences.

What can I do with it?
Through the Project Preferences dialog box you can:

• Customize the presentation of the grid and graph report results
• Modify the default options of the Report Editor, Filter Editor, Document Editor, and Prompt Generation Wizard

Project Preferences layout
The Project Preferences dialog box is divided into four tabs:

• Home Page
• Reports
• Editors
• Advanced

Home Page tab
From this tab you can customize an HTML file to serve as the home page for a project. You can enable or disable the home page functionality, and enter the HTML file path, background image, and color.
Reports tab

From this tab you can customize the presentation of the grid and graph report results. You can also access the following dialog boxes:

- Grid Options
- Graph Options
- Export Options

Grid Options dialog box

The Grid Options dialog box allows you to customize the presentation of the grid report results. This dialog box is divided into the following tabs:

- General tab
- Drilling tab

General tab

This tab is divided into the following sections; Display and Outline. From the Display section you can select the default report style, the minimum column width, and toggle on or off wordwrap. From the Outline section you can choose to open the report in regular or outline mode, and choose to display long names or merge header cells.

Drilling tab

From this tab you can choose to enable or disable drilling, offer the user the ability to drill anywhere or drill down only, and enable or disable the option to keep parent while drilling.

Graph Options dialog box

This dialog box is divided into two tabs: General and Web Display.

General tab

From this tab you can select the default graph type and style, scrolling preferences, and graph size ratio.

Web Display tab

From this tab you can:

- allow reports to be displayed as graphs on the Web
- choose the types of graphs to be displayed
- choose to save the graph dimensions when the report is closed
- select graph pixel dimensions
Export Options dialog box

The Export Options dialog box allows you to select the application you wish to export to, set general exporting options, select pre and post export macro options, and display advanced exporting options. From this dialog you can access the following dialog:

Advanced Options for Exporting to Excel

From this dialog you can set the following options:

• Select the sections to export to the Microsoft Excel document in addition to the report data.
• Select the formatting options to apply when the report is exported to a Microsoft Excel document.
• Select how to handle unexpected errors when exporting data or trying to execute macros associated with this Microsoft Excel document.
• Specify where the data will be exported in the Microsoft Excel document.

Editors tab

From this tab you can define the default options for filters, documents and custom groups. You can also modify the following:

• Document options
• Filter options
• Custom Group options

Document

From this tab you can select to display HTML update messages.

Filter

From this dialog box you can choose the following default options:

• show advanced qualification option
• show all available prompt buttons
• show the tip box on the qualification dialog boxes
• trim leading spaces of a value
Custom Group

From this dialog box you can choose the following default options:

• show advanced qualification
• show all available prompt buttons
• show tip box on the qualification dialog boxes
• trim leading spaces of a value

Advanced tab

From the Advanced tab you can:

• Choose to add long prompts to the list of available value prompts in the Prompt Generation Wizard.
• Select to use the server cache. This setting is only available if you have the required privilege. It allows you to choose between retrieving a cached or new report. The default is set to retrieving a cached report.
• Select to purge the object cache
The following XSL stylesheets are available with this version of MicroStrategy 7. These stylesheets are located in the XSL folder within the application directory.

<table>
<thead>
<tr>
<th>XSL</th>
<th>Appearance</th>
<th>Color Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agent</td>
<td><img src="agent.wmf" alt="agent.wmf" /></td>
<td>• Region: medium gray with black text&lt;br&gt;• Dollar Sales, Central, England, France and Germany: dark blue with white text&lt;br&gt;• dollar amounts: white with black text</td>
</tr>
<tr>
<td>AgentBanding</td>
<td><img src="agentbanding.wmf" alt="agentbanding.wmf" /></td>
<td>• Region: medium gray with black text&lt;br&gt;• Dollar Sales, Central, England, France and Germany: dark blue with white text&lt;br&gt;• dollar amounts: First and third = white with black text, second and fourth = medium gray with black text</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Basic1</td>
<td><img src="basic1.wmf" alt="Region Dollar Sales" /></td>
<td>• Region, Dollar Sales, dollar amounts: white with black text&lt;br&gt;• Central, England, France and Germany: white with purple text</td>
</tr>
<tr>
<td>Basic2</td>
<td><img src="basic2.wmf" alt="Region Dollar Sales" /></td>
<td>• Region and Dollar Sales: white with light gray text&lt;br&gt;• Central, England, France, Germany and dollar amounts: white with black text</td>
</tr>
<tr>
<td>Basic3</td>
<td><img src="basic3.wmf" alt="Region Dollar Sales" /></td>
<td>• Region and Dollar Sales: violet with white text&lt;br&gt;• Central, England, France, and Germany: gray with black text&lt;br&gt;• dollar amounts: white with black text</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Basic4</td>
<td><img src="basic4.wmf" alt="basic4.wmf" /></td>
<td>• Region and Dollar Sales: purple with white text</td>
</tr>
<tr>
<td></td>
<td><img src="basic4.wmf" alt="Region Dollar Sales" /></td>
<td>• Central, England, France, Germany, dollar amounts: medium gray with purple text</td>
</tr>
<tr>
<td>Basic5</td>
<td><img src="basic5.wmf" alt="basic5.wmf" /></td>
<td>• Region and Dollar Sales: rust with white text</td>
</tr>
<tr>
<td></td>
<td><img src="basic5.wmf" alt="Region Dollar Sales" /></td>
<td>• Central, England, France, Germany, dollar amounts: light yellow with black text</td>
</tr>
<tr>
<td>Contemporary1</td>
<td><img src="contemporary1.wmf" alt="contemporary1.wmf" /></td>
<td>All: white with black text - light gray borders</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Contemporary2 | ![contemporary2.wmf](contemporary2.wmf) | • Region and Dollar Sales: black with gray text  
  • Central, England, France, Germany, dollar amounts: white with black text |
| Default    | ![default.wmf](default.wmf)                    | • Region, Dollar Sales, and dollar amounts: white with black text  
  • Central, England, France, and Germany: white with bright blue text |
| Denim      | ![denim1.wmf](denim1.wmf)                      | • Region and Dollar Sales: slate blue with black text  
  • Central, England, France, Germany and dollar amounts: gray with black text |
<table>
<thead>
<tr>
<th>XSL</th>
<th>Appearance</th>
<th>Color Description</th>
</tr>
</thead>
</table>
| Denim2| ![Denim2](denim2.wmf) | • Region and Dollar Sales: slate blue with dark blue text  
• Central, England, France, and Germany: bright blue with light yellow text  
• dollar amounts: white with dark blue text |
| Elegant1 | ![Elegant1](elegant1.wmf) | • Region and Dollar Sales: teal with light yellow text  
• Central, England, France, Germany and dollar amounts: white with black text |
| Elegant2 | ![Elegant2](elegant2.wmf) | • Region and Dollar Sales: purple with white text  
• Central, England, France, Germany and dollar amounts: white with black text |
<table>
<thead>
<tr>
<th>XSL</th>
<th>Appearance</th>
<th>Color Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Elegant3</td>
<td><img src="elegant3.wmf" alt="Region and Dollar Sales Table" /></td>
<td>• Region and Dollar Sales: dark gray with white text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: white with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ElegantBanding1</td>
<td><img src="elegantbanding.wmf" alt="Region and Dollar Sales Table" /></td>
<td>• Region and Dollar Sales: navy blue with white text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: alternating light yellow and white with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ElegantBanding2</td>
<td><img src="elegantbanding2.wmf" alt="Region and Dollar Sales Table" /></td>
<td>• Region and Dollar Sales: navy blue with white text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: alternating white and gray with black text</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------</td>
<td>----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ElegantBanding3</td>
<td></td>
<td>• Region and Dollar Sales: gray with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: alternating gray and light</td>
</tr>
<tr>
<td></td>
<td></td>
<td>yellow with black text</td>
</tr>
<tr>
<td>professional1</td>
<td><img src="professional1.png" alt="professional1.png" /></td>
<td>• Region and Dollar Sales: white with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: white with black text</td>
</tr>
<tr>
<td>professional2</td>
<td><img src="professional2.png" alt="professional2.png" /></td>
<td>• Region and Dollar Sales: lilac with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, Germany and dollar amounts: white with black text</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>-----------</td>
<td>------------</td>
<td>-------------------</td>
</tr>
</tbody>
</table>
| Professional3 | ![professional3.wmf](professional3.wmf) | • Region and Dollar Sales: green with white text  
• Central, England, France, Germany and dollar amounts: white with black text |
| Professional4 | ![professional4.wmf](professional4.wmf) | • Region and Dollar Sales: red with black text  
• Central, England, France, Germany and dollar amounts: white with black text |
| Simple1   | ![simple1.wmf](simple1.wmf) | • Region and Dollar Sales: gray with black text  
• Central, England, France, Germany and dollar amounts: white with black text |
<table>
<thead>
<tr>
<th>XSL</th>
<th>Appearance</th>
<th>Color Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple2</td>
<td><img src="simple2.wmf" alt="simple2.wmf" /></td>
<td>All: white with black text, gray borders</td>
</tr>
<tr>
<td>Simple3</td>
<td><img src="simple3.wmf" alt="simple3.wmf" /></td>
<td>All: white with black text, green border around headers</td>
</tr>
<tr>
<td>SimpleBanding1</td>
<td><img src="simplebanding1.wmf" alt="simplebanding1.wmf" /></td>
<td>• Region and Dollar Sales: gray with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Central, England, France, and Germany: white with black text</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Dollar amounts: alternating white and gray with black text</td>
</tr>
<tr>
<td>XSL</td>
<td>Appearance</td>
<td>Color Description</td>
</tr>
<tr>
<td>--------------</td>
<td>------------</td>
<td>-------------------------------------------------------</td>
</tr>
</tbody>
</table>
| SimpleBanding2 | ![Table](simplebanding2.wmf) | - Region and Dollar Sales: medium gray with black text  
- Central, England, France, and Germany: light gray with black text  
- Dollar amounts: alternating medium gray and light gray with black text |
This appendix lists the analytical functions supported by MicroStrategy 7.

### Basic Functions
- Average
- Mean
- Count
- Sum
- Maximum
- Minimum
- Median
- Mode
- Product

### OLAP Functions
- Running Total
- Running Standard Deviation
- Running Standard Deviation of Population
- Running Minimum
- Running Maximum
- Running Count
- Moving Difference
- Moving Maximum
- Moving Minimum
- Moving Average
Moving Sum
Moving Count
Moving Standard Deviation
Moving Standard Deviation of Population
Last Value in Range
First Value in Range
Exponential Weight Moving Average
Exponential Weight Running Average

**Statistic Aggregate Functions**

Standard Deviation
Standard Deviation of a Population
Variance
Variance of a Population
Geometric Mean
Average Deviation
Kurtosis
Skew

**Rank Functions**

Rank
Percentile
“N”-Tile
N-tile by Step
N-tile by Value
N-tile by Step and Value

**Advanced Statistic Functions**

Beta Distribution
Beta Inverse
Binomial Distribution Probability
Chi Distribution
Chi Inverse
Confidence
Correlation Coefficient
Covariance
Critical Binormal Distribution
Chi Test (Independence)
Cumulative Binomial Distribution
Exponent Distribution
F-Probability Distribution
F-Test
Fisher Transformation
Gamma Distribution
Gamma Inverse
Gamma Logarithm
Homoscedastic Ttest
Heteroscedastic Ttest
Hypergeometric Distribution
Intercept Point
Inverse of Lognormal Cumulative Distribution
Inverse of F Probability Distribution
Inverse of Fisher
Inverse of the Standard Normal Cumulative Distribution
Inverse of the T-Distribution
Lognormal Cumulative Distribution
Mean T-Test
Negative Binomial Distribution
Normal Cumulative Distribution
Normal Distribution Inverse
Number of Permutations for a Given Object
Paired T-test
Poisson Distribution (Predict Number of Events)
Pearson Product Moment Correlation Coefficient
RSQ (Square of Pearson)
Slope of Linear Regression
STEYX (Standard Error of Predicted “y” Value)
Standardize
Standard Normal Cumulative Distribution
T-Distribution
Variance Test
Weibull Distribution (Reliability Analysis)

**Mathematical Functions**

- Absolute
- A-cosine
- A-cosine hyperbolic
- A-sinine
- A-sinine hyperbolic
- A-tan
- A-tan2
- A-tan hyperbolic
- Ceiling
- Combine
- Cosine
- Cosine hyperbolic
- Degrees
- Exponent
- Factorial
- Floor
- Int
- Ln
Financial Functions

Accrued Interest
Accrued Interest Maturity
Amount Received at Maturity
Bond-equivalent Yield for T-BILL
Convert Dollar Price from Fraction to Decimal
Convert Dollar Price from Decimal to Fraction
Cumulative Interest Paid on Loan
Cumulative Principal Paid on Loan
Depreciation for each Accounting Period
Days In Coupon Period to Settlement Date
Days In Coupon Period with Settlement Date
Days from Settlement Date to Next Coupon
Double-Declining Balance Method
Discount Rate For a Security
Effective Annual Interest Rate
Fixed-Declining Balance Method
Future Value
Future Value of Initial Principal with Compound
Interest Rates
Interest Rate
Interest Payment
Internal Rate of Return
Interest Rate per Annuity
Macauley Duration
Modified Duration
Modified Internal Rate of Return
Next Coupon Date After Settlement Date
Number of Coupons Between Settlement and Maturity Date
Nominal Annual Interest Rate
Number of Investment Periods
Net Present Value
Odd First period Yield
Odd Last Period
Previous Coupon Date Before Settlement Date
Price Per $100 Face Value with Odd First Period Payment
Payment on Principal
Price
Price Discount
Price at Maturity
Present Value
Prorated Depreciation for each Accounting Period
Straight Line Depreciation
Sum-Of-Years’ Digits Depreciation
T-BILL Price
T-BILL Yield
Variable Declining Balance
Yield
Yield for Discounted Security
Yield at Maturity
Index

A
advanced qualification
  access 72
  create 140, 208
  custom expression 20
  Custom Group Editor 108
  definition 20
  display option 136, 151
  Joint Element list 20
aggregation parameters, Metric Editor 77, 79
analytical functions 247
Attribute Display dialog box
  modify 174
  view or modify attribute options 133
attribute form display 132
attribute options, view or modify 133
attribute qualification
  access 70, 71, 72
  attribute-to-attribute qualification 16
  create 142, 210
  definition 13, 70
  dynamic dates 16
  element list 15
  element list with a prompt 15
Attribute Qualification dialog box 90
attribute qualification prompts 144
attributes
  element list 15
  qualification 13, 70
  single attribute qualification 15
  single attribute qualification with a prompt 15
attribute-to-attribute qualification 143
autofit 37
autostyles 38, 129, 183

B
banding
  apply 167
  count 50

C
Choose from All Attributes in a Hierarchy prompts 42
Choose from an Attribute Element List prompt 43
clearing report sorts 170
column headers 125
comparison operators 11
compound metrics
  description 27
conditionality, Metric Editor 79
Consolidation Editor
  access 109
  definition 109
  expressions 110
  layout 110
  tasks 109
  toolbar and menu options 111
Consolidation Editor, elements 110
consolidation elements
  expressions of 55
  from the same attribute 54
  from unrelated attributes 55
  import 217
  importing 55
consolidation expressions 110
consolidations
  create 215
  definition 42, 53
  element description 54
  elements from unrelated attributes 55
  elements of the same attribute 54
evaluation order 56
expressions of consolidation elements 55
imported elements 55
continuation, metric
definition 19
copyright ii
creating a Filter Qualification prompt 146
creating a metric prompt qualification 138
crosstab, templates 3
custom expression, syntax 20
custom group
advanced qualification 236
default options 236
custom group banding qualification
create 205
Custom Group Editor 108
Custom Group Editor
access 105
add qualification 107
advanced qualification 108
attribute qualification 107
break by 108
custom group banding qualification 108
definition 105
filter qualification 108
layout 106
metric qualification 107
output level 108
tasks 105
custom group element headers 49
custom group elements 48
custom groups
add to report 203
banding qualification 50
create 204
custom group element headers 49
custom group elements 48
definition 42, 47
display options 213
qualification types applied 49
customize reports
autofit 37
autostyles 38
banding format options 38
lock column headers 39
lock row headers 39
metric properties formatting options 38
page by 38
sorting 37
view long names 39
wordwrap 37

date editor 71
date qualification
definition 15
dynamic dates 16
static dates 15
dates
dynamic 16
static 15
display options, custom groups 213
displaying VLDB properties 132
Document Editor
access 113
definition 113
document view 115
HTML view 115
hyperlink dialog box 116
layout 114
normal view 115
picture dialog box 116
tasks 113
toolbar and menu options 117
documents
add a report 219
bulleted list 220
change report view 227
decrease indent 223
default options 227
definition 57
display HTML update messages 235
edit HTML 223
font color 221
format font 224
hidden elements 228
hidden table borders 228
highlight color 221
HTML source code 228
hyperlink 222
indent text or images 224
insert image 224
layout 57
merge table cells 226
numbered list 220
preview 227
split table cells 228
table cells 225
table columns 225
table rows 226
table, create 222
dynamic dates 16

E

element list 15
element list with a prompt 15
elements, Consolidation Editor 110
embedding a template 173
evaluation order, consolidations 56
evaluation order, reports 169
evaluation order, templates 122
executing a report 182
Export Options dialog box 92
expression prompts 43
expressions, consolidation
  create 216, 217

F

filter
default options 235
filter definition prompts 42
Filter Editor
  access 69
  advanced qualification 72
  attribute qualification 70, 71, 72
  break by 71
definition 69
  Level Editor 71
  metric continuation 71
output 71
tasks 69
toolbar and menu options 72
filter operators 8
filter qualification
  create 145, 207
  Custom Group Editor 108
definition 19
  prompt creation 146
filters
  advanced qualification 20
  attribute qualification 13
  attribute-to-attribute qualification 16
  break by 17
  comparison operators 11
  continuation 19
  create 137
  custom expression 20
date editor 71
date qualification 15
definition 7
dynamic dates 16
filter qualification 19
Joint Element list 20
logical operators 8
metric qualification 16
operators 8
output level 17
pattern operators 13
qualification types 13
rank and percent operators 12
relationship filtering 21
set default options 150
single attribute qualification 15
  single attribute qualification with a prompt 15
  static dates 15, 16
formatting options
  autostyles 38
  banding 38
  metric properties 38
  setting metric formatting options 130
Formula tab in the Metric Editor 74
Graph options 183, 234
   web display 234
Graph view 186
Grid options 234
Grid reports default presentation 183
Grid view 186

Hiding pages 124
Home page 233
   customize 233
HTML, documents 223

Join types 131, 184
Joint Element list 20

Level (dimensionality), Metric Editor 79
Level Editor
   access 135, 138
   calculate output level 151
Level prompts 45
Limit Editor 180
Limits, report 40
Link a template 174
Locking column headers 39, 125
Locking row headers 39, 125
Logical operators
   change 137
   exclusions 10
   functional description 8
   intersections 9
   unions 9

Merge header cells 126, 174
Metric calculations, continuation of 71

Metric Editor
   access 73
   aggregation parameters 77, 79
   attribute level (dimensionality) 79
   capabilities 32
   conditionality 79
   definition 73
   Formula tab 74
   layout 74
   menu bar 32
   tab components (Formula tab) 77
   tab components (Subtotals tab) 81
   tab usage (Formula tab) 77
   tab usage (Subtotals tab) 81
   tasks 73
   Tools menu options 86
   unique menu options 83
   View menu 83
   View menu options 84

Metric formatting options 169
Metric properties, formatting options 38
Metric qualification 107
   break by 17, 71
   continuation 19
   continuation of 71
   create 206
   definition 16
   metric value 16
   output 71
   output level 17
   percent 16
   rank 16
   Metric value 16
Metrics
   aggregation types 30
   applying subtotals 31, 80, 82
   components 29
   delimiters 29
   description 27
   examples 30
   formatting options 130
   Level Editor 71
   metric value 16
   operators 29
percent 16
qualification 16
rank 16
report limits 40, 123, 127, 169, 170, 180
modify a template
    add objects to it 126
    remove an object from it 126

O
object cache, purge 236
object prompts 44
operators
    comparison 11
    filter 8
    logical 8
    pattern 13
    rank and percent 12
output level 108
    calculate 151
    definition 17
    example 17
output, metric calculation 71

P
page by 38
page setup 94
pages
    adding to reports 166
    adding to templates 121
    hiding 124
    remove page field 181
pattern operators 13
percent, metrics 16
print
    modify page setup 175
    preview 181
Project Preferences
document option 235
    graph options 234
    grid options 234
    purge object cache 236
    server cache 236
Project Preferences dialog box 233
Prompt Generation Wizard
    access 97
    defining a prompt 99
    definition 97
    filter definition prompts 99, 100, 101
    object prompts 102, 103
    primary page contents 98
    prompt definition pages 98, 99
    tasks 97
    value prompts 102
prompt types
    Expression 43
    Filter Definition 42
    Object 44
    Value 44
prompt typesLevel 45
prompts
    Choose from All Attributes in a Hierarchy 42
    Choose from an Attribute Element List 43
    description 41
    Expression 43
    Filter Definition 42
    Level 45
    Object 44
    options 41, 42
    properties 41
    Qualify on a Metric 43
    Qualify on an Attribute 43
    search objects 44
    Value 44
    purge object cache 236

Q
qualification types 13
qualifications
    advanced 20, 108
    attribute 13, 70, 107
    attribute-to-attribute 16
    banding 50
    custom group banding 108
date 15
    filter 19, 108
metric 16, 107
single attribute 15
single attribute with a prompt 15
Qualify on a Metric prompts 43
Qualify on an Attribute prompts 43

R
rank and percent operators 12
relationship filtering
definition 21
syntax 21
replace a template with a copy 37
replace template with shortcut 36
Report Data Options dialog box 92
Report Editor
access 89
Attribute Display dialog box 92, 174
create template 171
definition 89
evaluation order 169
Export Options dialog box 92
join type 184
layout 90
link templates 174
metric defaults 182
Report Data Options dialog box 92
report limit settings 186
sorting 92, 185
subtotals 92
tasks 89
Template Editor 90
toolbar and menu options 91
view long names 185
VLDB properties 92
Report Limit Editor 128
report limits 40
clear 169
create 123, 170
modify 127, 180
settings 186
reports
add a template 167
add to a document 219
attribute display 174
autofit 37
autostyle for report format 183
banding 167
banding format options 38
creating 35, 170
customize 37
default presentation 183
definition 35
embedding a template 173
graph options 183
graph view 186
grid view 186
join types 184
limits 40, 186
link a template 174
lock column headers 39
lock row headers 39
merge header cells 174
metric defaults 182
metric properties formatting options 38
page by 38
page field 181
page setup 94
preview before printing 181
replace a template with a copy 37
replace a template with shortcut 36
report limits 170, 180
run 182
show pages 166
sorting 37, 170
template 36
view long names 39, 185
wordwrap 37
restore metric defaults 128, 182
row headers 125
run a report 182

S
simple metrics
components 29
simple prompt metric qualification 139
single attribute qualification 15
single attribute qualification with a prompt 15
sorting 37, 92
criteria 37
objects you can sort 37
order 37
within Report Editor 185
within Template Editor 131
static dates 15
subtotals 92
subtotals in metrics 31, 80, 82
syntax
  custom expressions 20
  relationship filtering 21

T
  tabular templates 3
Template Editor
  access 63
definition 63
evaluation order 122
join type 131
layout 64
menu options 65
metric defaults 128
sorting 131
tasks 63
toolbar options 65

templates
  add objects to templates 126
  add to report 167
  adding pages to 121
  create 171
crosstab 3
definition 3
embedding 173
in reports 36
join types 131
link 174
merge header cells 126
metric defaults 128
objects contained 4
remove an object from a template 126
replace with copy 37
replace with shortcut 36
report limit editor 128
report limits 123, 127
tabular 3
view attribute forms 132
the 222

V
  value prompts 44
  view long names 39, 185
  VLDB Properties dialog box 92
  VLDB properties, displaying 132

W
  wordwrap 37