Cascade
Website Content Management for the Site Manager
University of Missouri – St. Louis
Contents

Purpose & How to Use This Guide ................................................................................................................ 5

What is Cascade ........................................................................................................................................ 5

Getting Started ........................................................................................................................................... 5

Login and Select Your Site ......................................................................................................................... 5

Setting Preferences for Default Site & Un-Publish on Move/Delete .................................................... 5

Dashboard ..................................................................................................................................................... 6

View messages .......................................................................................................................................... 6

Restore deleted files ................................................................................................................................. 7

View draft versions ................................................................................................................................... 7

Navigation Menu ........................................................................................................................................... 7

Site Structure: Assets, Folders, Pages, and Files ...................................................................................... 8

Assets ........................................................................................................................................................ 8

Folders ....................................................................................................................................................... 8

Pages ......................................................................................................................................................... 9

Site Layout ................................................................................................................................................... 10

Creating and Editing Content ...................................................................................................................... 11

Adding a New Page ................................................................................................................................ 11

Create and Name the Page ...................................................................................................................... 11

System Name ...................................................................................................................................... 11

Parent Folder ...................................................................................................................................... 11

Inline Metadata ....................................................................................................................................... 11

Display Name ...................................................................................................................................... 12

Title ..................................................................................................................................................... 12

Include in Navigation .......................................................................................................................... 12

Display Right Sidebar .......................................................................................................................... 12

Navigation Display ............................................................................................................................... 12

Content ................................................................................................................................................... 12

Callout/Related Links .............................................................................................................................. 12

Add, delete, and reorder content in your Related Links list ............................................................... 13

Right Callout content .......................................................................................................................... 14

Tabs 15

CTA Information ................................................................................................................................ 17

Check Spelling .................................................................................................................................. 17

Submit/Save Your Page ........................................................................................................................... 17

Editing a Page ........................................................................................................................................... 18

WYSIWYG Text Edit Options .................................................................................................................. 18
Coping Images from the Image Library ....................................................................................... 38
Building an Image Rotation Block .............................................................................................. 41
Assigning an Image Rotation Block to Your Home Page .......................................................... 42
Purpose & How to Use This Guide
The purpose of this guide is to acquaint you with the features of Cascade Server (Cascade). It is designed to be read chronologically and then used for reference.

What is Cascade
Cascade is a content management system (CMS) by Hannon Hill. The CMS application provides a tool for creating, editing, and publishing Web pages. Using a CMS gives you an easy way to maintain web pages because the HTML is created for you as you enter your content.

Getting Started
The content of your website is on the Cascade server. You are responsible for maintaining and publishing that content.

Login and Select Your Site
Cascade is a web-based application that you access through a web browser (such as Internet Explorer or Firefox).

1. Open your browser and type cms.umsl.edu in the address area.
2. Login to Cascade using your username (SSO ID) and password. If you are accessing Cascade from a computer that is not on UMSL’s network (such as at home), then you must access through a VPN connection. You can get instructions for downloading VPN software from the Technology Support website.
3. At the top of the Cascade screen you will see the site-chooser drop-down box. Click in the site chooser box to select your site.

Setting Preferences for Default Site & Un-Publish on Move/Delete
You should choose to have content automatically unpublished (removed from live web site) automatically whenever you move or delete pages. You can also set a default site that will be displayed each time you log in to Cascade.

1. Click on the My Settings link at the top-right of the screen.
2. Click to place a checkmark in the box for the Un-publish on Move/Delete preference.
3. The last User Preference option listed is Default Site. Click on the choose site icon, click browse, select the site that you want to see each time you login to Cascade, and then click Confirm. Then click Submit.

<table>
<thead>
<tr>
<th>User Preferences</th>
</tr>
</thead>
<tbody>
<tr>
<td>Language</td>
</tr>
<tr>
<td>Item List Size</td>
</tr>
<tr>
<td>After Publishing Assets</td>
</tr>
<tr>
<td>Simple Interface</td>
</tr>
<tr>
<td>Default Chooser Width</td>
</tr>
<tr>
<td>Default Chooser Height</td>
</tr>
<tr>
<td>Disable the Type-Ahead Chooser</td>
</tr>
<tr>
<td>Number of search results per type in type-ahead search</td>
</tr>
</tbody>
</table>

Dashboard

When you login you will see the dashboard, also referred to as the Home Area. You can always return to the dashboard page by clicking on the menu button. The dashboard shows you information as it relates to your site(s). Some functions you can perform from the dashboard include:

- **View messages** – You can view messages about pages you have published and/or un-published. The message includes the detail about the publishing function and indicates if any errors occurred during publishing. You will only see messages for files published with your login id.
**Restore deleted files** – Deleted files are stored in the Recycle Bin for 15 days. From the Dashboard, click on the Recycle Bin tab. You can restore a file to your site while it is still in the recycle bin by clicking on the restore icon in the Actions column. The file will be restored to the folder specified in the Original Location column.

![Recycle Bin screenshot](image)

**View draft versions** – You can verify which files you have saved as a draft. Click on the link for a draft to view it and to continue to create/edit the file.

**Navigation Menu**

Above the Dashboard area is the navigation menu.

- Use the System menu to search within your site(s).
- Click on the Home menu to return to the dashboard page that appears when you login.
- Use the New menu to create new assets such as a folder, page, or block and to import a file or create an external link.
- Use the History menu to view a list of, and navigate back to assets (pages/files) you have recently selected.
- Use the Tools menu to import a zip archive file.
Site Structure: Assets, Folders, Pages, and Files

Assets

An asset is anything you can create, edit and manage in Cascade. “Asset” is a term referring to a file, folder, block, or page in Cascade. You may work with the following assets in Cascade:

1. Page – indicates an html page.
2. File – created by an external program and imported for use in Cascade, may be a jpeg image, PDF file, or any other static content.
3. Block - a "pluggable" piece of content that can be easily substituted, into the right-hand related links area, the image rotation block, or the right callout area.
4. External Link - a symbolic link to a specific URL that links to a web page outside of your Cascade site. Used in the Related Links box, or the left-hand menu.
5. Folder - a container that holds other assets. All of the assets within a folder should be related to each other. For example, an image folder should only contain image files. Folders are used to create sub-navigation for your site or as containers for non-page assets (images, etc.).
6. Reference - a special asset that is used to get a link to a page that is not in a related folder to show up on the left hand navigation.

The asset tree displays a hierarchical view of the folders and files with your site’s content. All of the files in your site are located on the Cascade server.

Folders

Folders help keep your site organized by grouping similar items together. The Base Folder (represented as /) is the root level folder for your site. The Base Folder, along with the “_internal”, and “files” folders are typical folders on every site. The folder’s system name becomes part of the URL when published.

When a folder has a file in it named “index”, then the folder Title displays in the web page’s left-hand navigation menu.
Clicking on a folder name will reveal its contents in the asset tree and in the main view area. In the example below, clicking on the *files* folder and then on the *images* folder displays the contents of the images folder in the main view area.

Tip: If the folder you clicked on contains images, then clicking on the **Gallery** link will show thumbnails for each image.

**Pages**

Your site will have a Homepage (index file under the Base Folder) and a set of secondary pages. A standard format (template) is applied to each page which sets the page layout. You can add/change content on the page and control the display of the left–hand navigation and the right–hand sidebar.
Site Layout
Below is an example of a Secondary page (not a home page). A home page has an additional area for including an image banner or slide show at the top of the page.
Creating and Editing Content

Adding a New Page

When you want to add a new page, it is usually considered a unit secondary page. A standard format (template) is applied to each page which sets the page layout. You can add/change content on the page and control the display of the left-hand navigation and the right-hand sidebar.

Create and Name the Page

1. Select the folder in which you want to place your new page. Left-hand navigation is based on folder structure.
2. On the navigation menu select New > Unit Pages > Unit Secondary Page

3. Name your page and choose where to store it in your file directory:

   - **System Name** – This becomes the page name that appears in the URL. System name should be all lowercase without spaces. To separate words use a hyphen instead of an underscore character. If this is the first page in a new folder, you need to name it “index” in order for the folder’s Title to appear in the left-hand navigation of your page.
   - **Parent Folder** – the location in your Cascade file directory for the new page.

Inline Metadata

4. Set Display Name, Title and page layout options.
Display Name – appears in the page header, breadcrumbs, left-hand navigation menu and in the Related Links area if used there.

Title – displays on the title bar of the browser and is used by search engines.

Include in Navigation – Allows you to choose whether the page should be included in the left navigation of the page.

Display Right Sidebar – Select yes if you want to display the right sidebar. When you include a Related Links List, Related Pages, Related External Link, and/or Right Callout content in the Callout/Related >> Related links area, your page will display the information only if you select yes for this option.

Navigation Display – Controls whether or not the left navigation menu appears on the page.

Content

5. Use the WYSIWYG text edit area to enter your content.

6. Content – Enter the content you want to display on the main body of the page. This is a good place for commonly used links. For details on entering content and using Styles, see the Editing a Page section.
Callout/Related Links

7. Enter content for the Related Links and/or Callout area. Displaying a related links list or right hand Callout content is optional. This content displays on the right-hand side of your page if you selected Yes for the “Display Right Sidebar” option in the Inline Metadata area of your page.

You can include 3 types of content in a Related Links list:

- **Related Links List block** – this would be a block file that you previously created. The content of this file can be used on multiple pages by just selecting the block file for your Related Links on each page you want the content to appear. See instructions on creating a Related Links list block.

- **Related Page** – Point to any html page on your site.

- **Related External Link** – Point to an external link that you previously created. This is the way to include, in the Related Links list, a link to content that is not on your Cascade site.

Add, delete, and reorder content in your Related Links list:

- **Add content** - Browse for the block, page, or external link by clicking on the block, page, or external link icon, depending on what you are adding.
  - Select Browse and a chooser window will open. Use the folder listing to navigate to the page or file to which you want to link.
  - Click the button.

- **Add a row** - To add an additional row, click the plus button for the type of link you want to add.

- **Reorder** – Change the order of the links by using the up and down arrows next to the row specification (1/2). Moving the links up or down repositions them in the Related Links box. On your web page, links in a block file will display first in the Related Links box, then Related Pages, followed by Related External Links.

- **Delete** – To delete a row from the Related Links list click the minus sign button on the appropriate line. Clear the content on the line without removing the row by clicking on the clear selection icon.

See example on next page.
The Related Links list from the above example would look like this:

If you want to change an existing Related Links block file, see Adding or Changing a Related Links List Block.

Right Callout content displays on the right-hand side of the page. If you are displaying a Related Links list, then the Right Callout content will display under it. If there is no Related Links list on the page, then the Right Callout content will start at the top of the right-hand area.
Right Callout Heading – Enter text here if you want to include a heading for the content that you enter in the Right Callout WYSIWYG box.

Right Callout – Text and pictures entered here will display on the right-hand side of the page, below the Related Links box, if you selected Yes for the “Display Right Sidebar” option in the Inline Metadata area of your page. The width of the image in the Right Callout area cannot be wider than 175px.

Right Callout Block – If you want to repeat the Right Callout content on multiple pages, then you can create a Right Callout Block and insert it here.

Tabs
You can create tabbed content. Tabs are an optional way to display multiple topics of content on one page.

Example of how tabbed content appears on a web page:

8. Creating tabs
   - Click the Tabs button to expand the Tabs area.
• For Header, enter the text that you want to display as the tab label.
• In the Content area, enter the text, pictures, etc. that you want to include under this tab.
• Click the plus button to add another tab section.

• NOTE: When you view a page with Tabs in Cascade, you will only be able to see the content on the first tab. You have to publish the page and view it on the published site in order to see all content. You may want to publish to webdev to test how your tabbed content is working before you publish to the live site.
CTA Information

9. Add CTA information – Select Yes if you would like the Call To Action buttons to appear in the right hand column.

The request info, apply now and take a tour buttons will all appear. These buttons have the links indicated below associated with them. These buttons will stay visible as you scroll up and down the web page. Best practice is to *not display* a Related Links or Right Callout area if you are displaying the CTA buttons.

<table>
<thead>
<tr>
<th>CTA buttons</th>
<th>Button Links</th>
</tr>
</thead>
</table>
| REQUEST INFO    | Admissions undergraduate studies request page
| APPLY NOW       | Admissions Apply Now page: [http://www.umsl.edu/admissions/apply-now.html](http://www.umsl.edu/admissions/apply-now.html) |
| TAKE A TOUR     | Personal Tours form [http://forms.umsl.edu/tours/](http://forms.umsl.edu/tours/)                      |

Check Spelling

10. **Advanced Options – Check Spelling** - Click the Advanced Options link and click in the Spelling box to turn on spell check. Spelling for this page will be checked when you click the Submit button. The option does not stay checked. You have to select this option each time you submit the page if you want to check spelling.

Submit/Save Your Page

11. Click the [Submit](#) button. A new page will be created in Cascade and will be displayed in your file tree with its system name. You must [publish](#) your page in order for it to appear on the website.
Editing a Page

1. Select the page you want to edit, and then click the **Edit** tab.

2. You can edit the main content on the page, but you cannot edit the template areas. Use the **WYSIWYG toolbar options** to format text, add images, and to add/edit hyperlinks in the **Content** and **Right Callout** areas.

**WYSIWYG Text Edit Options**

| Insert custom characters (e.g., copyright symbols, accent marks, etc.) | Undo, redo |
| Apply subscript or superscript | Link, break link |
| Bold, italic, underline, strikethrough | Insert/edit anchor |
| Align left, center, right, full | Insert/edit image |
| Available text styles (controlled by the template) | Insert/edit embedded media |
| Cut | Insert a horizontal line |
| Copy | Insert/edit a table |
| Paste | Cleanup code |
| Paste as plain text | Removes formatting from a selection |
| Find/Replace | Edit HTML source code |
| Toggle Spell Checker | Show/hide guidelines and invisible elements |
| Bullets and numbering | Toggle full screen mode |
| Outdent, indent | |

3. Click **Submit** to save your changes. If you are not ready to keep these changes, you could click the **Save Draft** button and work with a draft of the page until you are ready to submit the page. You will have an option to discard the Draft version.

4. **Publish** your page. Publishing the file puts the file on the web server.
More About Links, Text Styles, and Images

Links
There are two types of links, internal and external. Internal links are links to pages or files within your Cascade site. External links are to pages outside of your site. To add or edit a link in the content area:

1. Highlight the text you want to make a link, and then click on the insert/edit link tool.
   a. Select Internal if you are pointing to a page or file within your folders (your site).
      i. Click on the browse icon.
      ii. A chooser window will open. Use the folder listing to navigate to the page or file you want to link to.*
      iii. Click the button.
      iv. In the Target box, select New Window if you want this page open in a new browser window.
   b. Select External if the link is not located on your site, or if you are creating a link to an email account.
      i. A Link box appears. Type (or copy/paste) the full URL for the external link (e.g. http://www.umsl.edu), or precede an email account with mailto: (e.g. mailto:brownma@umsl.edu)

2. If you are editing a link, click the button. If this is a new link, click the button.
*Note: If the file has not yet been imported to Cascade, see the Adding a File to Cascade section.

Text Styles
Use the Format drop-down list to select Heading 3 or Heading 4 to give emphasis to a section on your page. Due to the format of the template, avoid using Heading 1 and Heading 2.

1. Highlight the text that you want to change.
2. Select a format from the drop-down list.

In this example, the text “General Security Awareness” was changed to Heading 3:
Utilizing Styles
There are several pre-defined styles for adding buttons, alerts, and tables to your content area. For more information on utilizing styles, and for using the HTML editor to enter style tags, please see the style guide http://www.umsl.edu/~cmsusers/styleguide.html.

Creating Buttons
There are four color style options for buttons. To create a button:

1. Select the HTML editor.

2. In the HTML editor, enter `<button>`your text`</button>` at the position where you want the button to appear. Then click Insert.

For example, the HTML “<button>Apply</button>” produces the button in the example below.

3. The button can now be styled with one of 4 color options. In this example, the “Apply” button style will be used.

4. Highlight the text of your button, and then click on the “Styles” menu. From the drop-down choose “Button Button-Apply”.

---

January 2015
5. The button should now appear red with the text highlighted. Be sure the text is highlighted, and then **link the button text** by clicking the insert/edit link icon.

![Button Highlighted](image1.png)

6. Specify your link, and then click **Insert**. Your linked button will appear as below.

![Linked Button](image2.png)

**Alerts**

On alert box gives a filled background behind your text to make it stand out on the page. To create an alert box:

1. **Select the HTML editor.**

2. In the HTML editor, enter `<div>your text</div><br>` at the position where you want the alert to appear. Then click **Insert.**

![HTML Source Editor](image3.png)

3. Highlight the text inside your alert box then click on the “**Styles**” menu.

4. From the dropdown choose “alert alert-info” (to have a light blue background).
5. Your alert box text can be styled as usual (center text, bold, italic, etc.).

![Alert Box Example](https://example.com/alert.png)

**Note:** You can copy and paste the HTML from an alert example in the Style Guide located at [http://www.umsl.edu/~cmsusers/styleguide.html](http://www.umsl.edu/~cmsusers/styleguide.html).

**Images**

You can add an image to the Content or Right Callout area. *The width of the image in the Right Callout area cannot be wider than 175px.* To insert an image:

I. Place your cursor where you want to insert the image.

II. Click on the Insert/edit image tool.
   a. Select Internal if the image is located in a folder on your site.
      1. Click the browse icon.
      2. A chooser window will open. Use the folder listing to navigate to the image file (it should be in the files/images folder).*
      3. Click the Confirm button.
      4. Enter Alternate Text. This is the text that is used by screen reader software often used by visually impaired individuals. The text is usually a short description of the image.
      5. Check the box “This is a decorative image” if the image is for decorative purposes only and alternate text does not need to appear in place of the image.
   b. Select External to point to an image outside of your site.
      1. In the Image box, enter (or copy/paste) the URL for the image.
      2. Enter Alternate Text. This is the text that is used by screen reader software often used by visually impaired individuals. The text is usually a short description of the image.
      3. Check the box “This is a decorative image” if the image is for decorative purposes only and alternate text does not need to appear in place of the image.

III. If you are editing an image, click the **Update** button. If this is a new image, click the **Insert** button.

*Note: If the image file has not yet been imported to Cascade, see the Adding a File to Cascade section.*
Responsive Images

Images placed directly into your site’s content region are automatically responsive and will be scaled to the device screen size. At certain times, images are placed inside tables. The following will help correct unwanted results when images are inside tables.

After creating your table and entering your content, submit your edits and view your work.

Images are automatically resized in tables to fit the container the image is inside of. In the example above the image is at 100% of the table’s <td> width.

If the image appears at an undesired size, define the width of the table’s <td> tag with a percentage.

Your image will now take up 50% of the table’s overall width.
Publishing Your Content to UMSL’s Web Server

The process of publishing your page/file is what puts that content on the web server. Anytime you make a change to a page or file you need to publish it to the web server so that your additions/changes can be viewed on your live webpage. You can publish individual pages, folders, or your entire site. You can publish from the Publish tab or the View tab.

The Publish Tab

1. Highlight the page or folder that you want to publish.
   Note: Select Base Folder to publish your entire site.
2. Select the Publish tab.

3. The Publish option should be selected. The destinations that your content will be published to are “Live” (UMSL’s production website server) and “WebDev” (content only viewable on the test server site). If you selected a folder, then the entire content of that folder will be published. If you select Base Folder, then your entire website will be published.

4. Click the button. You should see Publish message sent successfully at the top of your Cascade window. It may take a few minutes before you can view your changes on the web. Be sure to refresh your browser page (Ctrl + R) in order to see the changes.
Publish from the View Tab

Another way to publish is from the View tab. Publishing this way allows you to view the progress of the publish function. You can choose to publish any combination of folders by selecting/unselecting content.

1. Highlight the page or folder that you want to publish (or select Base Folder to publish your entire site).
2. At the bottom of the file listing, click the All option. Then select the Publish option from the dropdown selection box. You can un-select any content that you do not want to publish.
3. Click Submit to confirm you want to publish this content.
4. You will see Queued Jobs (files waiting to be published) and Current Jobs (files being published). When all files are cleared from Queued and Current Jobs, then your content should be viewable on the live and webdev sites; however, publishing is not instantaneous, so it may take a few minutes before you see the updated content. Be sure to refresh your browser (Ctrl + R).

Publish Entire Site

If you add or remove a first level left-hand navigation option, or update the page footer block, then you must publish your entire site before the change will appear on the live website.

1. To publish your entire site, select the Base Folder at the top of your file list.
2. Then publish from the View or Publish tab as described above.

See next page for an example of selecting content and publishing an entire site from the View tab.
Publish to WebDev (test server)

If you do not want to publish content to the live web server, but you want to see what the content would look like (such as tabs) when it is published then you can choose to publish only to the test server named webdev.

The URL for your webdev site is typically the same as your live site, but with ~webdev preceding your site name. For example:

Live site:  http://www.umsl.edu/cashiers  
Webdev site:  http://www.umsl.edu/~webdev/cashiers

1. Highlight the page or folder that you want to publish (or select Base Folder to publish your entire site).
2. Click on the Publish tab.
3. Uncheck the box for the "live" Destination.
4. Click Submit.
Using Anchors
By including an anchor tag within a page, you can place links in the body of your page which, when clicked, allow the reader to jump to another location on the page.

Create the Anchor
1. Place the cursor in front of the text where you want to create an anchor.
2. Select the anchor icon in the text editor.
3. Name your anchor. Name must not contain spaces.

Link to the Anchor
1. Highlight the text you wish to link to your anchor.
2. Select the insert/edit link icon in the text editor.
3. In the “Anchor” field, type in the name of the anchor you wish to link to. (See example below)
4. Select “Insert.”
Editing the Footer and Tracking Visits to Your Site

You can edit the address and contact phone number information in the page footer. The footer is a block file which appears on all of your html pages, so changing and publishing the footer block file will update the footer for all of your pages. The footer file name is “site-nav” and is located in the root level (Base Folder) of your file tree. This footer file is also where you can copy a Google Analytics Tracking ID. Adding Google Analytics to your site will allow you to keep track of how many people are visiting your site, get information on which pages are most popular and see where users are clicking. Please refer to this separate documentation for information on using Google Analytics on your site.

1. Select the footer file, “site-nav” located at the root level of your file tree.
2. Click the **Edit** tab and update the address and phone number information as appropriate. The image below shows where the editable information appears in the footer.

![Footer Image]

3. Click the **Submit** button.

4. **Publish your entire site** to update the footer on all pages of the live site.

---

**Importing Files**

Best practice is to store all non-html files under the “files” folder. For example, PDF files should be stored in the “files/pdf” folder, and image files (JPG and GIF) in the “files/images” folder.

**Adding a File to Cascade**

Images and PDF documents are common examples of files you may use in your site. To upload a file to Cascade, follow these steps. To import several files at once, see the [Zip Archive](#) feature.

1. In the left hand file/asset tree click on the **files** folder, then click on the folder for the type of file you are going to upload. For example, select the images folder if you are uploading an image (jpg or gif) file.
2. On the navigation menu select **New > Default > File**
3. Click the **Browse** button to search for and select the file you are uploading, or drag and drop your file into the dotted line box.

4. **System Name** – If you already selected the file you want to import, then the System Name will be filled in with the file name. If necessary, change the system name to a URL friendly name. For example, remove all spaces and capital letters from the name. To separate words use a hyphen instead of an underscore character. Be sure to include the file extension with the name, otherwise you will not be able to view the file in your site.

5. **Parent Folder** - This indicates the folder where your file will be stored. If the location is not correct, click the folder icon to select the correct folder.

6. Click the **Submit** button.

7. A green bar will appear at the top of the window stating “Asset created successfully” and you will be viewing the file from the View tab.

8. **Publish** the file by clicking the Publish tab and then clicking the **Submit** button. Publishing the file puts the file on the web server.

---

**Replace/Update an Existing file**

If you need to replace an existing file with a new version of that file, follow the instructions below. If you need to delete a file, see the instructions for **Un-publish and Delete Files**. If you need to rename a file, see the instructions for **Renaming a File**.

1. **Select the file** that you want to replace and then click the **Edit** tab.
2. Click the **Browse** button to search for and select the file you are uploading, or drag and drop your file into the dotted line box. **NOTE:** You do not need to “name” the file. Since you are replacing an existing file in Cascade, the system name will remain the same, regardless of what the file name is of the file you are importing.
3. Click **Submit**.
4. Click the Publish tab and select the Publish option (should be selected by default). Click **Submit**.

**NOTE:** When you publish the new version of the file, any of your html pages that have a link to this file will automatically load the new file. You do not need to re-publish the html pages. You may need to clear your browsers cache to clear old history in order to see the new version of the file.

---

**Using Zip Archive**

If you have several files you need to import into Cascade you can put those files in a zipped folder and then import them into Cascade in one step instead of one at a time.

1. In Windows Explorer (where you view your folders and files), select the files you want to import to Cascade (using the Ctrl and Shift keys to select files as appropriate).
2. Right click on the selected files or folder and choose “Send To”, then “Compressed (zipped) folder.”
3. The zip archive folder will appear in the Windows folder you are working in.
4. In Cascade, from the file/asset tree, select **Tools** then **Zip Archive.**
5. For **Placement Folder**, click on the browse icon and select the folder you want your files to go into, (e.g. files/pdfs or files/images).
6. Click the **Confirm** button.
7. Click the **Browse** button to the right of the Zip Archive box and find your zipped folder you created in step 2.
8. Click the button.

Renaming a File

If you want to rename a file, be sure to un-publish it first, or to select un-publish as part of the rename process.
1. In the file tree, highlight the file you want to rename.
2. Click on the Move/Rename tab.
3. BE SURE TO CHECK THE BOX so that the current file name will be un-published (removed) from the server.
4. In the System Name box, make the correction to the file name. System names (except for External Links) should be all lowercase with no spaces. Use a hyphen to separate words.
5. Click the button.

Adding an External Link

An External Link points to a webpage that is outside of your Cascade site. Adding an external link to Cascade allows you to use the link in the Related Links list or block or in the left-hand menu.
1. In the left hand file/asset tree click on the files folder, then click on the external-links folder. OR, if you the External link to appear as a top level menu choice in the left-hand navigation menu, then select the Base Folder to store the extern link at the root level of your file tree.
2. On the navigation menu select New > Default > External Link.
3. On the Create tab, complete the following:
   a. System Name – The name you give your link is what will appear on the webpage. Use uppercase and spaces as appropriate.
   b. Parent Folder – This is the folder where the external link will be stored. If you plan to use the link in a Related Links list, then best practice is to store the file in the files/external-links folder. OR, if you want to link as a left-nav menu option, then choose the folder under which you want this link to be a second level menu option, or choose the Base/root folder if you want this link to be a first level menu option.
   c. Link - Enter the full URL of the external webpage. You can copy/paste the URL from a website.
   d. Click the button.
   e. A green bar will appear stating “Asset created successfully”.

Adding or Changing a Related Links List Block

If you want a Related Links block to appear on multiple pages in the right-hand column, then create a block file and point to it in the Callout/Related >> Related Links area on each page as a Related Links List. Your site may already have a related links list block.

Add a Related Links List Block:
2. On the New Block page enter a **System Name**. The default name is “untitled-related-links-list”. Change the word “untitled” to a relevant name (for example “admissions-related-links-list”). The system name becomes the file name for the block of links.

3. If the Parent Folder is not **files/blocks**, then click the browse icon to open the chooser window. Select the files/blocks folder and click the **Confirm** button.

4. In the Related Links section, click the page icon or external link icon to add a page or external link*

5. Navigate to the page or external link (under files/external-links) and select it, then click on the **Confirm** button.

6. Click the plus sign icon to add additional related pages or related external links.

7. If you have multiple links in your list, you can reorder them by using the up and down arrows next to the row specification (1/2). Related Pages will display first in the Related Links box, followed by Related External Links.

8. Click the **Submit** button.

*Note: If the related external link has not yet been created in Cascade, see the Adding an External Link section.

**Change a Related Links List Block**

1. Navigate to the block file you want to change. It should be in the **files/blocks** folder.

2. Click the **Edit** tab.

3. In the **Related Links** section, click the plus sign icon to add an additional related page or related external link*

4. On the new line, browse for the page or link by clicking on the page or external file icon, depending on what you are adding.

5. Navigate to the page or external link (under files/external-links) and select it, then click the **Confirm** button.

6. If you have multiple links in your list, you can reorder them by using the up and down arrows next to the row specification (1/2). Related Pages will display first in the Related Links box, followed by Related External Links.

7. **To delete a page or related link** from the block, click the minus sign icon.

8. Click the **Submit** button.

9. Publish the page(s) that use this block file.

*Note: If the related external link has not yet been created in Cascade, see the Adding an External Link section.
Adding or Changing a Right Column Callout Block

Right Callout content displays on the right-hand side of the page. If you are displaying a Related Links list, then the Right Callout content will display under it. If there is no Related Links list on the page, then the Right Callout content will start at the top of the right-hand area. If you want the same content to appear in the right-hand column on multiple pages, then create a right column callout block file.

Add a Right Column Callout Block:
2. On the New Block page enter a System Name. The default name is “xhtml-block”. Type a new name (for example “admissions-right-callout”). The system name becomes the file name for the block.
   • Enter your content (text, links, images, etc.). Note: The width of an image in the Right Callout area cannot be wider than 175px.
3. Click the Submit button.

Change a Right Column Callout Block
1. Navigate to the block file you want to change. It should be in the files/blocks folder.
2. Click the Edit tab.
3. Make your changes to the content.
4. Click the Submit button.
5. Publish the page(s) that use this block file.

Creating a New Folder
If you are adding new content to your site that does not relate to existing content, then you want to create a new folder to keep all the like content together. If you want to create a new first level left menu option, the folder’s title will be what appears in the left menu. In order for the folder title to appear in the left menu, you must have an html page named “index” in the folder. The folder’s system name becomes part of the URL name. Follow the steps below to create a new folder.

1. On the navigation menu select New > Unit Pages > Unit Folder

   ![Navigation Menu Screenshot](image_url)

   1. On the System tab enter the following:
      a. System Name - Type a name for the folder. The name should be in all lowercase with no spaces in the name. To separate words in the name, use a hyphen (-) and not an underscore (_). Give it a name that makes sense for the page it takes you to. The folder system name becomes part of the URL.
b. **Parent Folder** – This is the location in Cascade (your file tree) where the folder will be located. To change the folder location, click on the browse icon and select a new location from the chooser.

c. **Title** - This is the name that will appear in left-hand navigation menu if you add a file named “index” to this folder.

d. **Publish** - This determines whether the folder will be published.

e. **Indexing** - This determines whether the folder will be indexed for dynamic navigation.

3. Click the **Submit** button.

### Creating References

Using a Reference gives you a way to get a link for a page, which is not in the folder, to show up on the left hand navigation under this folder title. In the example below, the page “travel-expenses” is in the “about” folder. To have a link to the “travel-expenses” page show as a sub-navigation option under Workshops on the left-hand menu, a reference to the travel-expense page was created in the “workshop” folder. The icon indicates a reference.

To create a reference:

1. Navigate to the page you want to create a Reference for. In the above example, that would have been “about/travel-expenses”.
2. Click on the **More** tab, and from the pop-up menu select **Reference**.
3. Enter a System Name, or just leave it default to the original name. This is the name that will appear in the file tree.
4. Parent Folder is the location where the reference will be located. Click on the browse icon and select the appropriate folder location. Then click the **Confirm** button.
5. Click the **Submit** button.
6. Click on the index page in the folder in which you placed the reference to verify that a link to the referenced page appears in the left menu. In the example above, that would have been the “workshops” folder.
7. **Publish** the folder by selecting the folder, then clicking the Publish tab and then clicking the **Submit** button.
Un-publish and Delete Files

Un-publishing a page will remove it from the live website. You should always un-publish a page before you delete the page. There may also be occasions when you want to un-publish a page from the website, but still keep it in Cascade so that you can have it for reference in the future.

Un-publish a file

1. Select the page or folder that you want to un-publish.
2. Click on the Publish tab.
3. For Publish Mode, select Un-publish.
4. Click the Submit button.

Delete a file or folder

Deleting a file removes it from the Cascade server. You must first un-publish the file (or select to up-publish the file as part of the delete function) in order to remove the file from the web server and your live website.

1. In the menu navigation area, select the file you want to delete.
2. Click on the More tab to view additional options and select Delete.
3. BE SURE TO SELECT THE BOX TO UN-PUBLISH CONTENT.
4. Click the Submit button.
Restoring Previous Version of Page

Each time you submit a page that you are editing, a version of that page is saved. You can restore a previous version of a page (up to 20 versions are saved).

1. Highlight the page in the file tree for which you want to restore a previous version.
2. Select the More Tab and then click on Versions.
3. Select the version you think you want to restore by clicking on the file name in that line.
4. You will be viewing that version of the page. If this is the version you want to restore, click the Activate link. Or select to view additional versions by clicking on the Newer or Older links.
Reordering Left Hand Navigation

You can change the order in which your left-hand menu navigation options appear on your website. To reorder the main level left-hand navigation:

1. Select the Base Folder.
2. You will see your folders and files listed in the main view area; use the arrows in the Actions columns to change the Order number. You can sort by Order number by clicking the column name “Order”. Some folders, such as the “_internal”, and “files” folders do not display in the left navigation, so their position numbers are not relevant to the ordering.
3. Select the Publish tab. You must publish your entire site if you modify the left menu’s first navigation level.
4. Click the Submit button on the Publish page.

Reorder Sub-navigation

1. Select the folder name. You will see your files in the main view area.
2. Repeat steps 2-4 above.
Image Rotation Block
An image rotation block is a file of banner sized images (910x285) that you can use on a home page template. Each time your web page is loaded/refreshed in the browser, a random image from your block is displayed.

Using the Image Library
The Image Library contains usable banner images for your website. You may use any of these images to construct a custom image rotation block. You may also use your own images, but the image library is a ready supply of photos for you to use. If you use your own images, you need to size them to 910x285.

Coping Images from the Image Library
The following instructions assume that you are using images from the Image Library. If you are only using your own images or if you are deleting some images from your block, then you do not need to start from the Image Library and can skip to the Building an Image Rotation Block section.

The Image Library is a site that is available to you in the site-chooser drop-down box.

1. At the top left of the Cascade window you will see the site-chooser drop-down box. Click in the site chooser box and select “Image Library”. To use images from the Image Library, you should first copy the appropriate images to your site.
   a. Select a folder in the asset tree. To preview the images, click the Gallery link.
   b. Make note of the image files that you want to copy to your site, and then click on the image folder name to get a file listing in the main content window.

![Image Library](image.png)
c. Select images by putting a checkmark in the box(es) to the left of the image name(s).

d. Scroll to the bottom of the page and click in the With Selected box. From the drop-down list, click on Copy.

e. You receive a screen to confirm where you want to copy your images. Click on the browse icon to change copy locations.

The chooser window opens:
f. To copy the images from the Image Library to a folder on your site you must first select your site from the site selection drop-down box at the top of the window.

![Image of Cascade Server interface]

Choose the folder you want to copy the images to on your site. Probably the files/images folder. Then click the Confirm button.
Building an Image Rotation Block

1. If you want to preview the images before starting to build your rotation block, click on the folder that contains the images, and then click the Gallery tab to view small versions of each image file. You can make note of the ones you want to add to your image block.

2. To make a new image rotation block, select New > Blocks > Image Rotation Block.

3. On the New Block, Create screen, enter a System Name to name your image rotation block file. You should keep the “image-rotation” part of the name so that you can easily distinguish the image rotation block from other blocks. For example, change the system name to “philosophy-image-rotation”.

   **Note:** Please see the screen shots on the next page that corresponds with steps 3-5, and 7.

4. The Parent Folder should be the folder where you store your block files (probably files/blocks). Change the parent folder if necessary by clicking on the browse icon and selecting the appropriate folder.

5. In the Image Rotation area, add your first image by clicking the browse icon.

6. On the choose a file screen, click on the folder where your images are stored, (probably files/images) and select a photo you want to add to your image block. A sample of the photo will be displayed. To select this photo, click the button.

7. Add another image to the block by clicking on the plus button and then clicking the browse icon in the new row. Select a photo as explained in step 6.

8. Repeat steps 6 and 7 until you have added all the photos you want in your image rotation block.
9. Click the **Submit** button to save your block file.

**Assigning an Image Rotation Block to Your Home Page**

1. To assign an image rotation block to your home page, select your site and then **select your home index page**.
2. Click the **Edit** tab.
3. Toward the bottom of the Edit window you will see an area for “Images” (below the right hand callout section). Click on the browse icon in the block row under Image Rotation Block.
4. In the Choose window, navigate to your image rotation block file (should be under files/blocks), and select the appropriate image rotation block file.

5. Click the **Confirm** button. You will see your image rotation file listed next to the block icon.

6. Click the **Submit** button. The image rotation block will now be assigned to your index page.

7. Publish your index page. The banner will now automatically cycle through the images you selected.